aboutsummaryrefslogtreecommitdiff
path: root/java/jdk13
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2002-08-05 18:19:58 +0000
committerGreg Lewis <glewis@FreeBSD.org>2002-08-05 18:19:58 +0000
commitcbf822470972089f66eee40852ae031cbc081d4f (patch)
tree72d9a20b23805d7db6f0ac39044339ec8e19708e /java/jdk13
parent3341a3cd35974d77fb245c48d3d8fb3c0fef09de (diff)
downloadports-cbf822470972089f66eee40852ae031cbc081d4f.tar.gz
ports-cbf822470972089f66eee40852ae031cbc081d4f.zip
Notes
Diffstat (limited to 'java/jdk13')
-rw-r--r--java/jdk13/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/java/jdk13/Makefile b/java/jdk13/Makefile
index dbf1c7ba5b51..c9cf50626a3d 100644
--- a/java/jdk13/Makefile
+++ b/java/jdk13/Makefile
@@ -17,7 +17,6 @@ MAINTAINER= glewis@FreeBSD.org
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
zip:${PORTSDIR}/archivers/zip \
- gtar:${PORTSDIR}/archivers/gtar \
${X11BASE}/lib/libMrm.a:${PORTSDIR}/x11-toolkits/open-motif
.if !defined(NATIVE_BOOTSTRAP)
BUILD_DEPENDS+= ${JDK13DIR}/bin/javac:${PORTSDIR}/java/linux-sun-jdk13
@@ -63,7 +62,6 @@ ALL_TARGET= all plugin images
.else
ALL_TARGET= all images
.endif
-TAR= gtar # Necessary for proper extraction of sources
PLIST_SUB+= JDK_VERSION=${JDK_VERSION}
JDKIMAGEDIR= ${WRKSRC}/../build/bsd-i386/jdk-image-i386
@@ -98,6 +96,11 @@ IGNORE= "You can not legally distribute pre-compiled binaries"
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 460101 || ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500038 )
+BUILD_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
+TAR= gtar # Necessary for proper extraction of sources
+.endif
+
.for file in ${DISTFILES}
.if !exists(${DISTDIR}/${file})
IGNORE=You must manually fetch the source distribution and FreeBSD patches (${DISTFILES}) from http://www.sun.com/software/java2/download.html and http://www.eyesbeyond.com/freebsddom/java/jdk13.html, place it in ${DISTDIR} and then run make again