aboutsummaryrefslogtreecommitdiff
path: root/java/jdk15
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2002-08-06 16:36:21 +0000
committerGreg Lewis <glewis@FreeBSD.org>2002-08-06 16:36:21 +0000
commitdca45b0ea445f1f4e606edb4ae96d4f7b70863a7 (patch)
tree944ae1de3e7d9bf74853aad0cef9fbfd4270a3f0 /java/jdk15
parent15b59d045bdb5b04347897f1eec67508eca3e967 (diff)
downloadports-dca45b0ea445f1f4e606edb4ae96d4f7b70863a7.tar.gz
ports-dca45b0ea445f1f4e606edb4ae96d4f7b70863a7.zip
Notes
Diffstat (limited to 'java/jdk15')
-rw-r--r--java/jdk15/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index c9cf50626a3d..d66e332faf9b 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -132,6 +132,15 @@ pre-build:
echo "This is known to cause problems during bootstrapping."; \
exit 1; \
fi
+ @if [ `sysctl -n compat.linux.osname` != "Linux" ]; \
+ then \
+ echo "Please set the value of the sysctl compat.linux.osname"; \
+ echo "to 'Linux' with the command:"; \
+ echo " sysctl compat.linux.osname=Linux"; \
+ echo "Having it set to other values, such as 'FreeBSD',"; \
+ echo "is known to cause problems during bootstrapping."; \
+ exit 1; \
+ fi
.endif
post-build: