aboutsummaryrefslogtreecommitdiff
path: root/java/jdk15
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2005-09-04 14:31:32 +0000
committerGreg Lewis <glewis@FreeBSD.org>2005-09-04 14:31:32 +0000
commita2fb4348330018a6a52cb60e83e1fbef37fe430b (patch)
treecfaa47d1e46e109b5fff89ef3dc47cd5845123ce /java/jdk15
parent24aa3e3720cdb7c1e69ea6f0a9c199ac16c57d0e (diff)
downloadports-a2fb4348330018a6a52cb60e83e1fbef37fe430b.tar.gz
ports-a2fb4348330018a6a52cb60e83e1fbef37fe430b.zip
Notes
Diffstat (limited to 'java/jdk15')
-rw-r--r--java/jdk15/Makefile3
-rw-r--r--java/jdk15/files/pkg-install.in26
2 files changed, 18 insertions, 11 deletions
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index 9fecbd340c4f..e9dc343d6490 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -102,7 +102,8 @@ MAKE_ENV+= DONT_ENABLE_IPV6="YES"
ALL_TARGET= all
PLIST_FILES= jdk${JDK_VERSION}/jre/.systemPrefs/.system.lock \
- jdk${JDK_VERSION}/jre/.systemPrefs/.systemRootModFile
+ jdk${JDK_VERSION}/jre/.systemPrefs/.systemRootModFile \
+ jdk${JDK_VERSION}/jre/lib/${ARCH}/client/classes.jsa
PLIST_DIRS= jdk${JDK_VERSION}/jre/.systemPrefs
.if (${ARCH} == amd64)
diff --git a/java/jdk15/files/pkg-install.in b/java/jdk15/files/pkg-install.in
index fa980a9778f0..c85ac26b433d 100644
--- a/java/jdk15/files/pkg-install.in
+++ b/java/jdk15/files/pkg-install.in
@@ -1,19 +1,25 @@
#!/bin/sh
# System preference location
-PREFS_LOCATION=%%JRE_HOME%%
+JRE_HOME=%%JRE_HOME%%
-# Set up system preferences during post install
+# Post-install actions
if [ "$2" = "POST-INSTALL" ]; then
- if [ ! -d "${PREFS_LOCATION}/.systemPrefs" ] ; then
- mkdir -m 755 "${PREFS_LOCATION}/.systemPrefs"
+ # Set up system preferences
+ if [ ! -d "${JRE_HOME}/.systemPrefs" ] ; then
+ mkdir -m 755 "${JRE_HOME}/.systemPrefs"
fi
- if [ ! -f "${PREFS_LOCATION}/.systemPrefs/.system.lock" ] ; then
- touch "${PREFS_LOCATION}/.systemPrefs/.system.lock"
- chmod 644 "${PREFS_LOCATION}/.systemPrefs/.system.lock"
+ if [ ! -f "${JRE_HOME}/.systemPrefs/.system.lock" ] ; then
+ touch "${JRE_HOME}/.systemPrefs/.system.lock"
+ chmod 644 "${JRE_HOME}/.systemPrefs/.system.lock"
fi
- if [ ! -f "${PREFS_LOCATION}/.systemPrefs/.systemRootModFile" ] ; then
- touch "${PREFS_LOCATION}/.systemPrefs/.systemRootModFile"
- chmod 644 "${PREFS_LOCATION}/.systemPrefs/.systemRootModFile"
+ if [ ! -f "${JRE_HOME}/.systemPrefs/.systemRootModFile" ] ; then
+ touch "${JRE_HOME}/.systemPrefs/.systemRootModFile"
+ chmod 644 "${JRE_HOME}/.systemPrefs/.systemRootModFile"
+ fi
+
+ # Set up class data sharing
+ if [ -x "${JRE_HOME}/bin/java" ]; then
+ "${JRE_HOME}/bin/java" -Xshare:dump
fi
fi