aboutsummaryrefslogtreecommitdiff
path: root/java/jdk16-doc/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2007-08-19 20:22:13 +0000
committerGreg Lewis <glewis@FreeBSD.org>2007-08-19 20:22:13 +0000
commita1cf618ad19d2ffc44107ef56b2b06731341547c (patch)
treeb3da19c427e03493d657990de65a71fc38a26ec5 /java/jdk16-doc/Makefile
parent3540e3acd275af74343e883b48007ab2cbd26b37 (diff)
downloadports-a1cf618ad19d2ffc44107ef56b2b06731341547c.tar.gz
ports-a1cf618ad19d2ffc44107ef56b2b06731341547c.zip
Notes
Diffstat (limited to 'java/jdk16-doc/Makefile')
-rw-r--r--java/jdk16-doc/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/java/jdk16-doc/Makefile b/java/jdk16-doc/Makefile
new file mode 100644
index 000000000000..b5d7429fdcff
--- /dev/null
+++ b/java/jdk16-doc/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: jdk16-doc
+# Date created: August 18, 2007
+# Whom: Greg Lewis <glewis@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jdk-doc
+PORTVERSION= ${JDK_VERSION:S/_/./g}
+PORTREVISION= 1
+CATEGORIES= java
+MASTER_SITES= #
+DISTNAME= jdk-6-doc
+
+MAINTAINER= java@FreeBSD.org
+COMMENT= Java Development Kit ${JDK_MAJOR_VER} Documentation
+
+LATEST_LINK= jdk${JDK_CONCAT_VER}-doc
+DOCSDIR?= ${PREFIX}/share/doc/jdk${JDK_MAJOR_VER}
+NO_CDROM= "License does not allow distribution with fee."
+RESTRICTED= "This documentation is under license and export control."
+
+WRKSRC= ${WRKDIR}/docs
+JDK_VERSION= 1.6.0
+JDK_MAJOR_VER= ${JDK_VERSION:R}
+JDK_CONCAT_VER= ${JDK_MAJOR_VER:S/.//g}
+DOWNLOAD_URL= http://java.sun.com/javase/downloads/index.jsp
+
+NO_BUILD= yes
+USE_ZIP= yes
+PORTDOCS= *
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+IGNORE=You must manually fetch ${DISTNAME}${EXTRACT_SUFX} from ${DOWNLOAD_URL} by selecting the \"Download\" link for the \"Java SE 6 Documentation\", place it in ${DISTDIR} and then run make again
+.endif
+
+do-install:
+ @${ECHO} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}/ && ${COPYTREE_SHARE} \* ${DOCSDIR}/)
+ @${ECHO} " [ DONE ]"
+
+.include <bsd.port.post.mk>