aboutsummaryrefslogtreecommitdiff
path: root/java/jflex/files
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2004-12-20 14:36:39 +0000
committerHerve Quiroz <hq@FreeBSD.org>2004-12-20 14:36:39 +0000
commit958b51028ae38e3b73ddc77ae30bd2c3bdfff178 (patch)
tree3bc382de774d363ef92d1f68f7f5460ab85d670c /java/jflex/files
parent96281f84f1295719adf53cd3933b595791ed8014 (diff)
Notes
Diffstat (limited to 'java/jflex/files')
-rw-r--r--java/jflex/files/jflex.sh.in14
-rw-r--r--java/jflex/files/patch-Makefile7
-rw-r--r--java/jflex/files/patch-jflex68
3 files changed, 14 insertions, 75 deletions
diff --git a/java/jflex/files/jflex.sh.in b/java/jflex/files/jflex.sh.in
new file mode 100644
index 000000000000..7d90f63d7ab0
--- /dev/null
+++ b/java/jflex/files/jflex.sh.in
@@ -0,0 +1,14 @@
+#!/bin/sh
+#
+# Replacement for the script that came with JFlex
+# because bash is not necessarily on a FreeBSD
+# machine. Also, we know where the jar is.
+#
+# Conor McDermottroe <ports@mcdermottroe.com>
+#
+# $FreeBSD$
+
+# Allow the user to override where JFlex.jar lives
+JAVAJARDIR="${JAVAJARDIR:-"%%JAVAJARDIR%%"}"
+
+"%%LOCALBASE%%/bin/java" -jar "${JAVAJARDIR}/JFlex.jar" "$@"
diff --git a/java/jflex/files/patch-Makefile b/java/jflex/files/patch-Makefile
deleted file mode 100644
index 86a6f4679b92..000000000000
--- a/java/jflex/files/patch-Makefile
+++ /dev/null
@@ -1,7 +0,0 @@
---- src/Makefile.orig Mon May 3 23:23:09 2004
-+++ src/Makefile Mon May 3 23:20:03 2004
-@@ -0,0 +1,4 @@
-+# Makefile to wrap a call to ant
-+
-+all:
-+ ${SETENV} CLASSPATH=${DISTDIR}/JFlex.jar:${DISTDIR}/java_cup.jar:${JAVAJARDIR}/junit.jar:. ${LOCALBASE}/bin/ant jar
diff --git a/java/jflex/files/patch-jflex b/java/jflex/files/patch-jflex
deleted file mode 100644
index 3ea64aef137a..000000000000
--- a/java/jflex/files/patch-jflex
+++ /dev/null
@@ -1,68 +0,0 @@
---- bin/jflex.orig Mon May 3 23:06:29 2004
-+++ bin/jflex Mon May 3 23:11:12 2004
-@@ -1,51 +1,19 @@
--#! /bin/bash
-+#!/bin/sh
- #
--# JFlex start script $Revision: 2.0 $
-+# Replacement for the script that came with JFlex
-+# because bash is not necessarily on a FreeBSD
-+# machine. Also, we know where the jar is.
- #
--# if Java is not in your binary path, you need to supply its
--# location in this script. The script automatically finds
--# JFLEX_HOME when called directly, via binary path, or symbolic
--# link.
--#
--# Site wide installation: simply make a symlink from e.g.
--# /usr/bin/jflex to this script at its original position
--#
--#===================================================================
--#
--# configurables:
--
--# path to the java interpreter
--JAVA=java
--
--# end configurables
--#
--#===================================================================
--#
--
--# calculate true location
--
--PRG=`type $0`
--PRG=${PRG##* }
--
--# If PRG is a symlink, trace it to the real home directory
--
--while [ -L "$PRG" ]
--do
-- newprg=$(ls -l ${PRG})
-- newprg=${newprg##*-> }
-- [ ${newprg} = ${newprg#/} ] && newprg=${PRG%/*}/${newprg}
-- PRG="$newprg"
--done
--
--PRG=${PRG%/*}
--JFLEX_HOME=${PRG}/..
--
--# --------------------------------------------------------------------
-+# Conor McDermottroe <ports@mcdermottroe.com>
-
--export CLASSPATH
--CLASSPATH=$JFLEX_HOME/lib/JFlex.jar
-+# Allow the user to override where JFlex.jar lives
-+if [ -z "$JAVAJARDIR" ]; then
-+ JAVAJARDIR=%%JAVAJARDIR%%
-+fi
-
--$JAVA JFlex.Main $@
-+# Allow the user to specify which java interpreter to use
-+if [ -z "$JAVA" ]; then
-+ JAVA="`which javavm`"
-+fi
-
--#for more memory:
--#$JAVA -Xmx128m JFlex.Main $@
-+$JAVA -jar $JAVAJARDIR/JFlex.jar $@