aboutsummaryrefslogtreecommitdiff
path: root/java/jflex/files
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2004-05-10 18:38:26 +0000
committerMark Linimon <linimon@FreeBSD.org>2004-05-10 18:38:26 +0000
commitfcc83fd470fa9ecebd6b79f1cab39c6010378482 (patch)
tree9b315c729dacc1a3af3f712950e7bedd8f8dc74e /java/jflex/files
parent7938534b67aacd89f1cb398730ece06263a0502c (diff)
Notes
Diffstat (limited to 'java/jflex/files')
-rw-r--r--java/jflex/files/patch-Makefile30
-rw-r--r--java/jflex/files/patch-jflex27
2 files changed, 18 insertions, 39 deletions
diff --git a/java/jflex/files/patch-Makefile b/java/jflex/files/patch-Makefile
index 6ae7f7ad203f..86a6f4679b92 100644
--- a/java/jflex/files/patch-Makefile
+++ b/java/jflex/files/patch-Makefile
@@ -1,23 +1,7 @@
-$FreeBSD$
-
---- src/Makefile.orig Mon Oct 8 03:57:06 2001
-+++ src/Makefile Thu Feb 19 11:11:04 2004
-@@ -1,16 +1,14 @@
- # you need JFlex 1.2.2 and CUP 0.10j or later for this Makefile to work
-
- JFLEX = jflex -skel skeleton.nested
--CUP = java java_cup.Main
-+CUP = java -classpath ${JAVAJARDIR}/java_cup.jar java_cup.Main
-
--JAVAC = javac -target 1.1 -bootclasspath /usr/lib/jdk1.1/lib/classes.zip
- #JAVAC = jikes
--JAR = jar
-
- DEST = ../lib
-
- # jdk 1.2
--CLPATH = -classpath /usr/lib/java/jre/lib/rt.jar:.
-+CLPATH = -classpath ${JAVA_CLASSES}:.
-
- # jdk 1.1
- #CLPATH = -classpath /usr/lib/java/lib/classes.zip:.
+--- src/Makefile.orig Mon May 3 23:23:09 2004
++++ src/Makefile Mon May 3 23:20:03 2004
+@@ -0,0 +1,4 @@
++# Makefile to wrap a call to ant
++
++all:
++ ${SETENV} CLASSPATH=${DISTDIR}/JFlex.jar:${DISTDIR}/java_cup.jar:${JAVAJARDIR}/junit.jar:. ${LOCALBASE}/bin/ant jar
diff --git a/java/jflex/files/patch-jflex b/java/jflex/files/patch-jflex
index 29ddff094b62..3ea64aef137a 100644
--- a/java/jflex/files/patch-jflex
+++ b/java/jflex/files/patch-jflex
@@ -1,13 +1,14 @@
-$FreeBSD$
-
---- bin/jflex.orig Mon Oct 1 04:18:48 2001
-+++ bin/jflex Wed Feb 18 12:19:00 2004
+--- bin/jflex.orig Mon May 3 23:06:29 2004
++++ bin/jflex Mon May 3 23:11:12 2004
@@ -1,51 +1,19 @@
-#! /bin/bash
+#!/bin/sh
#
--# JFlex start script $Revision: 1.16 $
--#
+-# JFlex start script $Revision: 2.0 $
++# Replacement for the script that came with JFlex
++# because bash is not necessarily on a FreeBSD
++# machine. Also, we know where the jar is.
+ #
-# if Java is not in your binary path, you need to supply its
-# location in this script. The script automatically finds
-# JFLEX_HOME when called directly, via binary path, or symbolic
@@ -47,22 +48,16 @@ $FreeBSD$
-JFLEX_HOME=${PRG}/..
-
-# --------------------------------------------------------------------
--
++# Conor McDermottroe <ports@mcdermottroe.com>
+
-export CLASSPATH
-CLASSPATH=$JFLEX_HOME/lib/JFlex.jar
--
--$JAVA JFlex.Main $@
-+# Replacement for the script that came with JFlex
-+# because bash is not necessarily on a FreeBSD
-+# machine. Also, we know where the jar is.
-+#
-+# Conor McDermottroe <ports@mcdermottroe.com>
-+
+# Allow the user to override where JFlex.jar lives
+if [ -z "$JAVAJARDIR" ]; then
+ JAVAJARDIR=%%JAVAJARDIR%%
+fi
-+
+
+-$JAVA JFlex.Main $@
+# Allow the user to specify which java interpreter to use
+if [ -z "$JAVA" ]; then
+ JAVA="`which javavm`"