aboutsummaryrefslogtreecommitdiff
path: root/java/junit/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-11-03 17:49:59 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-11-03 17:49:59 +0000
commit48fceb85cf32a2521dedc0c7634a5f86c593515a (patch)
tree5af0b7d80d4c1e0a2f995c375fd6ac28b03c4bd0 /java/junit/Makefile
parent9cc2dd4c9f8d5f68218775d9a15c114afb2a1986 (diff)
Add JUnit, a regression testing utility for use with the Java(TM)
Language. PR: ports/22578 Submitted by: OKAZAKI Tetsurou <okazaki@be.to>
Notes
Notes: svn path=/head/; revision=34771
Diffstat (limited to 'java/junit/Makefile')
-rw-r--r--java/junit/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/java/junit/Makefile b/java/junit/Makefile
new file mode 100644
index 000000000000..643d51b95685
--- /dev/null
+++ b/java/junit/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: JUnit
+# Date created: Jun 15 1999
+# Whom: OKAZAKI Tetsurou
+#
+# $FreeBSD$
+#
+
+PORTNAME= junit
+PORTVERSION= 3.2
+CATEGORIES= java devel
+MASTER_SITES= http://www.xprogramming.com/ftp/TestingFramework/JUnit/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
+
+MAINTAINER= okazaki@be.to
+
+RUN_DEPENDS= ${LOCALBASE}/bin/javavm:${PORTSDIR}/java/javavmwrapper
+
+JDK_VERSION?= 1.1.8
+
+.if ${JDK_VERSION} == "1.1.8"
+RUN_DEPENDS+= ${LOCALBASE}/share/java/classes/jfc-1.1.1/swing.jar:${PORTSDIR}/java/jfc
+.endif
+
+FIND?= /usr/bin/find
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
+JUNIT_SUBDIR= ${PORTNAME}-${PORTVERSION}
+JUNIT_DESTDIR= ${PREFIX}/share/java/${JUNIT_SUBDIR}
+
+PLIST_SUB= JUNIT_SUBDIR=${JUNIT_SUBDIR}
+DATADIRS= doc javadoc junit vaj
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/java/classes ${JUNIT_DESTDIR}
+ cd ${INSTALL_WRKSRC}; \
+ ${INSTALL_DATA} junit.jar ${PREFIX}/share/java/classes; \
+ ${INSTALL_DATA} README.html ${JUNIT_DESTDIR}; \
+ ${INSTALL_DATA} src.zip ${JUNIT_DESTDIR}
+.if defined(DATADIRS)
+.for DIR in ${DATADIRS}
+ cd ${INSTALL_WRKSRC}; \
+ ${FIND} ${DIR} -type d -exec ${MKDIR} ${JUNIT_DESTDIR}/\{} \; ;\
+ ${FIND} ${DIR} -type f -exec ${INSTALL_DATA} \{} ${JUNIT_DESTDIR}/\{} \;
+.endfor
+.endif
+
+.include <bsd.port.mk>