aboutsummaryrefslogtreecommitdiff
path: root/java/langspec
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-10-18 21:57:27 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-10-18 21:57:27 +0000
commit7952dcb847eb6825dedefeef1cac5b974c5550f2 (patch)
tree76a66d71a709274eb9aece274932468a3274c237 /java/langspec
parent0d50bf886c30801a94ab907a33b092c0b0eded94 (diff)
downloadports-7952dcb847eb6825dedefeef1cac5b974c5550f2.tar.gz
ports-7952dcb847eb6825dedefeef1cac5b974c5550f2.zip
Notes
Diffstat (limited to 'java/langspec')
-rw-r--r--java/langspec/Makefile29
-rw-r--r--java/langspec/distinfo2
-rw-r--r--java/langspec/pkg-descr7
3 files changed, 38 insertions, 0 deletions
diff --git a/java/langspec/Makefile b/java/langspec/Makefile
new file mode 100644
index 000000000000..f1bff7bea296
--- /dev/null
+++ b/java/langspec/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: langspec
+# Date created: 18 October 2004
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= langspec
+PORTVERSION= 2.0
+CATEGORIES= java
+MASTER_SITES= ftp://ftp.javasoft.com/docs/specs/ \
+ http://java.sun.com/docs/books/jls/second_edition/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.html
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= The Java Language Specification
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}
+PORTDOCS= *
+
+do-install:
+ @${ECHO} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
+ @${CP} -R ${WRKSRC}/* ${DOCSDIR}
+ @${ECHO} " [ DONE ]"
+
+.include <bsd.port.mk>
diff --git a/java/langspec/distinfo b/java/langspec/distinfo
new file mode 100644
index 000000000000..15ec54861ccd
--- /dev/null
+++ b/java/langspec/distinfo
@@ -0,0 +1,2 @@
+MD5 (langspec-2.0.html.tar.Z) = 32ee43d9b2f89e3cff262a9595923bef
+SIZE (langspec-2.0.html.tar.Z) = 573151
diff --git a/java/langspec/pkg-descr b/java/langspec/pkg-descr
new file mode 100644
index 000000000000..23b73bec086c
--- /dev/null
+++ b/java/langspec/pkg-descr
@@ -0,0 +1,7 @@
+The Java Language Specification. This book attempts a complete specification
+of the syntax and semantics of the language.
+
+WWW: http://java.sun.com/docs/books/jls/index.html
+
+- Alex Dupre
+ale@FreeBSD.org