aboutsummaryrefslogtreecommitdiff
path: root/java/mx4j
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-02-20 23:01:02 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-02-20 23:01:02 +0000
commit4313297a0cee172da6abc7bc58913b6cb9377da2 (patch)
treef9cbf5203aad5ef2e32f4592bcc8394526033894 /java/mx4j
parent7f07af37d66a7436c42bba26ee7752e0b22eaa30 (diff)
downloadports-4313297a0cee172da6abc7bc58913b6cb9377da2.tar.gz
ports-4313297a0cee172da6abc7bc58913b6cb9377da2.zip
Notes
Diffstat (limited to 'java/mx4j')
-rw-r--r--java/mx4j/Makefile61
-rw-r--r--java/mx4j/distinfo2
-rw-r--r--java/mx4j/pkg-descr12
3 files changed, 75 insertions, 0 deletions
diff --git a/java/mx4j/Makefile b/java/mx4j/Makefile
new file mode 100644
index 000000000000..5eb28a996d4a
--- /dev/null
+++ b/java/mx4j/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: mx4j
+# Date created: 16 Jan 2005
+# Whom: Filippo Natali <filippo@widestore.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mx4j
+PORTVERSION= 2.1.1
+CATEGORIES= java devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= filippo@widestore.net
+COMMENT= Open Source implementation of the Java Management Extensions (JMX)
+
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+JARFILES= mx4j-examples.jar mx4j-impl.jar mx4j-jmx.jar \
+ mx4j-remote.jar mx4j-rimpl.jar mx4j-rjmx.jar \
+ mx4j-soap.war mx4j-tools.jar mx4j.jar
+
+PLIST_FILES= ${JARFILES:S,^,%%JAVAJARDIR%%/,}
+NO_BUILD= yes
+
+post-extract:
+ @${FIND} -s -d ${WRKSRC}/examples -type d -exec ${RMDIR} {} \; >/dev/null 2>&1 || true
+
+do-install: do-install-jar do-install-javadoc
+
+do-install-jar:
+ @${ECHO_MSG} -n ">> Installing .jar files..."
+ @for jarfile in ${JARFILES}; do \
+ ${INSTALL_DATA} ${WRKSRC}/lib/$$jarfile ${JAVAJARDIR} ; \
+ done
+ @${ECHO_MSG} " [DONE]"
+
+do-install-javadoc:
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @cd ${WRKSRC}/docs \
+ && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${ECHO_MSG} " [DONE]"
+ @${ECHO_MSG} -n ">> Installing examples in ${EXAMPLESDIR}..."
+ @cd ${WRKSRC}/examples \
+ && ${FIND} . -type d -exec ${MKDIR} ${EXAMPLESDIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/{} \;
+ @${ECHO_MSG} " [DONE]"
+ @${FIND} -s ${WRKSRC}/examples -not -type d \
+ | ${SED} -ne 's,^${WRKSRC}/examples,${EXAMPLESDIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s -d ${WRKSRC}/examples -type d \
+ | ${SED} -ne 's,^${WRKSRC}/examples,@dirrm ${EXAMPLESDIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.mk>
diff --git a/java/mx4j/distinfo b/java/mx4j/distinfo
new file mode 100644
index 000000000000..faefaa78959f
--- /dev/null
+++ b/java/mx4j/distinfo
@@ -0,0 +1,2 @@
+MD5 (mx4j-2.1.1.tar.gz) = 0b5ce38677e3cd56bbd80e272ff7661b
+SIZE (mx4j-2.1.1.tar.gz) = 4587837
diff --git a/java/mx4j/pkg-descr b/java/mx4j/pkg-descr
new file mode 100644
index 000000000000..9fd880665f44
--- /dev/null
+++ b/java/mx4j/pkg-descr
@@ -0,0 +1,12 @@
+MX4J is a project to build an Open Source implementation of the
+Java(TM) Management Extensions (JMX) and of the JMX Remote API
+(JSR 160) specifications, and to build tools relating to JMX.
+
+JMX is an optional package for J2SE that provides a standard
+way to manage applications. It can also be used to wrap legacy
+systems and provide a standard interface to the outside world,
+enabling the development of web services. JMX allows developers
+to write more modular and loosely coupled system components and
+reduce the complexity of large, interoperating systems.
+
+WWW: http://mx4j.sourceforge.net