aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk11/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2022-02-09 04:42:45 +0000
committerGreg Lewis <glewis@FreeBSD.org>2022-02-09 04:45:06 +0000
commit846ff4e9529104b008946f89b9fb3d3a27c13773 (patch)
treef5189e974956591632d50666bcd8cff3893625a7 /java/openjdk11/Makefile
parent691035521a23921508e467d0edc3cc4f97b7c4f8 (diff)
downloadports-846ff4e9529104b008946f89b9fb3d3a27c13773.tar.gz
ports-846ff4e9529104b008946f89b9fb3d3a27c13773.zip
Diffstat (limited to 'java/openjdk11/Makefile')
-rw-r--r--java/openjdk11/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/java/openjdk11/Makefile b/java/openjdk11/Makefile
index dafdc32fb27e..5537b8b3dbb0 100644
--- a/java/openjdk11/Makefile
+++ b/java/openjdk11/Makefile
@@ -142,7 +142,12 @@ CONFIGURE_ARGS+= --with-extra-ldflags="-Wl,-rpath=${LOCALBASE}/lib/gcc${GCC_DEFA
.else
MAKE_ENV+= USE_CLANG=true
.if ${COMPILER_VERSION} >= 130
-CONFIGURE_ARGS+= --with-extra-cflags="-Wno-unused-but-set-parameter"
+# PR258954: OpenJDK <= 13 crash due to undefined behavior with clang >= 13
+# See also https://bugs.openjdk.java.net/browse/JDK-8229258
+LLVM_VER= 12
+BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
+CC= ${LOCALBASE}/bin/clang${LLVM_VER}
+CXX= ${LOCALBASE}/bin/clang++${LLVM_VER}
.endif
.endif