aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk7
diff options
context:
space:
mode:
authorAlan Somers <asomers@FreeBSD.org>2016-12-09 20:30:53 +0000
committerAlan Somers <asomers@FreeBSD.org>2016-12-09 20:30:53 +0000
commit7bcea9568e7bc5b3879273b4aa7ce1de14c129bc (patch)
treeb2cd3f51249f5082e509e4dda629debcf18fa1bb /java/openjdk7
parentf2cd7a2efd9ddd1fd4157b4e0107f06c27c08e4b (diff)
downloadports-7bcea9568e7bc5b3879273b4aa7ce1de14c129bc.tar.gz
ports-7bcea9568e7bc5b3879273b4aa7ce1de14c129bc.zip
Notes
Diffstat (limited to 'java/openjdk7')
-rw-r--r--java/openjdk7/Makefile22
1 files changed, 18 insertions, 4 deletions
diff --git a/java/openjdk7/Makefile b/java/openjdk7/Makefile
index b4df2b8027dc..c835fe57969b 100644
--- a/java/openjdk7/Makefile
+++ b/java/openjdk7/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openjdk
PORTVERSION= ${JDK_MAJOR_VERSION}.${PORT_MINOR_VERSION}.${PORT_BUILD_NUMBER}
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= java devel
MASTER_SITES= http://download.java.net/openjdk/jdk${JDK_MAJOR_VERSION}u${JDK_MINOR_VERSION}/promoted/b${JDK_BUILD_NUMBER}/ \
@@ -41,11 +41,25 @@ LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}
USES= compiler dos2unix iconv gmake zip
-USE_XORG+= x11 xext xi xrender xt xtst
+# Even when not building with X11 support, openjdk7 requires Xrender, X11, and
+# Xt headers.
+X11_BUILD_DEPENDS_OFF+= ${LOCALBASE}/libdata/pkgconfig/x11.pc:x11/libX11
+X11_BUILD_DEPENDS_OFF+= ${LOCALBASE}/libdata/pkgconfig/xext.pc:x11/libXext
+X11_BUILD_DEPENDS_OFF+= ${LOCALBASE}/libdata/pkgconfig/xrender.pc:x11/libXrender
+X11_BUILD_DEPENDS_OFF+= ${LOCALBASE}/libdata/pkgconfig/xt.pc:x11-toolkits/libXt
+# Add more X11 build deps and runtime deps when X11 is enabled
+X11_LIB_DEPENDS+= libX11.so.6:x11/libX11
+X11_LIB_DEPENDS+= libXext.so.6:x11/libXext
+X11_LIB_DEPENDS+= libXi.so.6:x11/libXi
+X11_LIB_DEPENDS+= libXrender.so.1:x11/libXrender
+X11_LIB_DEPENDS+= libXt.so.6:x11-toolkits/libXt
+X11_LIB_DEPENDS+= libXtst.so.6:x11/libXtst
+X11_MAKE_ENV_OFF= BUILD_HEADLESS_ONLY=1
+
MAKE_ARGS= CC=${CC:Q} CXX=${CXX:Q} HOST_CC=${CC:Q}
-OPTIONS_DEFINE= POLICY TZUPDATE
-OPTIONS_DEFAULT= POLICY TZUPDATE
+OPTIONS_DEFINE= POLICY TZUPDATE X11
+OPTIONS_DEFAULT= POLICY TZUPDATE X11
DEBUG_DESC= Enable extra debugging info
POLICY_DESC= Install the Unlimited Strength Policy Files
TZUPDATE_DESC= Update the time zone data