aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk7
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2012-12-25 20:49:55 +0000
committerGreg Lewis <glewis@FreeBSD.org>2012-12-25 20:49:55 +0000
commitc15a9595f108d06194d64334ab2305a0fe7d8469 (patch)
treebae5d8909fcfffda584ead0343b37074e57395e4 /java/openjdk7
parentf51df0f37afc2a870a1799748028797c7a0ea063 (diff)
Notes
Diffstat (limited to 'java/openjdk7')
-rw-r--r--java/openjdk7/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/java/openjdk7/Makefile b/java/openjdk7/Makefile
index bf9f19c6cb9b..424f6e427dc3 100644
--- a/java/openjdk7/Makefile
+++ b/java/openjdk7/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openjdk
PORTVERSION= ${JDK_MAJOR_VERSION}.${PORT_MINOR_VERSION}.${PORT_BUILD_NUMBER}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= java devel
MASTER_SITES= http://download.java.net/openjdk/jdk${JDK_MAJOR_VERSION}u${JDK_MINOR_VERSION}/promoted/b${JDK_BUILD_NUMBER}/ \
http://download.java.net/jaxp/1.4.5/:jaxp \
@@ -60,7 +60,8 @@ LIB_DEPENDS+= freetype:${PORTSDIR}/print/freetype2 \
BUILD_DEPENDS+= zip:${PORTSDIR}/archivers/zip \
unzip:${PORTSDIR}/archivers/unzip \
${LOCALBASE}/include/cups/cups.h:${PORTSDIR}/print/cups-client
-RUN_DEPENDS+= javavm:${PORTSDIR}/java/javavmwrapper
+RUN_DEPENDS+= javavm:${PORTSDIR}/java/javavmwrapper \
+ ${LOCALBASE}/lib/X11/fonts/dejavu:${PORTSDIR}/x11-fonts/dejavu
OPENJDK_OSARCH= bsd-${ARCH:S/i386/i586/}
INSTALLDIR= ${PREFIX}/${PORTNAME}${JDK_MAJOR_VERSION}