aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk8/Makefile
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2015-05-19 22:13:51 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2015-05-19 22:13:51 +0000
commit75c6d35b751e3ffd470a051d811541b8fac8df20 (patch)
treef0d9ee04668d909f2e2b940a1914689584772536 /java/openjdk8/Makefile
parent018bf00de880ddfe83e9dca654377e81ad454e68 (diff)
downloadports-75c6d35b751e3ffd470a051d811541b8fac8df20.tar.gz
ports-75c6d35b751e3ffd470a051d811541b8fac8df20.zip
Notes
Diffstat (limited to 'java/openjdk8/Makefile')
-rw-r--r--java/openjdk8/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/java/openjdk8/Makefile b/java/openjdk8/Makefile
index 3b0f337f23ed..6a7d07d30090 100644
--- a/java/openjdk8/Makefile
+++ b/java/openjdk8/Makefile
@@ -2,6 +2,7 @@
PORTNAME= openjdk
PORTVERSION= ${JDK_MAJOR_VERSION}.${JDK_UPDATE_VERSION}.${JDK_BUILD_NUMBER:S/^0//}
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= http://download.java.net/openjdk/jdk${JDK_MAJOR_VERSION}/promoted/b${DIST_BUILD_NUMBER}/:jdk \
https://adopt-openjdk.ci.cloudbees.com/job/jtreg/${JTREG_JENKINS_BUILD}/artifact/:jtreg \
@@ -27,6 +28,7 @@ RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper \
USES= compiler:features dos2unix gmake iconv pkgconfig \
shebangfix
+USE_AUTOTOOLS= autoconf
USE_XORG= x11 xext xi xrender xt xtst
GNU_CONFIGURE= yes
@@ -116,6 +118,7 @@ CONFIGURE_ARGS+= --disable-ccache \
--with-giflib=system \
--with-jobs=${MAKE_JOBS_NUMBER} \
--with-milestone=fcs \
+ --with-package-path=${LOCALBASE} \
--with-zlib=system
CONFIGURE_SCRIPT= ../../configure
CONFIGURE_WRKSRC= ${WRKSRC}/common/autoconf
@@ -182,6 +185,11 @@ BOOTSTRAPJDKDIR?= ${LOCALBASE}/openjdk7
BUILD_DEPENDS+= ${BOOTSTRAPJDKDIR}/bin/javac:${PORTSDIR}/java/openjdk7
.endif
+# PR193009: work around the rtld bug
+#.if ${OSVERSION} < 1001511
+CONFIGURE_ARGS+= --enable-static-libjli
+#.endif
+
.if ${COMPILER_TYPE} == clang
.if ${COMPILER_VERSION} >= 35
MAKE_ENV+= COMPILER_WARNINGS_FATAL=false
@@ -238,6 +246,9 @@ post-patch:
${WRKSRC}/jdk/make/lib/ServiceabilityLibraries.gmk
@${CHMOD} 755 ${WRKSRC}/configure
+run-autotools-autoconf:
+ @cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} bash autogen.sh
+
post-build:
.if !defined(BUILD_JRE)
@${JDK_IMAGEDIR}/bin/jar cfe \