aboutsummaryrefslogtreecommitdiff
path: root/java/openjdk8
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2016-09-04 04:06:00 +0000
committerGreg Lewis <glewis@FreeBSD.org>2016-09-04 04:06:00 +0000
commit71b1ef1dd5d6c3e1c8cbd3f04fc7fd93ccea1874 (patch)
treef431d2618aa0605c30bf54e2c8169b1dbb38c179 /java/openjdk8
parentb59414ce0fc7054e540586a3c1602e0cec00afb1 (diff)
downloadports-71b1ef1dd5d6c3e1c8cbd3f04fc7fd93ccea1874.tar.gz
ports-71b1ef1dd5d6c3e1c8cbd3f04fc7fd93ccea1874.zip
Notes
Diffstat (limited to 'java/openjdk8')
-rw-r--r--java/openjdk8/Makefile1
-rw-r--r--java/openjdk8/files/patch-hotspot-agent-src-share-classes-sun-jvm-hotspot-debugger-bsd-BsdThread.java11
-rw-r--r--java/openjdk8/files/patch-hotspot-src-os-bsd-vm-os_bsd.cpp26
3 files changed, 38 insertions, 0 deletions
diff --git a/java/openjdk8/Makefile b/java/openjdk8/Makefile
index ed1c17b745e0..5a145a3888ba 100644
--- a/java/openjdk8/Makefile
+++ b/java/openjdk8/Makefile
@@ -2,6 +2,7 @@
PORTNAME= openjdk
PORTVERSION= ${JDK_MAJOR_VERSION}.${JDK_UPDATE_VERSION}.${JDK_BUILD_NUMBER:S/^0//}
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= http://download.java.net/openjdk/jdk${JDK_MAJOR_VERSION}/promoted/b${DIST_BUILD_NUMBER}/:jdk \
https://adopt-openjdk.ci.cloudbees.com/job/jtreg/${JTREG_JENKINS_BUILD}/artifact/:jtreg \
diff --git a/java/openjdk8/files/patch-hotspot-agent-src-share-classes-sun-jvm-hotspot-debugger-bsd-BsdThread.java b/java/openjdk8/files/patch-hotspot-agent-src-share-classes-sun-jvm-hotspot-debugger-bsd-BsdThread.java
new file mode 100644
index 000000000000..2f42fcb3672a
--- /dev/null
+++ b/java/openjdk8/files/patch-hotspot-agent-src-share-classes-sun-jvm-hotspot-debugger-bsd-BsdThread.java
@@ -0,0 +1,11 @@
+--- ./hotspot/agent/src/share/classes/sun/jvm/hotspot/debugger/bsd/BsdThread.java.orig 2016-05-14 19:57:37.394543000 +0000
++++ ./hotspot/agent/src/share/classes/sun/jvm/hotspot/debugger/bsd/BsdThread.java 2016-05-14 20:47:09.600014000 +0000
+@@ -61,7 +62,7 @@
+ }
+
+ public String toString() {
+- return Integer.toString(thread_id);
++ return Integer.toString(thread_id) + "/" + Long.toString(unique_thread_id);
+ }
+
+ public ThreadContext getContext() throws IllegalThreadStateException {
diff --git a/java/openjdk8/files/patch-hotspot-src-os-bsd-vm-os_bsd.cpp b/java/openjdk8/files/patch-hotspot-src-os-bsd-vm-os_bsd.cpp
new file mode 100644
index 000000000000..f66e7637372f
--- /dev/null
+++ b/java/openjdk8/files/patch-hotspot-src-os-bsd-vm-os_bsd.cpp
@@ -0,0 +1,26 @@
+--- ./hotspot/src/os/bsd/vm/os_bsd.cpp 2016-06-01 20:57:38.276230000 -0500
++++ ./hotspot/src/os/bsd/vm/os_bsd.cpp 2016-06-01 20:56:46.380667000 -0500
+@@ -767,6 +767,11 @@
+ guarantee(unique_thread_id != 0, "unique thread id was not found");
+ osthread->set_unique_thread_id(unique_thread_id);
+ #endif
++#ifdef __FreeBSD__
++ uint64_t unique_thread_id = os::Bsd::gettid();
++ guarantee(unique_thread_id != 0, "unique thread id was not found");
++ osthread->set_unique_thread_id(unique_thread_id);
++#endif
+ // initialize signal mask for this thread
+ os::Bsd::hotspot_sigmask(thread);
+
+@@ -930,6 +935,11 @@
+ guarantee(unique_thread_id != 0, "just checking");
+ osthread->set_unique_thread_id(unique_thread_id);
+ #endif
++#ifdef __FreeBSD__
++ uint64_t unique_thread_id = os::Bsd::gettid();
++ guarantee(unique_thread_id != 0, "unique thread id was not found");
++ osthread->set_unique_thread_id(unique_thread_id);
++#endif
+ osthread->set_pthread_id(::pthread_self());
+
+ // initialize floating point control register