aboutsummaryrefslogtreecommitdiff
path: root/java/phpeclipse/Makefile
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2004-11-29 04:10:59 +0000
committerClive Lin <clive@FreeBSD.org>2004-11-29 04:10:59 +0000
commit2bb7341fa1d8dba2bf07c9f410075eb0ee9658b1 (patch)
tree44636877b05676abf9db37dcbb2e014d7cb4073f /java/phpeclipse/Makefile
parent073e7bc6aab0007bcc2023010c1584833ccbd4b7 (diff)
Notes
Diffstat (limited to 'java/phpeclipse/Makefile')
-rw-r--r--java/phpeclipse/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/java/phpeclipse/Makefile b/java/phpeclipse/Makefile
index 6ad47f4d8b92..282d2a3fe4ca 100644
--- a/java/phpeclipse/Makefile
+++ b/java/phpeclipse/Makefile
@@ -21,8 +21,20 @@ NO_BUILD= yes
USE_ZIP= yes
WRKSRC= ${WRKDIR}
+ECLIPSE= ${PREFIX}/eclipse
+
do-install:
- @${CP} -r ${WRKSRC}/features ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/plugins ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/features/* ${ECLIPSE}/features
+ @${CP} -r ${WRKSRC}/plugins/* ${ECLIPSE}/plugins
+
+post-install:
+ @${FIND} -s ${WRKSRC}/features -not -type d \
+ | ${SED} -ne 's,^${WRKSRC},${ECLIPSE:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s ${WRKSRC}/plugins -not -type d \
+ | ${SED} -ne 's,^${WRKSRC},${ECLIPSE:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s -d ${WRKSRC}/features/* -type d \
+ | ${SED} -ne 's,^${WRKSRC},@dirrm ${ECLIPSE:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s -d ${WRKSRC}/plugins/* -type d \
+ | ${SED} -ne 's,^${WRKSRC},@dirrm ${ECLIPSE:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
.include <bsd.port.mk>