aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2012-10-31 22:07:56 +0000
committerGreg Lewis <glewis@FreeBSD.org>2012-10-31 22:07:56 +0000
commit1158f572a383c8008d1fd0778b7b80d397efbfa7 (patch)
tree370eea21ec92a4f458cc2cbc12fcd1c751530c30 /java
parentc5d98a8f24b0f95ea6ea3e13de0bffbbd96187a7 (diff)
downloadports-1158f572a383c8008d1fd0778b7b80d397efbfa7.tar.gz
ports-1158f572a383c8008d1fd0778b7b80d397efbfa7.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/openjdk7/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/java/openjdk7/Makefile b/java/openjdk7/Makefile
index 598cf9894496..a4fa3118cb1f 100644
--- a/java/openjdk7/Makefile
+++ b/java/openjdk7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openjdk
PORTVERSION= ${JDK_MAJOR_VERSION}.${PORT_MINOR_VERSION}.${PORT_BUILD_NUMBER}
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= http://download.java.net/openjdk/jdk${JDK_MAJOR_VERSION}u${JDK_MINOR_VERSION}/promoted/b${JDK_BUILD_NUMBER}/ \
http://download.java.net/jaxp/1.4.5/:jaxp \
@@ -34,8 +35,9 @@ USE_ICONV= yes
USE_XORG+= x11 xext xi xrender xt xtst
MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= POLICY TZUPDATE
+OPTIONS_DEFINE= DEBUG POLICY TZUPDATE
OPTIONS_DEFAULT= POLICY TZUPDATE
+DEBUG_DESC= Enable extra debugging info
POLICY_DESC= Install the Unlimited Strength Policy Files
TZUPDATE_DESC= Update the time zone data
@@ -111,6 +113,10 @@ BOOTSTRAP_JDKS= ${LOCALBASE}/openjdk7 \
.include <bsd.port.options.mk>
+.if empty(PORT_OPTIONS:MDEBUG)
+MAKE_ENV+= ALT_OBJCOPY="/nonexistent"
+.endif
+
.if ${PORT_OPTIONS:MTZUPDATE}
RUN_DEPENDS+= ${LOCALBASE}/share/java/zi:${PORTSDIR}/java/java-zoneinfo
.endif