aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2013-10-21 21:27:59 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2013-10-21 21:27:59 +0000
commit30b9bd7b949781c7a8a2c12f5c1a65c0ef557e7a (patch)
tree717fb27624ae8ca3889e6f8787c9b9e0e7e43ae3 /java
parent238e1b9f9788623aa7e9f99f5eb867e914c44e91 (diff)
downloadports-30b9bd7b949781c7a8a2c12f5c1a65c0ef557e7a.tar.gz
ports-30b9bd7b949781c7a8a2c12f5c1a65c0ef557e7a.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/bootstrap-openjdk/Makefile7
-rw-r--r--java/bootstrap-openjdk/Makefile.update5
-rw-r--r--java/bootstrap-openjdk/distinfo.amd644
-rw-r--r--java/bootstrap-openjdk/distinfo.i3864
-rw-r--r--java/bootstrap-openjdk/files/bootstrap.patch45
5 files changed, 55 insertions, 10 deletions
diff --git a/java/bootstrap-openjdk/Makefile b/java/bootstrap-openjdk/Makefile
index 91896a6c66f9..e1fd1ac0dcfc 100644
--- a/java/bootstrap-openjdk/Makefile
+++ b/java/bootstrap-openjdk/Makefile
@@ -18,8 +18,8 @@ RUN_DEPENDS= ${LOCALBASE}/share/java/zi:${PORTSDIR}/java/java-zoneinfo
ONLY_FOR_ARCH= amd64 i386
DISTINFO_FILE= ${.CURDIR}/distinfo.${ARCH}
-DISTVERSION_amd64= r330107
-DISTVERSION_i386= r330107
+DISTVERSION_amd64= r330538
+DISTVERSION_i386= r330538
JDK_NAME= openjdk
JDK_PORT= openjdk6
@@ -37,9 +37,6 @@ INSTALLDIR= ${STAGEDIR}${PREFIX}/${JDK_ROOT}
.if ${OSVERSION} >= 900010
RUN_DEPENDS+= ${LOCALBASE}/lib/compat/libz.so.5:${PORTSDIR}/misc/compat8x
.endif
-.if ${OSVERSION} >= 1000054
-RUN_DEPENDS+= ${LOCALBASE}/lib/compat/libstdc++.so.6:${PORTSDIR}/misc/compat9x
-.endif
.if ${ARCH} == "i386"
PLIST_SUB+= CLIENTVM=""
diff --git a/java/bootstrap-openjdk/Makefile.update b/java/bootstrap-openjdk/Makefile.update
index aa9b10df0dc5..7dec4b665d6e 100644
--- a/java/bootstrap-openjdk/Makefile.update
+++ b/java/bootstrap-openjdk/Makefile.update
@@ -32,6 +32,7 @@ PORTREVISION!= ${GET_REVISION} 2>/dev/null || ${TRUE}
DISTDIR?= ${.CURDIR}
DISTFILE= ${JDK_PORT}-${ARCH}-r${PORTREVISION}.tar.xz
DISTINFO_FILE= ${.CURDIR}/distinfo.${ARCH}
+EXTRA_PATCHES= ${.CURDIR}/files/bootstrap.patch
MAKEFILE= ${.CURDIR}/Makefile
PLIST?= ${.CURDIR}/pkg-plist
PLIST_SUB= ARCH="${ARCH}" JDK_ROOT="."
@@ -60,7 +61,9 @@ all:
@${ECHO} "=============================================================="
@${ECHO} ""
.if !defined(NO_BUILD)
- @${SETENV} -i PATH=${PATH} ${MAKE} -C "${JDK_PORTDIR}" BATCH=yes
+ @${SETENV} -i PATH=${PATH} __MAKE_CONF=/dev/null \
+ ${MAKE} -C "${JDK_PORTDIR}" BATCH=yes EXTRA_PATCHES="${EXTRA_PATCHES}" \
+ PORT_DBDIR=/var/empty WITHOUT_ICEDTEA=yes
.endif
@cd "${JDK_IMAGEDIR}" && \
${SED} ${PLIST_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${PLIST} | \
diff --git a/java/bootstrap-openjdk/distinfo.amd64 b/java/bootstrap-openjdk/distinfo.amd64
index 87d3dfe8fae0..878fb4dd2f20 100644
--- a/java/bootstrap-openjdk/distinfo.amd64
+++ b/java/bootstrap-openjdk/distinfo.amd64
@@ -1,2 +1,2 @@
-SHA256 (openjdk6-amd64-r330107.tar.xz) = 18ff0c050d02670ae3202f514d1f8619485d44f7d1be4d004d207fa5ce890766
-SIZE (openjdk6-amd64-r330107.tar.xz) = 22387200
+SHA256 (openjdk6-amd64-r330538.tar.xz) = f1ba1aca887d26f3ce067c9d95e8e51294a28de643ea0d6593ed285b6cf1202b
+SIZE (openjdk6-amd64-r330538.tar.xz) = 22382548
diff --git a/java/bootstrap-openjdk/distinfo.i386 b/java/bootstrap-openjdk/distinfo.i386
index 2bdeca128dbf..d96204a193e8 100644
--- a/java/bootstrap-openjdk/distinfo.i386
+++ b/java/bootstrap-openjdk/distinfo.i386
@@ -1,2 +1,2 @@
-SHA256 (openjdk6-i386-r330107.tar.xz) = 90e3f9d3efb9b2b259ee224ed2f81b2a33dddcaf0dd4ca8950e28be8be66d280
-SIZE (openjdk6-i386-r330107.tar.xz) = 22676896
+SHA256 (openjdk6-i386-r330538.tar.xz) = 034d986e077ba33e235647fbc86d3b9e387fe88885897ee83c3df28922c85daa
+SIZE (openjdk6-i386-r330538.tar.xz) = 22677180
diff --git a/java/bootstrap-openjdk/files/bootstrap.patch b/java/bootstrap-openjdk/files/bootstrap.patch
new file mode 100644
index 000000000000..fef466f77103
--- /dev/null
+++ b/java/bootstrap-openjdk/files/bootstrap.patch
@@ -0,0 +1,45 @@
+--- hotspot/src/share/vm/Xusage.txt
++++ hotspot/src/share/vm/Xusage.txt
+@@ -1,5 +1,5 @@
+- -Xmixed mixed mode execution (default)
+- -Xint interpreted mode execution only
++ -Xint interpreted mode execution only (default)
++ -Xmixed mixed mode execution
+ -Xbootclasspath:<directories and zip/jar files separated by ;>
+ set search path for bootstrap classes and resources
+ -Xbootclasspath/a:<directories and zip/jar files separated by ;>
+--- hotspot/src/share/vm/runtime/arguments.cpp
++++ hotspot/src/share/vm/runtime/arguments.cpp
+@@ -67,7 +67,7 @@
+ bool Arguments::_has_profile = false;
+ bool Arguments::_has_alloc_profile = false;
+ uintx Arguments::_min_heap_size = 0;
+-Arguments::Mode Arguments::_mode = _mixed;
++Arguments::Mode Arguments::_mode = _int;
+ bool Arguments::_java_compiler = false;
+ bool Arguments::_xdebug_mode = false;
+ const char* Arguments::_java_vendor_url_bug = DEFAULT_VENDOR_URL_BUG;
+@@ -2036,8 +2036,8 @@
+ Arguments::_ClipInlining = ClipInlining;
+ Arguments::_BackgroundCompilation = BackgroundCompilation;
+
+- // Setup flags for mixed which is the default
+- set_mode_flags(_mixed);
++ // Setup flags for interpreter which is the default
++ set_mode_flags(_int);
+
+ // Parse JAVA_TOOL_OPTIONS environment variable (if present)
+ jint result = parse_java_tool_options_environment_variable(&scp, &scp_assembly_required);
+--- jdk/src/share/classes/sun/launcher/resources/launcher.properties
++++ jdk/src/share/classes/sun/launcher/resources/launcher.properties
+@@ -75,8 +75,8 @@
+
+ # Translators please note do not translate the options themselves
+ java.launcher.X.usage=\
+-\ -Xmixed mixed mode execution (default)\n\
+-\ -Xint interpreted mode execution only\n\
++\ -Xint interpreted mode execution only (default)\n\
++\ -Xmixed mixed mode execution\n\
+ \ -Xbootclasspath:<directories and zip/jar files separated by {0}>\n\
+ \ set search path for bootstrap classes and resources\n\
+ \ -Xbootclasspath/a:<directories and zip/jar files separated by {0}>\n\