aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2010-07-31 18:03:52 +0000
committerGreg Lewis <glewis@FreeBSD.org>2010-07-31 18:03:52 +0000
commit72519c4a2a5286a80e96c917b6980defd535c4c1 (patch)
treee45647db9c53019847046907b90bb5ff54867320 /java
parent2cc04f893360fe0528951d8ad668a71e741e6e57 (diff)
downloadports-72519c4a2a5286a80e96c917b6980defd535c4c1.tar.gz
ports-72519c4a2a5286a80e96c917b6980defd535c4c1.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-lomboz/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/java/eclipse-lomboz/Makefile b/java/eclipse-lomboz/Makefile
index 39f8f5d49301..b1b8b3accc50 100644
--- a/java/eclipse-lomboz/Makefile
+++ b/java/eclipse-lomboz/Makefile
@@ -31,12 +31,12 @@ JAVA_VERSION= 1.4+
JAVA_OS= native
do-install:
- @${MKDIR} ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) >> ${TMPPLIST}
+ @${MKDIR} ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
@(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
| ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
+ | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
.include <bsd.port.mk>