aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2021-11-24 18:04:49 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2021-11-25 00:58:08 +0000
commite82d4ec5e029a96015ad71df695aab7cc9fdd0f3 (patch)
treec0340f7c40a909f2c3abc6e37b9f8b305f01f54b /java
parent374e9ed352b30f0d298ab574bfa6fb32bcc49fb4 (diff)
Diffstat (limited to 'java')
-rw-r--r--java/bouncycastle15/Makefile5
-rw-r--r--java/bouncycastle15/pkg-descr29
2 files changed, 11 insertions, 23 deletions
diff --git a/java/bouncycastle15/Makefile b/java/bouncycastle15/Makefile
index 959de8427a0b..28eaac7e39af 100644
--- a/java/bouncycastle15/Makefile
+++ b/java/bouncycastle15/Makefile
@@ -11,7 +11,10 @@ DISTNAME= crypto-${DVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Cleanroom build of Java Cryptography Extensions
-LICENSE= MIT
+# APACHE20 is used by pg/src/main/java/org/bouncycastle/apache/bzip2/*.
+LICENSE= APACHE20 MIT
+LICENSE_COMB= multi
+LICENSE_FILE_MIT= ${WRKSRC}/LICENSE.html
BUILD_DEPENDS= ${JAVALIBDIR}/junit.jar:java/junit \
${JAVALIBDIR}/mail.jar:java/javamail
diff --git a/java/bouncycastle15/pkg-descr b/java/bouncycastle15/pkg-descr
index b330c53b83fc..7a9376f8aea7 100644
--- a/java/bouncycastle15/pkg-descr
+++ b/java/bouncycastle15/pkg-descr
@@ -1,24 +1,9 @@
-The Bouncy Castle Crypto APIs consist of the following:
+The Bouncy Castle Crypto package is a Java implementation of cryptographic
+algorithms. It was developed by the Legion of the Bouncy Castle, a registered
+Australian Charity.
-. A lightweight cryptography API in Java.
-. A provider for the JCE and JCA.
-. A clean room implementation of the JCE 1.2.1.
-. A library for reading and writing encoded ASN.1 objects.
-. Lightweight APIs for TLS (RFC 2246, RFC 4346) and DTLS (RFC 4347).
-. Generators for Version 1 and Version 3 X.509 certificates, Version 2 CRLs,
- and PKCS12 files.
-. Generators for Version 2 X.509 attribute certificates.
-. Generators/Processors for S/MIME and CMS (PKCS7/RFC 3852).
-. Generators/Processors for OCSP (RFC 2560).
-. Generators/Processors for TSP (RFC 3161 & RFC 5544).
-. Generators/Processors for CMP and CRMF (RFC 4210 & RFC 4211).
-. Generators/Processors for OpenPGP (RFC 2440).
-. Generators/Processors for Extended Access Control (EAC).
-. Generators/Processors for Data Validation and Certification Server (DVCS) -
- RFC 3029.
-. Generators/Processors for DNS-based Authentication of Named Entities (DANE).
-. A signed jar version suitable for JDK 1.4-1.8 and the Sun JCE.
+The package is organised so that it contains a light-weight API suitable for
+use in any environment (including the J2ME) with the additional infrastructure
+to conform the algorithms to the JCE framework.
-It's distributed under a modified X license.
-
-WWW: http://www.bouncycastle.org/
+WWW: https://www.bouncycastle.org/