aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-06-27 21:36:33 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-06-27 21:36:33 +0000
commit6cdf4863c99ba93bbe1a7455c4627e51fe61b471 (patch)
tree1819f9e6fcf371fb1fbb57b5fe73263a6d42b55e /java
parentb4df93bf77daddea2090982d4e59dca5c9471349 (diff)
Notes
Diffstat (limited to 'java')
-rw-r--r--java/eclipse/Makefile.plugins16
1 files changed, 12 insertions, 4 deletions
diff --git a/java/eclipse/Makefile.plugins b/java/eclipse/Makefile.plugins
index 7abc7b84f8aa..f23fa3467081 100644
--- a/java/eclipse/Makefile.plugins
+++ b/java/eclipse/Makefile.plugins
@@ -1,6 +1,14 @@
-# stopgap to unbreak index
# $FreeBSD$
+NO_BUILD= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.7
+JAVA_OS= native
-BROKEN= Attempting to use removed plugin makefile
-DEPRECATED= Attempting to use removed plugin makefile
-EXPIRATION_DATE= 2014-07-27
+REPO_DIRS?= features plugins
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse
+ @(cd ${WRKSRC}; ${COPYTREE_SHARE} "${REPO_DIRS}" ${STAGEDIR}${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse/)
+ @(cd ${STAGEDIR}${PREFIX}; ${FIND} -s share/eclipse/dropins/${PORTNAME} -not -type d) >> ${TMPPLIST}
+ @(cd ${STAGEDIR}${PREFIX}; ${FIND} -s -d share/eclipse/dropins/${PORTNAME} -type d) \
+ | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}