aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-05-17 10:31:58 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-05-17 10:31:58 +0000
commit3b338c89d97a04d03b1d7f693d6a581bac3d9a51 (patch)
tree577df219099b3c61c618b2e309b21865c04eb58e /java
parentad32c567fcf8f6150f2477782a05d8ffce27f5f7 (diff)
downloadports-3b338c89d97a04d03b1d7f693d6a581bac3d9a51.tar.gz
ports-3b338c89d97a04d03b1d7f693d6a581bac3d9a51.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-EPIC/Makefile30
1 files changed, 24 insertions, 6 deletions
diff --git a/java/eclipse-EPIC/Makefile b/java/eclipse-EPIC/Makefile
index 00cee8d43c7b..9f548423eff1 100644
--- a/java/eclipse-EPIC/Makefile
+++ b/java/eclipse-EPIC/Makefile
@@ -7,7 +7,7 @@
PORTNAME= EPIC
PORTVERSION= 0.3.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= java editors devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= e-p-i-c
@@ -25,15 +25,33 @@ WRKSRC= ${WRKDIR}/${EPIC}
EPIC= org.epic.updatesite
ECLIPSE= ${PREFIX}/eclipse
+EPICFILES= features/org.epic.feature.main_0.3.0 \
+ plugins/org.epic.debug_0.2.0 \
+ plugins/org.epic.ext.cbg.editor_0.3.0 \
+ plugins/org.epic.perleditor_0.1.2 \
+ plugins/org.epic.regexp_0.1.2
+
+post-extract:
+.for file in ${EPICFILES}
+ cd ${WRKSRC} \
+ && ${MKDIR} ${file} \
+ && ${UNZIP_CMD} ${file}.jar -d ${file}
+.endfor
do-install:
- @${CP} -r ${WRKSRC}/features/*.jar ${ECLIPSE}/features
- @${CP} -r ${WRKSRC}/plugins/*.jar ${ECLIPSE}/plugins
+.for file in ${EPICFILES}
+ cd ${WRKSRC} \
+ && ${MKDIR} ${ECLIPSE}/${file} \
+ && ${FIND} ${file} -type d -exec ${MKDIR} ${ECLIPSE}/{} \; \
+ && ${FIND} ${file} -type f -exec ${INSTALL_DATA} {} ${ECLIPSE}/{} \;
+.endfor
post-install:
- @${FIND} -s ${WRKSRC}/features -name "*.jar" \
- | ${SED} -ne 's,^${WRKSRC},${ECLIPSE:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
- @${FIND} -s ${WRKSRC}/plugins -name "*.jar" \
+.for file in ${EPICFILES}
+ @${FIND} ${WRKSRC}/${file} -type f \
| ${SED} -ne 's,^${WRKSRC},${ECLIPSE:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -d ${WRKSRC}/${file} -type d \
+ | ${SED} -ne 's,^${WRKSRC},@dirrm ${ECLIPSE:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+.endfor
.include <bsd.port.mk>