aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2005-05-17 20:57:51 +0000
committerGreg Lewis <glewis@FreeBSD.org>2005-05-17 20:57:51 +0000
commit4348e7f10f77ed610d2a6fc9ae27f3b77a7993aa (patch)
tree5738239e53b3172af9619702865bbe6eefec3079 /java
parent72c3c7ee152996a12b85aedb1ab38cac8493a789 (diff)
downloadports-4348e7f10f77ed610d2a6fc9ae27f3b77a7993aa.tar.gz
ports-4348e7f10f77ed610d2a6fc9ae27f3b77a7993aa.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/linux-sun-jdk15/Makefile6
-rw-r--r--java/linux-sun-jdk16/Makefile6
2 files changed, 8 insertions, 4 deletions
diff --git a/java/linux-sun-jdk15/Makefile b/java/linux-sun-jdk15/Makefile
index 830e17fd6995..cee762130cd5 100644
--- a/java/linux-sun-jdk15/Makefile
+++ b/java/linux-sun-jdk15/Makefile
@@ -40,10 +40,12 @@ APP_HOME= ${PREFIX}/${PKGNAMEPREFIX}${PORTNAME}${JDK_VERSION}
PACKED_JARS= lib/tools.jar jre/lib/rt.jar jre/lib/jsse.jar jre/lib/charsets.jar jre/lib/ext/localedata.jar jre/lib/plugin.jar jre/javaws/javaws.jar
UNPACK_CMD= ${APP_HOME}/bin/unpack200
-IGNORE= does not run (core dumps: Bad System Call)
-
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 504000
+IGNORE= does not run (core dumps: Bad System Call)
+.endif
+
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE?=You must manually fetch the J2SE SDK self-extracting file for the Linux platform (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
diff --git a/java/linux-sun-jdk16/Makefile b/java/linux-sun-jdk16/Makefile
index 830e17fd6995..cee762130cd5 100644
--- a/java/linux-sun-jdk16/Makefile
+++ b/java/linux-sun-jdk16/Makefile
@@ -40,10 +40,12 @@ APP_HOME= ${PREFIX}/${PKGNAMEPREFIX}${PORTNAME}${JDK_VERSION}
PACKED_JARS= lib/tools.jar jre/lib/rt.jar jre/lib/jsse.jar jre/lib/charsets.jar jre/lib/ext/localedata.jar jre/lib/plugin.jar jre/javaws/javaws.jar
UNPACK_CMD= ${APP_HOME}/bin/unpack200
-IGNORE= does not run (core dumps: Bad System Call)
-
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 504000
+IGNORE= does not run (core dumps: Bad System Call)
+.endif
+
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE?=You must manually fetch the J2SE SDK self-extracting file for the Linux platform (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif