aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2012-05-02 06:13:16 +0000
committerGreg Lewis <glewis@FreeBSD.org>2012-05-02 06:13:16 +0000
commit28609d64eff567ef822e145ce1c2d30824c6d8f7 (patch)
tree526e380dbdc91d4a57f13ff540ba75bc96176af9 /java
parenta76795c61a432db3721d7f46d9cdb2a53a613881 (diff)
downloadports-28609d64eff567ef822e145ce1c2d30824c6d8f7.tar.gz
ports-28609d64eff567ef822e145ce1c2d30824c6d8f7.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/openjdk6/Makefile4
-rw-r--r--java/openjdk6/files/patch-ZoneInfoFile.java14
2 files changed, 16 insertions, 2 deletions
diff --git a/java/openjdk6/Makefile b/java/openjdk6/Makefile
index 3a46fcd729b0..242d33b40537 100644
--- a/java/openjdk6/Makefile
+++ b/java/openjdk6/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openjdk6
PORTVERSION= b24
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= java devel
MASTER_SITES= http://download.java.net/openjdk/jdk6/promoted/${PORTVERSION}/ \
http://download.java.net/jaxp/openjdk/jdk6/:jaxp \
@@ -48,7 +48,7 @@ OPTIONS= DEBUG "Enable legacy debugging support" off \
POLICY "Install the Unlimited Strength Policy Files" off \
SOUND "Enable sound support" off \
TEST "Add support for running regression test" off \
- TZUPDATE "Update the time zone data" off
+ TZUPDATE "Update the time zone data" on
# java extracts directly to the cwd
WRKSRC= ${WRKDIR}
diff --git a/java/openjdk6/files/patch-ZoneInfoFile.java b/java/openjdk6/files/patch-ZoneInfoFile.java
new file mode 100644
index 000000000000..ea68672271f2
--- /dev/null
+++ b/java/openjdk6/files/patch-ZoneInfoFile.java
@@ -0,0 +1,14 @@
+$FreeBSD$
+
+--- jdk/src/share/classes/sun/util/calendar/ZoneInfoFile.java.orig 2012-05-01 18:59:17.000000000 -0700
++++ jdk/src/share/classes/sun/util/calendar/ZoneInfoFile.java 2012-05-01 19:02:16.000000000 -0700
+@@ -476,7 +476,8 @@
+ static {
+ String zi = (String) AccessController.doPrivileged(
+ new sun.security.action.GetPropertyAction("java.home"))
+- + File.separator + "lib" + File.separator + "zi";
++ + File.separator + "lib" + File.separator + "."
++ + File.separator + "zi";
+ try {
+ zi = new File(zi).getCanonicalPath();
+ } catch (Exception e) {