aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-01-24 12:51:38 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-01-24 12:51:38 +0000
commit583a0b910d59f2f9bd743d9edec9725f3870e2f2 (patch)
tree7072ba1fe2389209881d12bf56c3d95f75634d11 /java
parent112a7557d5adbadb5a8bc56070429d9ac56e7549 (diff)
downloadports-583a0b910d59f2f9bd743d9edec9725f3870e2f2.tar.gz
ports-583a0b910d59f2f9bd743d9edec9725f3870e2f2.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/jboss4/Makefile2
-rw-r--r--java/jboss4/pkg-descr42
-rw-r--r--java/jboss5/Makefile2
-rw-r--r--java/jboss5/pkg-descr42
4 files changed, 44 insertions, 44 deletions
diff --git a/java/jboss4/Makefile b/java/jboss4/Makefile
index c3a8e4f3e667..faddb01094e1 100644
--- a/java/jboss4/Makefile
+++ b/java/jboss4/Makefile
@@ -47,7 +47,7 @@ STDERR_LOG= ${LOG_DIR}/stderr.log
AUTO_START?= NO
STOP_TIMEOUT?= 5
PID_FILE= /var/run/${APP_SHORTNAME}.pid
-JAVA_OPTS=
+JAVA_OPTS=
JAVA_CP= bin/run.jar:${JAVA_HOME}/lib/tools.jar
JAVA_MAIN= org.jboss.Main
DAEMONCTL_DIR= ${FILESDIR}
diff --git a/java/jboss4/pkg-descr b/java/jboss4/pkg-descr
index b4b75ac4b9eb..881700f3267d 100644
--- a/java/jboss4/pkg-descr
+++ b/java/jboss4/pkg-descr
@@ -1,24 +1,24 @@
-JBoss is an implementation of the EJB 1.1 (and parts of 2.0) specification,
-that is, it is a server and container for Enterprise JavaBeans. In this it
-is similar to Sun's 'J2SDK Enterprise Edition' (J2EE), but the JBoss core
-server provides only an EJB server. The JBoss core does not include a web
-container for servlets/JSP pages, although there are bundles available that
-include either Tomcat or Jetty. The minimal core offering means that JBoss
-has minimal memory and disk space requirements. JBoss will run very
-effectively on a machine with 64 megabytes of RAM, and requires only a few
-megabytes of disk (including source code!). Sun's J2EE requires a minimum of
-128 megabytes of RAM, and 31 megabytes of disk space. Because of its small
-memory footprint, JBoss starts up about 10 times faster than J2EE. There is
-a built-in SQL database server for handling persistent beans, and this
-starts up automatically with the server (J2EE ships with the CloudScape SQL
-server, which has to be started separately).
+JBoss AS 4 is an officially certified J2EE 1.4 application server. The
+certification guarantees that JBoss AS 4 conforms to the formal J2EE
+specification.
-One of the nicest features of JBoss is its support for `hot' deployment. What
-this means is that deploying a Bean is a simple as copying its JAR file into
-the deployment directory. If this is done while the Bean is already loaded,
-JBoss automatically unloads it, then loads the new version. Contrast this
-with the rigmarole that other J2EE server makes us go through... JBoss is
-distributed under the LGPL, which means that it's free, even for commercial
-work, and the LGPL ensures that it remains that way.
+- supports J2EE Web Services including JAX-RPC (Java API for XML for
+Remote Procedure Call) and the Web Services for J2EE Architecture.
+
+- implements the JMS (Java Messaging Service) 1.1 specification.
+
+- implements the JCA (Java Connector Architecture) 1.5 specification.
+The JCA 1.5 specification adds support for the life cycle management of
+resource adapters, worker thread management as well as transaction and
+message inflow from the resource adapter to the application server.
+
+- implements the Java Authorization Contract for Containers (JACC)
+specification.
+
+- implements the EJB 2.1 specification. The EJB 2.1 specification
+extends the message-driven bean contracts to support other messaging
+types in addition to JMS. It supports stateless session beans as web
+service endpoints. It also includes a new container managed service
+called the EJB timer service.
WWW: http://www.jboss.org/
diff --git a/java/jboss5/Makefile b/java/jboss5/Makefile
index c3a8e4f3e667..faddb01094e1 100644
--- a/java/jboss5/Makefile
+++ b/java/jboss5/Makefile
@@ -47,7 +47,7 @@ STDERR_LOG= ${LOG_DIR}/stderr.log
AUTO_START?= NO
STOP_TIMEOUT?= 5
PID_FILE= /var/run/${APP_SHORTNAME}.pid
-JAVA_OPTS=
+JAVA_OPTS=
JAVA_CP= bin/run.jar:${JAVA_HOME}/lib/tools.jar
JAVA_MAIN= org.jboss.Main
DAEMONCTL_DIR= ${FILESDIR}
diff --git a/java/jboss5/pkg-descr b/java/jboss5/pkg-descr
index b4b75ac4b9eb..881700f3267d 100644
--- a/java/jboss5/pkg-descr
+++ b/java/jboss5/pkg-descr
@@ -1,24 +1,24 @@
-JBoss is an implementation of the EJB 1.1 (and parts of 2.0) specification,
-that is, it is a server and container for Enterprise JavaBeans. In this it
-is similar to Sun's 'J2SDK Enterprise Edition' (J2EE), but the JBoss core
-server provides only an EJB server. The JBoss core does not include a web
-container for servlets/JSP pages, although there are bundles available that
-include either Tomcat or Jetty. The minimal core offering means that JBoss
-has minimal memory and disk space requirements. JBoss will run very
-effectively on a machine with 64 megabytes of RAM, and requires only a few
-megabytes of disk (including source code!). Sun's J2EE requires a minimum of
-128 megabytes of RAM, and 31 megabytes of disk space. Because of its small
-memory footprint, JBoss starts up about 10 times faster than J2EE. There is
-a built-in SQL database server for handling persistent beans, and this
-starts up automatically with the server (J2EE ships with the CloudScape SQL
-server, which has to be started separately).
+JBoss AS 4 is an officially certified J2EE 1.4 application server. The
+certification guarantees that JBoss AS 4 conforms to the formal J2EE
+specification.
-One of the nicest features of JBoss is its support for `hot' deployment. What
-this means is that deploying a Bean is a simple as copying its JAR file into
-the deployment directory. If this is done while the Bean is already loaded,
-JBoss automatically unloads it, then loads the new version. Contrast this
-with the rigmarole that other J2EE server makes us go through... JBoss is
-distributed under the LGPL, which means that it's free, even for commercial
-work, and the LGPL ensures that it remains that way.
+- supports J2EE Web Services including JAX-RPC (Java API for XML for
+Remote Procedure Call) and the Web Services for J2EE Architecture.
+
+- implements the JMS (Java Messaging Service) 1.1 specification.
+
+- implements the JCA (Java Connector Architecture) 1.5 specification.
+The JCA 1.5 specification adds support for the life cycle management of
+resource adapters, worker thread management as well as transaction and
+message inflow from the resource adapter to the application server.
+
+- implements the Java Authorization Contract for Containers (JACC)
+specification.
+
+- implements the EJB 2.1 specification. The EJB 2.1 specification
+extends the message-driven bean contracts to support other messaging
+types in addition to JMS. It supports stateless session beans as web
+service endpoints. It also includes a new container managed service
+called the EJB timer service.
WWW: http://www.jboss.org/