aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-08-21 12:06:54 +0000
committerRene Ladan <rene@FreeBSD.org>2018-08-21 12:06:54 +0000
commit7526a10e450ca9426aaed0fa9341f56da75cdc0e (patch)
tree7247af281307dfc53b3d0e9891be0278d6ed213a /java
parent8950e0e96943dd73a5322e0622a1adf63ad849f3 (diff)
downloadports-7526a10e450ca9426aaed0fa9341f56da75cdc0e.tar.gz
ports-7526a10e450ca9426aaed0fa9341f56da75cdc0e.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/Makefile1
-rw-r--r--java/jgrapht/Makefile65
-rw-r--r--java/jgrapht/distinfo2
-rw-r--r--java/jgrapht/files/patch-build.xml12
-rw-r--r--java/jgrapht/pkg-descr17
5 files changed, 0 insertions, 97 deletions
diff --git a/java/Makefile b/java/Makefile
index d43e0b19fad6..edd391f8af11 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -77,7 +77,6 @@
SUBDIR += jflex
SUBDIR += jfreechart
SUBDIR += jgraph
- SUBDIR += jgrapht
SUBDIR += jgraphx
SUBDIR += jikes
SUBDIR += jlex
diff --git a/java/jgrapht/Makefile b/java/jgrapht/Makefile
deleted file mode 100644
index 70084e5d6a94..000000000000
--- a/java/jgrapht/Makefile
+++ /dev/null
@@ -1,65 +0,0 @@
-# Created by: ijliao
-# $FreeBSD$
-
-PORTNAME= jgrapht
-PORTVERSION= 0.7.3
-PORTREVISION= 1
-CATEGORIES= java math
-MASTER_SITES= SF/${PORTNAME}/JGraphT/Version%20${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Java package for mathematical graph-theory objects and algorithms
-
-BROKEN= fails to build
-DEPRECATED= Broken for more than 5 months
-EXPIRATION_DATE= 2018-08-20
-
-USES= dos2unix zip
-DOS2UNIX_GLOB= *.xml *.java
-USE_JAVA= yes
-JAVA_VERSION= 1.6 1.7
-
-OPTIONS_DEFINE= DOCS
-
-.include <bsd.port.options.mk>
-
-.if !defined(WITHOUT_COMPILE)
-USE_ANT= yes
-ALL_TARGET= jar
-.if ${PORT_OPTIONS:MDOCS}
-ALL_TARGET+= javadoc
-.endif
-.else
-NO_BUILD= yes
-.endif
-
-PORTDOCS= *
-
-PLIST_FILES= ${JAVAJARDIR}/${PORTNAME}.jar
-
-.include <bsd.port.pre.mk>
-
-JAVA_PORT_API= ${LOCALBASE}/share/doc/jdk${JAVA_PORT_VERSION:C/([0-9]\.[0-9])\.[0-9]/\1/}/api
-.if exists(${JAVA_PORT_API})
-MAKE_ARGS+= -Djdk.api="${JAVA_PORT_API}"
-.endif
-
-pre-fetch:
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You may use the following build options:"
- @${ECHO_MSG} ""
- @${ECHO_MSG} " WITHOUT_COMPILE=yes Install the pre-compiled .jar file"
- @${ECHO_MSG} ""
-
-do-install:
- @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
- @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-jdk1.5.jar ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
- @${ECHO_MSG} " [DONE]"
-.if ${PORT_OPTIONS:MDOCS}
- @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
- @cd ${WRKSRC}/javadoc && ${FIND} . -type d -exec ${MKDIR} ${STAGEDIR}${DOCSDIR}/{} \;
- @cd ${WRKSRC}/javadoc && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${DOCSDIR}/{} \;
- @${ECHO_MSG} " [DONE]"
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/java/jgrapht/distinfo b/java/jgrapht/distinfo
deleted file mode 100644
index 9ea854ac9784..000000000000
--- a/java/jgrapht/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (jgrapht-0.7.3.zip) = e59bc448b55f8e32f9a3aed0103e733015b1c343f86c790a23df76997716ab81
-SIZE (jgrapht-0.7.3.zip) = 1668719
diff --git a/java/jgrapht/files/patch-build.xml b/java/jgrapht/files/patch-build.xml
deleted file mode 100644
index 2870d1748c70..000000000000
--- a/java/jgrapht/files/patch-build.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-Patch to allow the JDK API location to be passed to Ant using -Djdk.api
-
---- build.xml.orig 2016-06-20 15:06:43 UTC
-+++ build.xml
-@@ -355,6 +355,7 @@
- <include name="**"/>
- <exclude name="org/jgrapht/experimental/**"/>
- </packageset>
-+ <link offline="true" packagelistLoc="${jdk.api}" href="${jdk.api}"/>
- </javadoc>
- </target>
-
diff --git a/java/jgrapht/pkg-descr b/java/jgrapht/pkg-descr
deleted file mode 100644
index c9150881f88d..000000000000
--- a/java/jgrapht/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-JGraphT is a free Java graph library that provides mathematical graph-theory
-objects and algorithms. JGraphT supports various types of graphs including:
- * directed and undirected graphs.
- * graphs with weighted / unweighted / labeled or any user-defined edges.
- * various edge multiplicity options, including: simple-graphs, multigraphs,
- pseudographs.
- * unmodifiable graphs - allow modules to provide "read-only" access to
- internal graphs.
- * listenable graphs - allow external listeners to track modification events.
- * subgraphs graphs that are auto-updating subgraph views on other graphs.
- * all compositions of above graphs.
-
-Although powerful, JGraphT is designed to be simple. For example, graph vertices
-can be of any objects. You can create graphs based on: Strings, URLs, XML
-documents, etc; you can even create graphs of graphs!
-
-WWW: http://jgrapht.sourceforge.net/