aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2005-09-14 14:46:36 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2005-09-14 14:46:36 +0000
commit5ddd31a2e011ebd1b03380e2f7278b888686dc48 (patch)
tree348a7401ceeb75523687312a30f642c8d1d934d6 /java
parentd6e523c707fd0fc7abe3c7ef2a97574d10860cdb (diff)
downloadports-5ddd31a2e011ebd1b03380e2f7278b888686dc48.tar.gz
ports-5ddd31a2e011ebd1b03380e2f7278b888686dc48.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/eclipse/Makefile10
-rw-r--r--java/eclipse/files/eclipse.desktop10
2 files changed, 18 insertions, 2 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index 9be9a4e09891..445e679b66d8 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -7,7 +7,7 @@
PORTNAME= eclipse
PORTVERSION= 3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_ECLIPSE}
MASTER_SITE_SUBDIR= R-${PORTVERSION}-200506271435
@@ -90,9 +90,10 @@ MAKE_ENV+= BROWSER=${BROWSER} \
MAKE_GNOME=${MAKE_GNOME} \
MAKE_MOZILLA=${MAKE_MOZILLA} \
MAKE_CAIRO=${MAKE_CAIRO} \
+ MACHINE_ARCH=${MACHINE_ARCH} \
MOTIF_HOME=${X11_HOME}
-PLIST_FILES= bin/eclipse
+PLIST_FILES= bin/eclipse share/gnome/applications/eclipse.desktop
SWTGTK=${WRKSRC}/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library
SWTMOTIF=${WRKSRC}/plugins/org.eclipse.swt/Eclipse SWT PI/motif/library
@@ -122,6 +123,11 @@ do-install:
-e "s+%%BROWSER%%+${BROWSER}+g" \
${FILESDIR}/eclipse.in > ${WRKSRC}/eclipse.tmp
${INSTALL_SCRIPT} ${WRKSRC}/eclipse.tmp ${PREFIX}/bin/eclipse
+ @${SED} \
+ -e "s+%%ECLIPSE_HOME%%+${PORTDESTDIR}+g" \
+ -e "s+%%PREFIX%%+${PREFIX}+g" \
+ ${FILESDIR}/eclipse.desktop > ${WRKSRC}/eclipse.desktop.tmp
+ ${INSTALL_DATA} ${WRKSRC}/eclipse.desktop.tmp ${X11BASE}/share/gnome/applications/eclipse.desktop
${INSTALL_PROGRAM} ${WRKSRC}/launchertmp/eclipse ${PREFIX}/eclipse/eclipse
@(cd ${WRKSRC}; ${FIND} -s eclipse -not -type d) >> ${TMPPLIST}
@(cd ${WRKSRC}; ${FIND} -s -d eclipse -type d) \
diff --git a/java/eclipse/files/eclipse.desktop b/java/eclipse/files/eclipse.desktop
new file mode 100644
index 000000000000..37a3c2b75e31
--- /dev/null
+++ b/java/eclipse/files/eclipse.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Comment=Eclipse IDE
+Name=Eclipse
+Exec=%%PREFIX%%/bin/eclipse
+Encoding=UTF-8
+Terminal=false
+Type=Application
+Icon=%%ECLIPSE_HOME%%/icon.xpm
+Categories=Application;Development;
+