aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 01:14:50 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 01:14:50 +0000
commit42b9878de05e3fd31b1537c7fb21ea8d4260e335 (patch)
treefaaedbe6ae8110bb19ce982907b65ca7c487c291 /java
parentf7c0630cd25902e9d0299337f0075f1969f3c15c (diff)
downloadports-42b9878de05e3fd31b1537c7fb21ea8d4260e335.tar.gz
ports-42b9878de05e3fd31b1537c7fb21ea8d4260e335.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/diablo-jdk15/Makefile2
-rw-r--r--java/diablo-jre15/Makefile2
-rw-r--r--java/ecj-bootstrap/Makefile4
-rw-r--r--java/jmp/Makefile4
-rw-r--r--java/netbeans3/Makefile2
5 files changed, 4 insertions, 10 deletions
diff --git a/java/diablo-jdk15/Makefile b/java/diablo-jdk15/Makefile
index 717d63ac4029..7ed914128243 100644
--- a/java/diablo-jdk15/Makefile
+++ b/java/diablo-jdk15/Makefile
@@ -50,7 +50,7 @@ LIB_DEPENDS= z.3:${PORTSDIR}/misc/compat6x
JDK_OSREL= freebsd6
.elif ${OSVERSION} >= 600000
JDK_OSREL= freebsd6
-.elif ${OSVERSION} >= 500000 && ${ARCH} == "i386"
+.elif ${ARCH} == "i386"
JDK_OSREL= freebsd5
.else
IGNORE= Only available for FreeBSD 5.x/i386 and FreeBSD 6.x/amd64 and later
diff --git a/java/diablo-jre15/Makefile b/java/diablo-jre15/Makefile
index 78f4687fa5a3..d82167aaf718 100644
--- a/java/diablo-jre15/Makefile
+++ b/java/diablo-jre15/Makefile
@@ -50,7 +50,7 @@ LIB_DEPENDS= z.3:${PORTSDIR}/misc/compat6x
JRE_OSREL= freebsd6
.elif ${OSVERSION} >= 600000
JRE_OSREL= freebsd6
-.elif ${OSVERSION} >= 500000 && ${ARCH} == "i386"
+.elif ${ARCH} == "i386"
JRE_OSREL= freebsd5
.else
IGNORE= Only available for FreeBSD 5.x/i386 and FreeBSD 6.x/amd64 and later
diff --git a/java/ecj-bootstrap/Makefile b/java/ecj-bootstrap/Makefile
index 0138ab8556bf..ad15e10f6374 100644
--- a/java/ecj-bootstrap/Makefile
+++ b/java/ecj-bootstrap/Makefile
@@ -29,8 +29,8 @@ ANT_VERSION= 1.6.5
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000 || ${OSVERSION} > 700000
-IGNORE= dumps core on FreeBSD 4.x and 7.x
+.if ${OSVERSION} > 700000
+IGNORE= dumps core on 7.x
.endif
GCJ= gcj41
diff --git a/java/jmp/Makefile b/java/jmp/Makefile
index 52f6a62a2eb8..ac17e8bce6ce 100644
--- a/java/jmp/Makefile
+++ b/java/jmp/Makefile
@@ -61,8 +61,4 @@ CFLAGS+= -DJMPDEBUG -g
CFLAGS+= -O3
.endif
-.if ${OSVERSION} < 500000
-BROKEN= Does not build on FreeBSD < 5.x
-.endif
-
.include <bsd.port.post.mk>
diff --git a/java/netbeans3/Makefile b/java/netbeans3/Makefile
index 9962b078c965..8566710de0a6 100644
--- a/java/netbeans3/Makefile
+++ b/java/netbeans3/Makefile
@@ -33,11 +33,9 @@ DOWNLOAD_URL?= http://www.netbeans.org/download/release36/promoted/FCS/release36
IGNORE= you must manually fetch the source distribution (${DISTFILES}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
-.if ${OSVERSION} >= 500000
post-patch:
@${CAT} ${FILESDIR}/bin_runide.sh.diff | ${PATCH} ${WRKSRC}/bin/runide.sh
@${RM} ${WRKSRC}/bin/runide.sh.orig
-.endif
do-install:
@${MKDIR} ${PREFIX}/netbeans3