aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 11:46:54 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 11:46:54 +0000
commit4ad115ab4e7cbe42412a4185a32532ea7f4b9b86 (patch)
tree4d7c2d928bc64195e60de1e71fe1b58b1e0609b6 /java
parent0f3d0b5eb8897f1c27b64a652519e71abd896216 (diff)
downloadports-4ad115ab4e7cbe42412a4185a32532ea7f4b9b86.tar.gz
ports-4ad115ab4e7cbe42412a4185a32532ea7f4b9b86.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/classpath/Makefile2
-rw-r--r--java/eclipse/Makefile2
-rw-r--r--java/icedtea-web/Makefile2
-rw-r--r--java/jamvm/Makefile2
-rw-r--r--java/sablevm/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
index ef42cdfd6752..fb7310e5fd9e 100644
--- a/java/classpath/Makefile
+++ b/java/classpath/Makefile
@@ -17,11 +17,11 @@ COMMENT= A GNU project to create a free Java class library
LICENSE= GPLv2
GNU_CONFIGURE= yes
+USES= pkgconfig
USE_GMAKE= yes
USE_ICONV= yes
USE_LDCONFIG= yes
USE_PERL5_BUILD=yes
-USE_PKGCONFIG= build
USE_XORG= x11 ice xtst xaw xproto xext
WANT_GNOME= yes
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index 2498d87a6069..6170465eca07 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -40,11 +40,11 @@ TESTS_DESC= Build SDK test suite
ONLY_FOR_ARCHS= i386 amd64
+USES= pkgconfig
USE_ANT= yes
USE_GL= glu
USE_GMAKE= yes
USE_GNOME= desktopfileutils gconf2 gtk20 gnomevfs2 libgnome libgnomeui
-USE_PKGCONFIG= build
USE_JAVA= yes
USE_XZ= yes
BZIP2_SUFX= .tar.bz2
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index d57938b9cda7..41f056ff0ed6 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -21,7 +21,7 @@ USE_JAVA= yes
JAVA_OS= native
JAVA_VENDOR= openjdk
JAVA_VERSION= 1.6+
-USE_PKGCONFIG= yes
+USES= pkgconfig
USE_PERL5_BUILD=yes
USE_XORG= x11
WANT_GNOME= yes
diff --git a/java/jamvm/Makefile b/java/jamvm/Makefile
index ad624086a40a..0e21d3d28dad 100644
--- a/java/jamvm/Makefile
+++ b/java/jamvm/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${LOCALBASE}/share/classpath/glibj.zip:${PORTSDIR}/java/classpath
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-classpath-install-dir=${LOCALBASE}
USE_GMAKE= yes
-USE_PKGCONFIG= build
+USES= pkgconfig
OPTIONS_DEFINE= FFI ZIP
OPTIONS_DEFAULT=FFI ZIP
diff --git a/java/sablevm/Makefile b/java/sablevm/Makefile
index e8f853d3b580..c84e9b7e873c 100644
--- a/java/sablevm/Makefile
+++ b/java/sablevm/Makefile
@@ -22,7 +22,7 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_LDCONFIG= yes
-USE_PKGCONFIG= build
+USES= pkgconfig
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib