aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2016-03-12 12:56:28 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2016-03-12 12:56:28 +0000
commitf1bfb634a2ed7e02ed293a358fe098aea703149b (patch)
treef537edc6170965dc0a8d5c959f5d887981523906 /java
parentb93c649781ce9e0987c1a1f14d0ff5a7d2271e5d (diff)
downloadports-f1bfb634a2ed7e02ed293a358fe098aea703149b.tar.gz
ports-f1bfb634a2ed7e02ed293a358fe098aea703149b.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/eclipse/Makefile10
-rw-r--r--java/eclipse/distinfo8
-rw-r--r--java/eclipse/files/patch-aggregator10
-rw-r--r--java/eclipse/files/patch-freebsd_natives12
4 files changed, 20 insertions, 20 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index bd8b9488d9f4..7b358e079215 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= eclipse
-PORTVERSION= 4.5.1
+PORTVERSION= 4.5.2
CATEGORIES= java devel
MASTER_SITES= https://googledrive.com/host/0B2kYpXHnC5LpSk01bU1ud0N5bXc/
DISTFILES= eclipse.platform.releng.aggregator-${PORTVERSION}.xz \
@@ -10,7 +10,7 @@ DISTFILES= eclipse.platform.releng.aggregator-${PORTVERSION}.xz \
DIST_SUBDIR= eclipse
MAINTAINER= ljboiler@gmail.com
-COMMENT= Eclipse Mars.1
+COMMENT= Eclipse Mars.2
LICENSE= EPL
@@ -63,12 +63,12 @@ GITCLONE=${DISTDIR}/eclipse/eclipse-gitclone/eclipse.platform.releng.aggregator
MVN_LOCAL_REPO= -Dmaven.repo.local=${WRKDIR}/eclipse-maven-repo-${PORTVERSION}/repository
MVN_TEST_FLAG= -Dmaven.test.skip=true -DskipTests=true
-#MVN_SETTINGS+= --offline
-MVN_OPTS?= MAVEN_OPTS='-Xms1024m -Xmx1792m'
+MVN_SETTINGS+= --offline
+MVN_OPTS?= MAVEN_OPTS='-Xmx1024m'
ECLIPSE_WS= gtk
ECLIPSE_ARCH= x86${ARCH:C/^i.86//:C/^amd/_/}
E_SHORTARCH= ${ARCH:C/^i.86//:C/^amd//}
-ECLIPSE_BUILDID=I20150603-2000
+ECLIPSE_BUILDID=M20160212-1500
SCRIPTS_ENV+= ECLIPSE_ARCH=${ECLIPSE_ARCH} \
E_SHORTARCH=${E_SHORTARCH}
PORTDESTDIR= ${PREFIX}/lib/eclipse
diff --git a/java/eclipse/distinfo b/java/eclipse/distinfo
index 6e95b1d36c55..72419c0175b8 100644
--- a/java/eclipse/distinfo
+++ b/java/eclipse/distinfo
@@ -1,4 +1,4 @@
-SHA256 (eclipse/eclipse.platform.releng.aggregator-4.5.1.xz) = 294fedd5742a2755f4f46e0b0f825565b762def15760772351ac484bd08ae2a2
-SIZE (eclipse/eclipse.platform.releng.aggregator-4.5.1.xz) = 187196744
-SHA256 (eclipse/eclipse-maven-repo-4.5.1.xz) = b28e70618b92d63eaae5d5919c6f6dd5d28ce14caa9e9ee9fd7a56630a90aa6b
-SIZE (eclipse/eclipse-maven-repo-4.5.1.xz) = 131884596
+SHA256 (eclipse/eclipse.platform.releng.aggregator-4.5.2.xz) = 71e46eadfcc7c8fd0c758585a228cdee5810bfbea3190a27b577e3e972b662b2
+SIZE (eclipse/eclipse.platform.releng.aggregator-4.5.2.xz) = 187185556
+SHA256 (eclipse/eclipse-maven-repo-4.5.2.xz) = 038fe0c5a2bed3e2d10611e79fb327a171ec4efe10f0dcbcf84630d0273d9eac
+SIZE (eclipse/eclipse-maven-repo-4.5.2.xz) = 138007292
diff --git a/java/eclipse/files/patch-aggregator b/java/eclipse/files/patch-aggregator
index ed9abf677513..246ddc43ec95 100644
--- a/java/eclipse/files/patch-aggregator
+++ b/java/eclipse/files/patch-aggregator
@@ -373,10 +373,10 @@ diff --git a/eclipse.platform.releng.tychoeclipsebuilder/pom.xml b/eclipse.platf
--- a/eclipse.platform.releng.tychoeclipsebuilder/pom.xml
+++ b/eclipse.platform.releng.tychoeclipsebuilder/pom.xml
@@ -35,6 +35,6 @@
- <module>platform.sdk</module>
- <module>sdk</module>
- <module>eclipse-junit-tests</module>
-- <module>eclipse.platform.repository</module>
-+ <!-- module>eclipse.platform.repository</module -->
+ <module>platform.sdk</module>
+ <module>sdk</module>
+ <module>eclipse-junit-tests</module>
+- <module>eclipse.platform.repository</module>
++ <!-- module>eclipse.platform.repository</module -->
</modules>
</project>
diff --git a/java/eclipse/files/patch-freebsd_natives b/java/eclipse/files/patch-freebsd_natives
index d5c5db13a7f6..2083dd8add40 100644
--- a/java/eclipse/files/patch-freebsd_natives
+++ b/java/eclipse/files/patch-freebsd_natives
@@ -47,7 +47,7 @@
@@ -15,10 +15,10 @@
<artifactId>eclipse.platform.resources</artifactId>
<groupId>eclipse.platform.resources</groupId>
- <version>4.5.1-SNAPSHOT</version>
+ <version>4.5.2-SNAPSHOT</version>
- <relativePath>../../</relativePath>
+ <relativePath>../../../../</relativePath>
</parent>
@@ -133,7 +133,7 @@
@@ -15,10 +15,10 @@
<artifactId>eclipse.platform.resources</artifactId>
<groupId>eclipse.platform.resources</groupId>
- <version>4.5.1-SNAPSHOT</version>
+ <version>4.5.2-SNAPSHOT</version>
- <relativePath>../../</relativePath>
+ <relativePath>../../../../</relativePath>
</parent>
@@ -209,7 +209,7 @@
Bundle-Vendor: %providerName
-Bundle-SymbolicName: org.eclipse.swt.gtk.linux.x86; singleton:=true
+Bundle-SymbolicName: org.eclipse.swt.gtk.freebsd.x86; singleton:=true
- Bundle-Version: 3.104.1.qualifier
+ Bundle-Version: 3.104.2.qualifier
Bundle-ManifestVersion: 2
Bundle-Localization: fragment
@@ -30,7 +30,7 @@
@@ -230,7 +230,7 @@
<groupId>org.eclipse.swt</groupId>
- <artifactId>org.eclipse.swt.gtk.linux.x86</artifactId>
+ <artifactId>org.eclipse.swt.gtk.freebsd.x86</artifactId>
- <version>3.104.1-SNAPSHOT</version>
+ <version>3.104.2-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<properties>
@@ -291,7 +291,7 @@
Bundle-Vendor: %providerName
-Bundle-SymbolicName: org.eclipse.swt.gtk.linux.x86_64; singleton:=true
+Bundle-SymbolicName: org.eclipse.swt.gtk.freebsd.x86_64; singleton:=true
- Bundle-Version: 3.104.1.qualifier
+ Bundle-Version: 3.104.2.qualifier
Bundle-ManifestVersion: 2
Bundle-Localization: fragment
@@ -30,7 +30,7 @@
@@ -328,7 +328,7 @@
<groupId>org.eclipse.swt</groupId>
- <artifactId>org.eclipse.swt.gtk.linux.x86_64</artifactId>
+ <artifactId>org.eclipse.swt.gtk.freebsd.x86_64</artifactId>
- <version>3.104.1-SNAPSHOT</version>
+ <version>3.104.2-SNAPSHOT</version>
<packaging>eclipse-plugin</packaging>
<properties>