aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2012-01-29 00:05:11 +0000
committerGreg Lewis <glewis@FreeBSD.org>2012-01-29 00:05:11 +0000
commit1b82ba59351c0e141faa9b58249d7ca7a91fe85d (patch)
tree305de5517ef33c42b06b09d3b2cf416c938e5685 /java
parentbb58f3474009148123fc9d1b2d6ceb547ccba7f1 (diff)
downloadports-1b82ba59351c0e141faa9b58249d7ca7a91fe85d.tar.gz
ports-1b82ba59351c0e141faa9b58249d7ca7a91fe85d.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-devel/Makefile2
-rw-r--r--java/eclipse-devel/files/freebsd-support.patch23
2 files changed, 24 insertions, 1 deletions
diff --git a/java/eclipse-devel/Makefile b/java/eclipse-devel/Makefile
index 3e9607e5a0f3..4c939045a93c 100644
--- a/java/eclipse-devel/Makefile
+++ b/java/eclipse-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= eclipse-devel
PORTVERSION= 3.7.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= java devel
MASTER_SITES= http://download.eclipse.org/technology/linuxtools/eclipse-build/3.7.x_Indigo/:1 \
http://download.eclipse.org/tools/orbit/downloads/drops/R20110523182458/repository/plugins/:2 \
diff --git a/java/eclipse-devel/files/freebsd-support.patch b/java/eclipse-devel/files/freebsd-support.patch
index c23dde56804a..e3c4ea0e6147 100644
--- a/java/eclipse-devel/files/freebsd-support.patch
+++ b/java/eclipse-devel/files/freebsd-support.patch
@@ -7349,3 +7349,26 @@ $FreeBSD$
org.eclipse.equinox.log,0.0.0=v20110502
org.eclipse.equinox.jmx.client,0.0.0=v20100503
org.eclipse.ui.win32,0.0.0=I20100509-0800
+--- build/eclipse-3.7.0-src/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/build.sh.orig 2011-05-27 13:45:22.000000000 -0500
++++ build/eclipse-3.7.0-src/plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/build.sh 2012-01-23 11:51:27.000000000 -0600
+@@ -25,7 +25,7 @@
+ fi
+
+ # Check if we have to compile external.xpt from external.idl
+-COMPONENTS_DIR=`pwd`/../../components
++COMPONENTS_DIR=`pwd`/../../org.eclipse.swt/components
+ if test ! -f ${COMPONENTS_DIR}/external.xpt; then
+ if test ! -f ${COMPONENTS_DIR}/external.idl; then
+ echo "Can't find ${COMPONENTS_DIR}/external.idl"
+@@ -179,9 +181,10 @@
+ elif [ x`pkg-config --exists libxul && echo YES` = "xYES" ]; then
+ XULRUNNER_INCLUDES=`pkg-config --cflags libxul`
+ XULRUNNER_LIBS=`pkg-config --libs libxul`
++ XULRUNNER_LIBS=`echo ${XULRUNNER_LIBS} -lxpcomglue`
+ export XULRUNNER_INCLUDES
+ export XULRUNNER_LIBS
+- MAKE_MOZILLA=make_xulrunner
++ MAKE_MOZILLA=`echo make_xulrunner make_xpcominit`
+ else
+ echo "None of the following libraries were found: Mozilla/XPCOM, Firefox/XPCOM, or XULRunner/XPCOM"
+ echo " *** Mozilla embedding support will not be compiled."