aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2020-11-18 11:15:56 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2020-11-18 11:15:56 +0000
commit3541ca6c206bb8ea37aa1503964bacb0e188b52e (patch)
tree0d292833c514a756340911be610321c701dba0c1 /java
parentbfe7ac7a92c748d9a048f3552465093db9c77674 (diff)
downloadports-3541ca6c206bb8ea37aa1503964bacb0e188b52e.tar.gz
ports-3541ca6c206bb8ea37aa1503964bacb0e188b52e.zip
java/javahelp: fix build with modern JDK
Notes
Notes: svn path=/head/; revision=555632
Diffstat (limited to 'java')
-rw-r--r--java/javahelp/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/java/javahelp/Makefile b/java/javahelp/Makefile
index ab5cb9912587..8b8ec7d4ef83 100644
--- a/java/javahelp/Makefile
+++ b/java/javahelp/Makefile
@@ -36,6 +36,10 @@ BUILD_WRKSRC= ${WRKSRC}/javahelp_nbproject
SUB_FILES= jhindexer \
jhsearch
+post-patch:
+ ${REINPLACE_CMD} '/javac.source/s,4,6,;/javac.target/s,4,6,' \
+ ${WRKSRC}/*/nbproject/project.properties
+
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/jhindexer ${WRKDIR}/jhsearch ${STAGEDIR}${PREFIX}/bin/
${INSTALL_DATA} ${BUILD_WRKSRC}/dist/lib/*.jar ${STAGEDIR}${JAVAJARDIR}/