aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-08-22 00:24:37 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-08-22 00:24:37 +0000
commit0074c5fa8cabe431c6868442326d476bb5ef2047 (patch)
tree1ef31ba9ad1115bd0e23a01a51630f10289403b1 /java
parent6b5fb87219ee4fff450c5a6daf74accfe83318ae (diff)
downloadports-0074c5fa8cabe431c6868442326d476bb5ef2047.tar.gz
ports-0074c5fa8cabe431c6868442326d476bb5ef2047.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/avis/Makefile3
-rw-r--r--java/commonclipse/Makefile3
-rw-r--r--java/eclipse-EPIC/Makefile3
-rw-r--r--java/eclipse-RDT/Makefile3
-rw-r--r--java/eclipse-checkstyle/Makefile3
-rw-r--r--java/eclipse-drjava/Makefile3
-rw-r--r--java/eclipse-findbugs/Makefile2
-rw-r--r--java/eclipse-hibernatetools/Makefile3
-rw-r--r--java/eclipse-jad/Makefile3
-rw-r--r--java/eclipse-pmd/Makefile3
-rw-r--r--java/eclipse-pydev/Makefile2
-rw-r--r--java/eclipse-quantum/Makefile3
-rw-r--r--java/eclipse-shelled/Makefile3
-rw-r--r--java/eclipse-sqlexplorer/Makefile3
-rw-r--r--java/eclipse-v4all/Makefile3
-rw-r--r--java/eclipseme/Makefile2
-rw-r--r--java/jamvm/Makefile2
-rw-r--r--java/jasmin/Makefile3
-rw-r--r--java/jaxen/Makefile3
-rw-r--r--java/jboss2/Makefile3
-rw-r--r--java/jboss3/Makefile3
-rw-r--r--java/jboss4/Makefile3
-rw-r--r--java/jboss5/Makefile3
-rw-r--r--java/jc/Makefile3
-rw-r--r--java/jcckit/Makefile3
-rw-r--r--java/jcommon/Makefile3
-rw-r--r--java/jfreechart/Makefile2
-rw-r--r--java/jgrapht/Makefile3
-rw-r--r--java/jikes/Makefile3
-rw-r--r--java/jlint/Makefile3
-rw-r--r--java/jode/Makefile3
-rw-r--r--java/jump/Makefile3
-rw-r--r--java/mx4j/Makefile2
-rw-r--r--java/phpeclipse/Makefile2
-rw-r--r--java/sablevm-classpath/Makefile3
-rw-r--r--java/springframework/Makefile2
-rw-r--r--java/veditor/Makefile2
-rw-r--r--java/xdoclet/Makefile3
38 files changed, 38 insertions, 67 deletions
diff --git a/java/avis/Makefile b/java/avis/Makefile
index d089329277e9..34066dd5fd7c 100644
--- a/java/avis/Makefile
+++ b/java/avis/Makefile
@@ -9,8 +9,7 @@ PORTNAME= avis
PORTVERSION= 1.2.0
PORTREVISION= 1
CATEGORIES= java net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= avis
+MASTER_SITES= SF/${PORTNAME}/Avis%20router/Release%20${PORTVERSION}
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= benjsc@FreeBSD.org
diff --git a/java/commonclipse/Makefile b/java/commonclipse/Makefile
index 155fa16fba8a..5438e1b3dc27 100644
--- a/java/commonclipse/Makefile
+++ b/java/commonclipse/Makefile
@@ -9,8 +9,7 @@ PORTNAME= commonclipse
PORTVERSION= 1.3.0
PORTREVISION= 1
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= commonclipse
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}%20for%20eclipse%203.1M6%20and%20up
DISTNAME= net.sf.commonclipse_${PORTVERSION}
DIST_SUBDIR= eclipse
diff --git a/java/eclipse-EPIC/Makefile b/java/eclipse-EPIC/Makefile
index a36041fe99f9..ee5ef495e8f1 100644
--- a/java/eclipse-EPIC/Makefile
+++ b/java/eclipse-EPIC/Makefile
@@ -9,8 +9,7 @@ PORTNAME= EPIC
PORTVERSION= 0.6.13
PORTREVISION= 1
CATEGORIES= java editors devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= e-p-i-c
+MASTER_SITES= SF/e-p-i-c/e-p-i-c/${PORTNAME}%20${PORTVERSION}
PKGNAMEPREFIX= eclipse-
DISTNAME= ${EPIC}_${PORTVERSION}_20070808
diff --git a/java/eclipse-RDT/Makefile b/java/eclipse-RDT/Makefile
index 3b503765ec12..0890e9590e6a 100644
--- a/java/eclipse-RDT/Makefile
+++ b/java/eclipse-RDT/Makefile
@@ -9,8 +9,7 @@ PORTNAME= RDT
PORTVERSION= 0.9.1
PORTREVISION= 1
CATEGORIES= java editors devel
-MASTER_SITES= SF
-MASTER_SITE_SUBDIR= rubyeclipse
+MASTER_SITES= SF/rubyeclipse/${PORTNAME:L}/${PORTNAME}%20${PORTVERSION}
PKGNAMEPREFIX= eclipse-
DISTNAME= ${RDT}-${RDTVERSION}
diff --git a/java/eclipse-checkstyle/Makefile b/java/eclipse-checkstyle/Makefile
index bb4e71f8250c..f21a6d3f3de1 100644
--- a/java/eclipse-checkstyle/Makefile
+++ b/java/eclipse-checkstyle/Makefile
@@ -9,8 +9,7 @@ PORTNAME= checkstyle
PORTVERSION= 3.4.1.0
PORTREVISION= 4
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= eclipse-cs
+MASTER_SITES= SF/eclipse-cs/Eclipse%20Checkstyle%20Plug-in/v3.4.1
PKGNAMEPREFIX= eclipse-
DISTNAME= com.atlassw.tools.eclipse.checkstyle_${PORTVERSION}
DIST_SUBDIR= eclipse
diff --git a/java/eclipse-drjava/Makefile b/java/eclipse-drjava/Makefile
index 2726c5ce69d3..7e62ed956ec7 100644
--- a/java/eclipse-drjava/Makefile
+++ b/java/eclipse-drjava/Makefile
@@ -9,8 +9,7 @@ PORTNAME= drjava
PORTVERSION= 0.9.8
PORTREVISION= 2
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= drjava
+MASTER_SITES= SF/${PORTNAME}/3.%20DrJava%20Eclipse%20Plug-in/${PORTNAME}-eclipse-${PORTVERSION}
PKGNAMEPREFIX= eclipse-
DISTNAME= drjava-eclipse-${PORTVERSION}
diff --git a/java/eclipse-findbugs/Makefile b/java/eclipse-findbugs/Makefile
index 03dfdc7e86df..a283ac7beebd 100644
--- a/java/eclipse-findbugs/Makefile
+++ b/java/eclipse-findbugs/Makefile
@@ -9,7 +9,7 @@ PORTNAME= findbugs
DISTVERSION= 1.3.2.20080222
PORTREVISION= 1
CATEGORIES= java devel
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20eclipse%20plugin/1.3.2
PKGNAMEPREFIX= eclipse-
DISTNAME= edu.umd.cs.findbugs.plugin.eclipse_${DISTVERSION}
DIST_SUBDIR= eclipse
diff --git a/java/eclipse-hibernatetools/Makefile b/java/eclipse-hibernatetools/Makefile
index 675d6d2b8f91..5f5d10d6131f 100644
--- a/java/eclipse-hibernatetools/Makefile
+++ b/java/eclipse-hibernatetools/Makefile
@@ -8,8 +8,7 @@
PORTNAME= hibernatetools
DISTVERSION= 3.2.3.GA
CATEGORIES= java devel databases
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= jboss
+MASTER_SITES= SF/jboss/JBossTools/JBossTools%202.1.2.GA
PKGNAMEPREFIX= eclipse-
DISTNAME= HibernateTools-${DISTVERSION}
DIST_SUBDIR= eclipse
diff --git a/java/eclipse-jad/Makefile b/java/eclipse-jad/Makefile
index b7d6404dd96e..3d53ed6b86e5 100644
--- a/java/eclipse-jad/Makefile
+++ b/java/eclipse-jad/Makefile
@@ -8,8 +8,7 @@
PORTNAME= jad
PORTVERSION= 3.3.0
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= jadclipse
+MASTER_SITES= SF/${PORTNAME}clipse/${PORTNAME}clipse3.3/${PORTVERSION}%20%28for%20Eclipse%20_%3D3.3M6%29
PKGNAMEPREFIX= eclipse-
DISTNAME= net.sf.jadclipse_${PORTVERSION}
EXTRACT_SUFX= .jar
diff --git a/java/eclipse-pmd/Makefile b/java/eclipse-pmd/Makefile
index 5d1360ad673b..70ee5fcc6507 100644
--- a/java/eclipse-pmd/Makefile
+++ b/java/eclipse-pmd/Makefile
@@ -9,8 +9,7 @@ PORTNAME= pmd
PORTVERSION= 2.0.5.v3
PORTREVISION= 4
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= pmd
+MASTER_SITES= SF/${PORTNAME}/OldFiles
PKGNAMEPREFIX= eclipse-
DISTNAME= pmd-eclipse3-site-2.0.5
DIST_SUBDIR= eclipse
diff --git a/java/eclipse-pydev/Makefile b/java/eclipse-pydev/Makefile
index 681a8966e69c..d4f1f8018d2f 100644
--- a/java/eclipse-pydev/Makefile
+++ b/java/eclipse-pydev/Makefile
@@ -9,7 +9,7 @@ PORTNAME= pydev
PORTVERSION= 1.4.7.2843
PORTREVISION= 0
CATEGORIES= java devel python
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Pydev%201.4.7
PKGNAMEPREFIX= eclipse-
DISTFILES= org.python.pydev.feature-${PORTVERSION}.zip
diff --git a/java/eclipse-quantum/Makefile b/java/eclipse-quantum/Makefile
index ff3bb95fe9aa..b7a8ea1e7013 100644
--- a/java/eclipse-quantum/Makefile
+++ b/java/eclipse-quantum/Makefile
@@ -9,8 +9,7 @@ PORTNAME= quantum
PORTVERSION= 3.0.1
PORTREVISION= 2
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= quantum
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-plugin/${PORTVERSION}
PKGNAMEPREFIX= eclipse-
DISTNAME= com.quantum.feature_${PORTVERSION}.bin.dist
DIST_SUBDIR= eclipse
diff --git a/java/eclipse-shelled/Makefile b/java/eclipse-shelled/Makefile
index 16cb9feb19ba..b12e857d7b77 100644
--- a/java/eclipse-shelled/Makefile
+++ b/java/eclipse-shelled/Makefile
@@ -9,8 +9,7 @@ PORTNAME= ShellEd
PORTVERSION= 1.0.2a
PORTREVISION= 1
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= shelled
+MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME:L}/1.0.2
PKGNAMEPREFIX= eclipse-
DISTNAME= shelled_${PORTVERSION}
DIST_SUBDIR= eclipse
diff --git a/java/eclipse-sqlexplorer/Makefile b/java/eclipse-sqlexplorer/Makefile
index 8e10c8a3491b..e3a8d9fdd1c1 100644
--- a/java/eclipse-sqlexplorer/Makefile
+++ b/java/eclipse-sqlexplorer/Makefile
@@ -9,8 +9,7 @@ PORTNAME= sqlexplorer
PORTVERSION= 2.2.4
PORTREVISION= 3
CATEGORIES= java
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= eclipsesql
+MASTER_SITES= SF/eclipsesql/SQL%20Explorer%20Plugin/${PORTVERSION}
PKGNAMEPREFIX= eclipse-
DISTNAME= net.sourceforge.${PORTNAME}_${PORTVERSION}
EXTRACT_SUFX= .zip
diff --git a/java/eclipse-v4all/Makefile b/java/eclipse-v4all/Makefile
index cc9f78ad2e56..24a743bbff4c 100644
--- a/java/eclipse-v4all/Makefile
+++ b/java/eclipse-v4all/Makefile
@@ -9,8 +9,7 @@ PORTNAME= v4all
PORTVERSION= 2.1.1.9
PORTREVISION= 2
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= v4all
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}_2_1_1_9
DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}
MAINTAINER= wes@freebsd.org
diff --git a/java/eclipseme/Makefile b/java/eclipseme/Makefile
index 685c7d5a74e4..18cef4102f18 100644
--- a/java/eclipseme/Makefile
+++ b/java/eclipseme/Makefile
@@ -9,7 +9,7 @@ PORTNAME= eclipseme
PORTVERSION= 0.4.6
PORTREVISION= 2
CATEGORIES= java devel
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/OldFiles
DISTNAME= ${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= eclipse
diff --git a/java/jamvm/Makefile b/java/jamvm/Makefile
index 21916f43f181..14fd57b5b2d9 100644
--- a/java/jamvm/Makefile
+++ b/java/jamvm/Makefile
@@ -8,7 +8,7 @@ PORTNAME= jamvm
PORTVERSION= 1.5.1
PORTREVISION= 2
CATEGORIES= java devel
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/JamVM%20${PORTVERSION}
MAINTAINER= bkoenig@alpha-tierchen.de
COMMENT= A compact Java virtual machine
diff --git a/java/jasmin/Makefile b/java/jasmin/Makefile
index baf90d3f98e7..6fd85c9b3b84 100644
--- a/java/jasmin/Makefile
+++ b/java/jasmin/Makefile
@@ -10,8 +10,7 @@ PORTVERSION= 2.3
PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= java lang
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Java Assembler Interface
diff --git a/java/jaxen/Makefile b/java/jaxen/Makefile
index c5889e2047b2..b7cc0c25cbc1 100644
--- a/java/jaxen/Makefile
+++ b/java/jaxen/Makefile
@@ -8,8 +8,7 @@ PORTNAME= jaxen
PORTVERSION= 1.0
PORTREVISION= 4
CATEGORIES= java textproc
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1-0-FCS
DISTNAME= ${PORTNAME}-${PORTVERSION}-FCS
MAINTAINER= hq@FreeBSD.org
diff --git a/java/jboss2/Makefile b/java/jboss2/Makefile
index 4ccf88f02858..0bc32631f3c4 100644
--- a/java/jboss2/Makefile
+++ b/java/jboss2/Makefile
@@ -9,8 +9,7 @@ PORTNAME= ${APP_TITLE:L}
PORTVERSION= 2.4.11
PORTREVISION= 3
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF/${PORTNAME}/OldFiles
DISTNAME= ${APP_TITLE}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
diff --git a/java/jboss3/Makefile b/java/jboss3/Makefile
index 776d8fa31268..4355c4948987 100644
--- a/java/jboss3/Makefile
+++ b/java/jboss3/Makefile
@@ -8,8 +8,7 @@
PORTNAME= ${APP_TITLE:L}
PORTVERSION= 3.2.8.SP1
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF/${PORTNAME}/JBoss/JBoss-${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= jonc@chen.org.nz
diff --git a/java/jboss4/Makefile b/java/jboss4/Makefile
index 727d77d5b64b..4fd1e78ee3df 100644
--- a/java/jboss4/Makefile
+++ b/java/jboss4/Makefile
@@ -9,8 +9,7 @@ PORTNAME= ${APP_TITLE:L}
PORTVERSION= 4.2.3.GA
PORTEPOCH= 1
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF/${PORTNAME}/JBoss/JBoss-${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
diff --git a/java/jboss5/Makefile b/java/jboss5/Makefile
index 7b63181a7e03..f4e9e2ae4fc8 100644
--- a/java/jboss5/Makefile
+++ b/java/jboss5/Makefile
@@ -10,8 +10,7 @@ PORTVERSION= 5.0.0.GA
PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF/${PORTNAME}/JBoss/JBoss-${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
diff --git a/java/jc/Makefile b/java/jc/Makefile
index 0b5f4833791b..4bd8df45e4b3 100644
--- a/java/jc/Makefile
+++ b/java/jc/Makefile
@@ -9,8 +9,7 @@ PORTNAME= jc
PORTVERSION= 1.4.7
PORTREVISION= 4
CATEGORIES= java
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR=jcvm/
+MASTER_SITES= SF/${PORTNAME}vm/JC%20source%20distribution/Release%20${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= JVM that converts class files to C source and compiles them with GCC
diff --git a/java/jcckit/Makefile b/java/jcckit/Makefile
index 4a0f4bcd29ee..1e32de6db699 100644
--- a/java/jcckit/Makefile
+++ b/java/jcckit/Makefile
@@ -10,8 +10,7 @@ PORTNAME= jcckit
PORTVERSION= 1.1
PORTREVISION= 2
CATEGORIES= java graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/JCCKit%20${PORTVERSION}
DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
diff --git a/java/jcommon/Makefile b/java/jcommon/Makefile
index bde8b956ee6a..04f20e767173 100644
--- a/java/jcommon/Makefile
+++ b/java/jcommon/Makefile
@@ -9,8 +9,7 @@
PORTNAME= jcommon
PORTVERSION= 1.0.16
CATEGORIES= java devel
-MASTER_SITES= SF
-MASTER_SITE_SUBDIR= jfreechart
+MASTER_SITES= SF/jfreechart/3.%20JCommon/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A collection of useful classes used by JFreeChart and JFreeReport
diff --git a/java/jfreechart/Makefile b/java/jfreechart/Makefile
index a36cb89c1ada..82930e476d68 100644
--- a/java/jfreechart/Makefile
+++ b/java/jfreechart/Makefile
@@ -9,7 +9,7 @@
PORTNAME= jfreechart
PORTVERSION= 1.0.10
CATEGORIES= java graphics
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/1.%20JFreeChart/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A free Java class library for generating charts
diff --git a/java/jgrapht/Makefile b/java/jgrapht/Makefile
index 5ac366cc6293..50d9640f4cc1 100644
--- a/java/jgrapht/Makefile
+++ b/java/jgrapht/Makefile
@@ -9,8 +9,7 @@ PORTNAME= jgrapht
PORTVERSION= 0.7.3
PORTREVISION= 1
CATEGORIES= java math
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF/${PORTNAME}/JGraphT/Version%20${PORTVERSION}
MAINTAINER= hq@FreeBSD.org
COMMENT= Java package for mathematical graph-theory objects and algorithms
diff --git a/java/jikes/Makefile b/java/jikes/Makefile
index 58fdee628199..1077e5d6e819 100644
--- a/java/jikes/Makefile
+++ b/java/jikes/Makefile
@@ -9,8 +9,7 @@ PORTNAME= jikes
PORTVERSION= 1.22
PORTREVISION= 1
CATEGORIES= java
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR=jikes/
+MASTER_SITES= SF/${PORTNAME}/Jikes/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A very fast Java source to byte-code compiler made available by IBM
diff --git a/java/jlint/Makefile b/java/jlint/Makefile
index f7718eda2c2a..184662b814c0 100644
--- a/java/jlint/Makefile
+++ b/java/jlint/Makefile
@@ -8,8 +8,7 @@
PORTNAME= jlint
PORTVERSION= 3.1
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Java program analyzer and checker
diff --git a/java/jode/Makefile b/java/jode/Makefile
index 4d5c30dc0f43..e385f4f97e22 100644
--- a/java/jode/Makefile
+++ b/java/jode/Makefile
@@ -8,8 +8,7 @@ PORTNAME= jode
PORTVERSION= 1.1.1.1
PORTREVISION= 2
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR=${PORTNAME}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.1.2-pre1
DISTNAME= ${PORTNAME}-${VENDOR_VERSION}
MAINTAINER= mi@aldan.algebra.com
diff --git a/java/jump/Makefile b/java/jump/Makefile
index 0b3690e4800c..965695a489f1 100644
--- a/java/jump/Makefile
+++ b/java/jump/Makefile
@@ -9,8 +9,7 @@ PORTNAME= jump
PORTVERSION= 0.5
PORTREVISION= 2
CATEGORIES= java math
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= jump-math
+MASTER_SITES= SF/${PORTNAME}-math/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Java library for arbitrary precision computations
diff --git a/java/mx4j/Makefile b/java/mx4j/Makefile
index 909ae16c9e4c..4d9fa32b7f03 100644
--- a/java/mx4j/Makefile
+++ b/java/mx4j/Makefile
@@ -9,7 +9,7 @@ PORTNAME= mx4j
PORTVERSION= 3.0.2
PORTREVISION= 1
CATEGORIES= java devel
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/MX4J%20Binary/${PORTVERSION}
MAINTAINER= simon@olofsson.de
COMMENT= Open Source implementation of the Java Management Extensions (JMX)
diff --git a/java/phpeclipse/Makefile b/java/phpeclipse/Makefile
index 3fd0af312e4b..eb48582ece93 100644
--- a/java/phpeclipse/Makefile
+++ b/java/phpeclipse/Makefile
@@ -8,7 +8,7 @@
PORTNAME= phpeclipse
PORTVERSION= 1.2.1
CATEGORIES= java editors devel
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/a%29%20Eclipse%203.3.x/PHPEclipse-${PORTVERSION}
DISTNAME= PHPEclipse_${PORTVERSION}_src
MAINTAINER= kamikaze@bsdforen.de
diff --git a/java/sablevm-classpath/Makefile b/java/sablevm-classpath/Makefile
index 9c04c161650a..2dcd9e7dc123 100644
--- a/java/sablevm-classpath/Makefile
+++ b/java/sablevm-classpath/Makefile
@@ -10,8 +10,7 @@ PORTNAME= sablevm-classpath
PORTVERSION= 1.13
PORTREVISION= 6
CATEGORIES= java
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= sablevm
+MASTER_SITES= SF/sablevm/sablevm/${PORTVERSION}
MAINTAINER= bkoenig@alpha-tierchen.de
COMMENT= Classpath of SableVM
diff --git a/java/springframework/Makefile b/java/springframework/Makefile
index 58d906d6b8c0..9a90fe9e8b5a 100644
--- a/java/springframework/Makefile
+++ b/java/springframework/Makefile
@@ -7,7 +7,7 @@
PORTNAME= springframework
PORTVERSION= 2.5.5
CATEGORIES= java devel
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-2/${PORTVERSION}
DISTNAME= spring-framework-${PORTVERSION}-with-dependencies
MAINTAINER= gerrit.beine@gmx.de
diff --git a/java/veditor/Makefile b/java/veditor/Makefile
index ddc7b7ff2d34..992344f42357 100644
--- a/java/veditor/Makefile
+++ b/java/veditor/Makefile
@@ -8,7 +8,7 @@
PORTNAME= veditor
PORTVERSION= 0.6.3
CATEGORIES= java cad
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20runtime/VEditor%20${PORTVERSION}
DISTNAME= net.sourceforge.${PORTNAME}_${PORTVERSION}
EXTRACT_SUFX= .jar
EXTRACT_ONLY=
diff --git a/java/xdoclet/Makefile b/java/xdoclet/Makefile
index 86bd70de8242..d68e508d45f3 100644
--- a/java/xdoclet/Makefile
+++ b/java/xdoclet/Makefile
@@ -10,8 +10,7 @@ PORTVERSION= 1.2.3
PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= java devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
DISTNAME= ${PORTNAME}-bin-${PORTVERSION}
DISTFILES= ${DISTNAME}.zip xjavadoc-${XJAVADOC_VER}.zip