aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-08-15 21:43:51 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2006-08-15 21:43:51 +0000
commit716fefb9b91fe5ec49440332cd3fc369d81b4f22 (patch)
tree921ca9148b02b092cec32870853cf3d7f81ffbb3 /java
parent262b13832f883befb691b6b19c688bbdebbed385 (diff)
downloadports-716fefb9b91fe5ec49440332cd3fc369d81b4f22.tar.gz
ports-716fefb9b91fe5ec49440332cd3fc369d81b4f22.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/Makefile1
-rw-r--r--java/eclipse-jad/Makefile40
-rw-r--r--java/eclipse-jad/distinfo3
-rw-r--r--java/eclipse-jad/pkg-descr3
4 files changed, 47 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index 36d610c21a32..81e82fc13a39 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -28,6 +28,7 @@
SUBDIR += eclipse-examples
SUBDIR += eclipse-gef
SUBDIR += eclipse-gef-examples
+ SUBDIR += eclipse-jad
SUBDIR += eclipse-langpack
SUBDIR += eclipse-log4e
SUBDIR += eclipse-lomboz
diff --git a/java/eclipse-jad/Makefile b/java/eclipse-jad/Makefile
new file mode 100644
index 000000000000..7c534023cd6e
--- /dev/null
+++ b/java/eclipse-jad/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: eclipse support for Jad
+# Date created: Tue Aug 15 21:22:20 UTC 2006
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jad
+PORTVERSION= 3.1
+CATEGORIES= java devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= jadclipse
+PKGNAMEPREFIX= eclipse-
+DISTNAME= jadclipse_3.1.0
+DIST_SUBDIR= eclipse
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY=
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Jad Java decompiler plugin for the Eclipse IDE
+
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
+ ${LOCALBASE}/bin/jad:${PORTSDIR}/java/jad
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+NO_EXTRACT= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+
+PLIST_FILES= eclipse/plugins/${DISTNAME}${EXTRACT_SUFX}
+
+post-extract:
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX} ${WRKSRC}
+
+do-install:
+ @${MKDIR} ${PREFIX}/eclipse/plugins
+ @${INSTALL_DATA} ${WRKSRC}/${DISTNAME}${EXTRACT_SUFX} ${PREFIX}/eclipse/plugins
+
+.include <bsd.port.mk>
diff --git a/java/eclipse-jad/distinfo b/java/eclipse-jad/distinfo
new file mode 100644
index 000000000000..fae0dd93f666
--- /dev/null
+++ b/java/eclipse-jad/distinfo
@@ -0,0 +1,3 @@
+MD5 (eclipse/jadclipse_3.1.0.jar) = 1c4d6b6c7ba5f91f68afa1da8a851d5c
+SHA256 (eclipse/jadclipse_3.1.0.jar) = 7a0999106afa2653a1d6d3ae5f4547bee71cf23ccadd9991431c3f168ec0e757
+SIZE (eclipse/jadclipse_3.1.0.jar) = 54556
diff --git a/java/eclipse-jad/pkg-descr b/java/eclipse-jad/pkg-descr
new file mode 100644
index 000000000000..b60004cea9b5
--- /dev/null
+++ b/java/eclipse-jad/pkg-descr
@@ -0,0 +1,3 @@
+Jad Java decompiler plugin for the Eclipse IDE.
+
+WWW: http://jadclipse.sourceforge.net/