aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-01-20 19:53:55 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-01-20 19:53:55 +0000
commita0c1e8baae85b2d157101b396b0a345232e3ea47 (patch)
treea5383b149bc526f30e2e6bafb0111e3728415b2f /java
parent8be6ffc4f3fda903005a356bfee167ca3f62ff34 (diff)
downloadports-a0c1e8baae85b2d157101b396b0a345232e3ea47.tar.gz
ports-a0c1e8baae85b2d157101b396b0a345232e3ea47.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/jdk13/Makefile11
-rw-r--r--java/jdk13/files/patch-os_linux.cpp13
2 files changed, 21 insertions, 3 deletions
diff --git a/java/jdk13/Makefile b/java/jdk13/Makefile
index 42b64800d4c4..da90f72b4c1d 100644
--- a/java/jdk13/Makefile
+++ b/java/jdk13/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jdk
PORTVERSION= ${JDK_VERSION}p${JDK_PATCHSET_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= java devel
MASTER_SITES= # http://www.sun.com/software/java2/download.html
# http://www.eyesbeyond.com/freebsddom/java/jdk13.html
@@ -108,6 +108,9 @@ HOTSPOT_TARGETS=compiler1 compiler2
PLIST_SUB+= HOTSPOT:="@comment "
.endif
+LD_LIBRARY_PATH_FILES= ../src/solaris/javavm/runtime/javai_md.c \
+ ../../hotspot1.3.1/src/os/linux/vm/os_linux.cpp
+
.include <bsd.port.pre.mk>
.if !defined(JDK13DIR)
@@ -191,8 +194,10 @@ pre-patch:
post-patch:
@-${FIND} ${WRKDIR} -name SCCS -exec ${RM} -rf {} \;
- @${REINPLACE_CMD} -e "s:%%LOCALBASE%%:${LOCALBASE}:" \
- ${WRKSRC}/../src/solaris/javavm/runtime/javai_md.c
+ @for file in ${LD_LIBRARY_PATH_FILES}; do \
+ ${REINPLACE_CMD} -e "s:%%LOCALBASE%%:${LOCALBASE}:" \
+ ${WRKSRC}/$${file}; \
+ done
.if defined(WITH_NATIVE_THREADS) || defined(WITH_HOTSPOT)
@for file in ${PTHREAD_FILES}; do \
${REINPLACE_CMD} -e "s:-pthread:${PTHREAD_LIBS}:g" ${WRKSRC}/$${file}; \
diff --git a/java/jdk13/files/patch-os_linux.cpp b/java/jdk13/files/patch-os_linux.cpp
new file mode 100644
index 000000000000..91bce20476cd
--- /dev/null
+++ b/java/jdk13/files/patch-os_linux.cpp
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- ../../hotspot1.3.1/src/os/linux/vm/os_linux.cpp.orig Tue Jan 20 10:49:50 2004
++++ ../../hotspot1.3.1/src/os/linux/vm/os_linux.cpp Tue Jan 20 10:50:14 2004
+@@ -319,7 +319,7 @@
+ #define SUNRSASIGN_JAR "/lib/sunrsasign.jar"
+ #define CLASSES_DIR "/classes"
+ #define EXTENSIONS_DIR "/lib/ext"
+-#define DEFAULT_LD_LIBRARY_PATH "/usr/lib" /* See ld.so.1(1) */
++#define DEFAULT_LD_LIBRARY_PATH "/usr/lib:%%LOCALBASE%%/lib" /* See ld.so.1(1) */
+
+ char *v; /* tmp var */
+ {