aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2019-10-16 15:29:32 +0000
committerRene Ladan <rene@FreeBSD.org>2019-10-16 15:29:32 +0000
commit13d4527a34237c3848445140a659128518ca196f (patch)
treea59de3287464c291f091b739fe407ba6df10c951 /java
parenta12065703469e10f4f34b1e43555af92cfceaa6c (diff)
downloadports-13d4527a34237c3848445140a659128518ca196f.tar.gz
ports-13d4527a34237c3848445140a659128518ca196f.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/Makefile3
-rw-r--r--java/eclipse-log4e/Makefile35
-rw-r--r--java/eclipse-log4e/distinfo2
-rw-r--r--java/eclipse-log4e/pkg-descr12
-rw-r--r--java/eclipse-lomboz/Makefile42
-rw-r--r--java/eclipse-lomboz/distinfo2
-rw-r--r--java/eclipse-lomboz/pkg-descr13
-rw-r--r--java/java-checkstyle/Makefile54
-rw-r--r--java/java-checkstyle/distinfo3
-rw-r--r--java/java-checkstyle/files/checkstyle.sh.in8
-rw-r--r--java/java-checkstyle/pkg-descr10
-rw-r--r--java/java-checkstyle/pkg-plist2
12 files changed, 0 insertions, 186 deletions
diff --git a/java/Makefile b/java/Makefile
index 80f8f69dc841..67fb007c7b20 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -28,8 +28,6 @@
SUBDIR += eclipse-drjava
SUBDIR += eclipse-ecj
SUBDIR += eclipse-findbugs
- SUBDIR += eclipse-log4e
- SUBDIR += eclipse-lomboz
SUBDIR += eclipse-pydev
SUBDIR += eclipse-shelled
SUBDIR += eclipse-windowbuilder
@@ -54,7 +52,6 @@
SUBDIR += jakarta-regexp
SUBDIR += jasmin
SUBDIR += jattach
- SUBDIR += java-checkstyle
SUBDIR += java-cup
SUBDIR += java-getopt
SUBDIR += java-subversion
diff --git a/java/eclipse-log4e/Makefile b/java/eclipse-log4e/Makefile
deleted file mode 100644
index a09bdfd23713..000000000000
--- a/java/eclipse-log4e/Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
-# Created by: sugimura@jp.FreeBSD.org
-# $FreeBSD$
-
-PORTNAME= log4e
-PORTVERSION= 1.5.1
-CATEGORIES= java
-MASTER_SITES= http://log4e.jayefem.de/download/eclipse3/
-PKGNAMEPREFIX= eclipse-
-DISTNAME= de.jayefem.${PORTNAME}_free_${PORTVERSION}
-DIST_SUBDIR= eclipse
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Eclipse plugin to use logger easily in Java projects
-
-BROKEN= unfetchable
-DEPRECATED= Unfetchable, unmaintained
-EXPIRATION_DATE= 2019-10-16
-
-RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:java/eclipse
-
-USES= zip
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-
-do-install:
- @${MKDIR} -p ${STAGEDIR}${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/plugins ${STAGEDIR}${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/features ${STAGEDIR}${PREFIX}/lib/eclipse
- @(cd ${WRKSRC}; ${FIND} -s features plugins -not -type d) \
- | ${SED} -ne 's,^,lib/eclipse/,p' >> ${TMPPLIST}
- @(cd ${WRKSRC}; ${FIND} -s -d features plugins -type d -empty) \
- | ${GREP} -vE 'plugins$$|features$$' \
- | ${SED} -ne 's,^,@dir lib/eclipse/,p' >> ${TMPPLIST}
-
-.include <bsd.port.mk>
diff --git a/java/eclipse-log4e/distinfo b/java/eclipse-log4e/distinfo
deleted file mode 100644
index e81b513ddae5..000000000000
--- a/java/eclipse-log4e/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (eclipse/de.jayefem.log4e_free_1.5.1.zip) = a3fc5d5648c2a27317941499906a8e9c7c68e85356f82b5d727e8b157cc8f829
-SIZE (eclipse/de.jayefem.log4e_free_1.5.1.zip) = 1705186
diff --git a/java/eclipse-log4e/pkg-descr b/java/eclipse-log4e/pkg-descr
deleted file mode 100644
index a36016542723..000000000000
--- a/java/eclipse-log4e/pkg-descr
+++ /dev/null
@@ -1,12 +0,0 @@
-Log4E
-
-Log4E is a free Eclipse Plugin which helps you to use your logger easily
-in Java Projects. The Plugin Log4E is not bound to any special logging
-framework. Thus you might be able to adapt to your own logger by defining
-your own templates using the preferences. It has active support for Log4j,
-Commons Logging and JDK 1.4 logging. Use the context menu of a java file
-or the context menu of an editor and get to the submenu "Log4".
-Notice that the editor submenu provides additional tasks.
-Every of the following tasks can be invoked either on class or on method level.
-
-WWW: http://log4e.jayefem.de
diff --git a/java/eclipse-lomboz/Makefile b/java/eclipse-lomboz/Makefile
deleted file mode 100644
index 9ebf0e05e631..000000000000
--- a/java/eclipse-lomboz/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# Created by: sugimura@jp.FreeBSD.org
-# $FreeBSD$
-
-PORTNAME= lomboz
-PORTVERSION= 3.1.r2
-PORTREVISION= 6
-CATEGORIES= java devel
-MASTER_SITES= http://download.forge.objectweb.org/lomboz/ \
- http://download.fr2.forge.objectweb.org/lomboz/ \
- http://download.zh.forge.objectweb.org/lomboz/
-PKGNAMEPREFIX= eclipse-
-DISTNAME= lomboz-emf-gef-jem-${PORTVERSION:S/.r/RC/}
-DIST_SUBDIR= eclipse
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= J2EE developer tool build as a plugin for the eclipse platform
-
-BROKEN= unfetchable
-DEPRECATED= Unfetchable, unmaintained
-EXPIRATION_DATE= 2019-10-16
-
-RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:java/eclipse
-
-CONFLICTS= eclipse-webtools-0.7*
-
-USES= zip
-NO_BUILD= yes
-NO_WRKSUBDIR= yes
-USE_JAVA= yes
-JAVA_VERSION= 1.6+
-JAVA_OS= native
-
-do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${STAGEDIR}${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${STAGEDIR}${PREFIX}/lib/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
- @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d -empty) \
- | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dir lib/,p' >> ${TMPPLIST}
-
-.include <bsd.port.mk>
diff --git a/java/eclipse-lomboz/distinfo b/java/eclipse-lomboz/distinfo
deleted file mode 100644
index 76ff5c353227..000000000000
--- a/java/eclipse-lomboz/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (eclipse/lomboz-emf-gef-jem-3.1RC2.zip) = 731513523eb45e909ba648e3eac92ee6c289068f8f49da93428573f4e9e73536
-SIZE (eclipse/lomboz-emf-gef-jem-3.1RC2.zip) = 44022854
diff --git a/java/eclipse-lomboz/pkg-descr b/java/eclipse-lomboz/pkg-descr
deleted file mode 100644
index 1b453cb8c0fd..000000000000
--- a/java/eclipse-lomboz/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-Lomboz is an open source and free J2EE development environment
-for businesses and individuals.
-
-You can develop, test, profile and deploy Web, Web services, Java,
-J2EE and EJB applications with this IDE. Lomboz has comprehensive
-support for most J2EE standard application server runtimes, and
-supports most popular open source runtimes such as JOnAS, and
-other vendor runtime environments.
-
-Lomboz is buillt on the Eclipse open source platform and the Web
-Tools Platform (WTP) projects.
-
-WWW: http://lomboz.objectweb.org/
diff --git a/java/java-checkstyle/Makefile b/java/java-checkstyle/Makefile
deleted file mode 100644
index 07cc0d43107e..000000000000
--- a/java/java-checkstyle/Makefile
+++ /dev/null
@@ -1,54 +0,0 @@
-# Created by: Dave Glowacki <dglo@ssec.wisc.edu>
-# $FreeBSD$
-
-PORTNAME= checkstyle
-PORTVERSION= 8.9
-CATEGORIES= java devel
-MASTER_SITES= SF
-PKGNAMEPREFIX= java-
-DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Java style checker
-
-LICENSE= LGPL21 APACHE20
-LICENSE_COMB= dual
-
-BROKEN= unfetchable
-DEPRECATED= Unfetchable, unmaintained
-EXPIRATION_DATE= 2019-10-16
-
-USE_JAVA= yes
-JAVA_VERSION= 1.6+
-NO_BUILD= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
-JAR_FILE= ${PORTNAME}-${PORTVERSION}-all.jar
-
-PORTDOCS= *
-PORTEXAMPLES= *
-
-SUB_FILES= ${PORTNAME}.sh
-
-OPTIONS_DEFINE= DOCS EXAMPLES
-NO_ARCH= yes
-
-do-install:
- @-${MKDIR} ${STAGEDIR}${JAVAJARDIR}
- ${INSTALL_DATA} ${WRKSRC}/${JAR_FILE} \
- ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}.jar
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh \
- ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-
-do-install-DOCS-on:
- @-${MKDIR} ${STAGEDIR}${DOCSDIR}
- (cd ${WRKSRC} && ${INSTALL_DATA} LICENSE* RIGHTS.antlr \
- ${STAGEDIR}${DOCSDIR})
-
-do-install-EXAMPLES-on:
- @-${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
-.for EXAMPLEFILE in checkstyle_checks import-control suppressions
- ${INSTALL_DATA} ${WRKSRC}/config/${EXAMPLEFILE}.xml ${STAGEDIR}${EXAMPLESDIR}
-.endfor
-
-.include <bsd.port.mk>
diff --git a/java/java-checkstyle/distinfo b/java/java-checkstyle/distinfo
deleted file mode 100644
index b10ee772db76..000000000000
--- a/java/java-checkstyle/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1524580389
-SHA256 (checkstyle-8.9-bin.tar.gz) = 8d25b45a5efd3e2d776b0b01f09bf9ce1d0c8899a226f4cbc7f6f04fab731415
-SIZE (checkstyle-8.9-bin.tar.gz) = 19538240
diff --git a/java/java-checkstyle/files/checkstyle.sh.in b/java/java-checkstyle/files/checkstyle.sh.in
deleted file mode 100644
index 0207a035ee0a..000000000000
--- a/java/java-checkstyle/files/checkstyle.sh.in
+++ /dev/null
@@ -1,8 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-
-JAVA_VERSION="%%JAVA_VERSION%%" \
- exec "%%LOCALBASE%%/bin/java" \
- -cp "%%JAVAJARDIR%%/checkstyle.jar" \
- com.puppycrawl.tools.checkstyle.Main "$@"
diff --git a/java/java-checkstyle/pkg-descr b/java/java-checkstyle/pkg-descr
deleted file mode 100644
index 7125e6e66e09..000000000000
--- a/java/java-checkstyle/pkg-descr
+++ /dev/null
@@ -1,10 +0,0 @@
-Checkstyle is a development tool to help programmers write Java code
-that adheres to a coding standard. It automates the process of
-checking Java code to spare humans of this boring (but important)
-task. This makes it ideal for projects that want to enforce a coding
-standard.
-
-Checkstyle can be used as either a commandline utility or as an
-Ant task.
-
-WWW: http://checkstyle.sourceforge.net/
diff --git a/java/java-checkstyle/pkg-plist b/java/java-checkstyle/pkg-plist
deleted file mode 100644
index 5ebd15d8aa87..000000000000
--- a/java/java-checkstyle/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/checkstyle
-%%JAVAJARDIR%%/checkstyle.jar