aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-17 12:13:58 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-17 12:13:58 +0000
commit5e497ab4731ecfe3b7735a5a7132313c308e2cfa (patch)
treeb948905743547f7a02487b86be0c01759c0e639c /java
parent5d6545d27c604bd78f06febd4784c53608cafa94 (diff)
downloadports-5e497ab4731ecfe3b7735a5a7132313c308e2cfa.tar.gz
ports-5e497ab4731ecfe3b7735a5a7132313c308e2cfa.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-ocl/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/java/eclipse-ocl/Makefile b/java/eclipse-ocl/Makefile
index 988e9d6d8b1e..316ae61306aa 100644
--- a/java/eclipse-ocl/Makefile
+++ b/java/eclipse-ocl/Makefile
@@ -24,14 +24,13 @@ USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
-NO_STAGE= yes
do-install:
- @${MKDIR} ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
- @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
- | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${STAGEDIR}${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
+ @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
+ | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
+ | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
.include <bsd.port.mk>