aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2019-08-30 21:21:09 +0000
committerGreg Lewis <glewis@FreeBSD.org>2019-08-30 21:21:09 +0000
commit78f6f0f5777161a74627be261d2fe13acef461dc (patch)
tree633ed93d0e5ecf7e44acc87d681c05ba73e4c7a5 /java
parentb01039c25b498022f040db557dc330a0ef1d1d30 (diff)
Notes
Diffstat (limited to 'java')
-rw-r--r--java/bootstrap-openjdk11/Makefile13
-rw-r--r--java/bootstrap-openjdk11/distinfo4
2 files changed, 15 insertions, 2 deletions
diff --git a/java/bootstrap-openjdk11/Makefile b/java/bootstrap-openjdk11/Makefile
index bf61d4a86b36..bdde6df54b57 100644
--- a/java/bootstrap-openjdk11/Makefile
+++ b/java/bootstrap-openjdk11/Makefile
@@ -27,6 +27,17 @@ JDK_ARCH= ${ARCH}
INSTALLDIR= ${STAGEDIR}${PREFIX}/${JDK_ROOT}
+.include <bsd.port.pre.mk>
+
+# Support aarch64 on FreeBSD 12 and up
+.if ${OSVERSION} >= 1200500
+ONLY_FOR_ARCHS+=aarch64
+.endif
+
+.if ${ARCH} == aarch64
+DISTNAME= ${JDK_PORT}-${JDK_ARCH}-12-${PORTVERSION}
+.endif
+
post-extract:
-${MV} ${WRKSRC}/include/bsd ${WRKSRC}/include/freebsd
@@ -35,4 +46,4 @@ do-install:
@cd ${WRKSRC} && ${COPYTREE_BIN} bin ${INSTALLDIR}
@${CHMOD} a+x ${INSTALLDIR}/lib/jspawnhelper
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/java/bootstrap-openjdk11/distinfo b/java/bootstrap-openjdk11/distinfo
index f6e4cd31ce2c..e46dcb09cb39 100644
--- a/java/bootstrap-openjdk11/distinfo
+++ b/java/bootstrap-openjdk11/distinfo
@@ -1,4 +1,6 @@
-TIMESTAMP = 1566697022
+TIMESTAMP = 1567191227
+SHA256 (bootstrap-openjdk11-aarch64-12-11.0.2.9.2.tar.xz) = 03b15627aeda4ca1e2350c713323191728468110bf6c0f2eb233e08985d590c2
+SIZE (bootstrap-openjdk11-aarch64-12-11.0.2.9.2.tar.xz) = 99517364
SHA256 (bootstrap-openjdk11-amd64-11.0.2.9.2.tar.xz) = e53f16a33fca82db960b68ea200b6146eaf8b3ec8b09f5fe1c7711d926d94ffa
SIZE (bootstrap-openjdk11-amd64-11.0.2.9.2.tar.xz) = 102199460
SHA256 (bootstrap-openjdk11-i386-11.0.2.9.2.tar.xz) = 68b84741d7b8a7241fb30614881f15db3c174d973f999d34e0f53aca6190e00f