aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-17 09:33:41 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-17 09:33:41 +0000
commitea2e5a3457f61a2bcb52218bb31c3fef8a2aac72 (patch)
tree424a77c23e4a19c8abdbff9b505ce0d7b5d31f84 /java
parentf6f74eefb8f0d8a10c9b03b662e19fc650c02a05 (diff)
downloadports-ea2e5a3457f61a2bcb52218bb31c3fef8a2aac72.tar.gz
ports-ea2e5a3457f61a2bcb52218bb31c3fef8a2aac72.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-uml/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/java/eclipse-uml/Makefile b/java/eclipse-uml/Makefile
index d427fea8887e..a3948146f0d9 100644
--- a/java/eclipse-uml/Makefile
+++ b/java/eclipse-uml/Makefile
@@ -23,14 +23,13 @@ USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
-NO_STAGE= yes
do-install:
- @${MKDIR} ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
- @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
- | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${STAGEDIR}${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
+ @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
+ | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
+ | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
.include <bsd.port.mk>