aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2013-07-08 23:13:51 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2013-07-08 23:13:51 +0000
commitd4423f257b9056a840548fbdbfab7f24f1f56a4c (patch)
treea29b58cf2f5a93eb36f41bc8c002455ef90f60c0 /java
parentb72e612d953deb166b0fdca9773c663aac604969 (diff)
downloadports-d4423f257b9056a840548fbdbfab7f24f1f56a4c.tar.gz
ports-d4423f257b9056a840548fbdbfab7f24f1f56a4c.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/cacao/Makefile11
-rw-r--r--java/cacao/distinfo4
-rw-r--r--java/cacao/files/patch-boehm-gc__pthread_support.c20
-rw-r--r--java/cacao/files/patch-src__threads__thread.cpp22
-rw-r--r--java/cacao/files/patch-src__vm__jit__i386__freebsd__md-os.cpp (renamed from java/cacao/files/patch-src__vm__jit__i386__freebsd__md-os.c)19
-rw-r--r--java/cacao/files/patch-src__vm__jit__x86_64__freebsd__md-os.cpp (renamed from java/cacao/files/patch-src__vm__jit__x86_64__freebsd__md-os.c)43
6 files changed, 54 insertions, 65 deletions
diff --git a/java/cacao/Makefile b/java/cacao/Makefile
index 6f384ad98f9e..5eb42a8834a2 100644
--- a/java/cacao/Makefile
+++ b/java/cacao/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cacao
-PORTVERSION= 1.6.0
+PORTVERSION= 1.6.1
CATEGORIES= java devel
MASTER_SITES= http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PORTVERSION}/
@@ -20,7 +20,8 @@ USE_XZ= yes
MAN1= cacao.1
-CONFIGURE_ARGS= --with-java-runtime-library=gnuclasspath \
+CONFIGURE_ARGS= --disable-test-dependency-checks \
+ --with-java-runtime-library=gnuclasspath \
--with-java-runtime-library-prefix=${PREFIX} \
--with-build-java-runtime-library-classes=${LOCALBASE}/share/classpath/glibj.zip
CONFIGURE_ENV= JAVAC="${JAVAC}" JAR="${JAR}"
@@ -34,9 +35,9 @@ JDK_DESC= Build with native JDK
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MJDK}
-USE_JAVA= yes
-JAVA_BUILD= jdk
-JAVA_VERSION= 1.6+
+BUILD_DEPENDS+= ${LOCALBASE}/bootstrap-openjdk/bin/javac:${PORTSDIR}/java/bootstrap-openjdk
+JAR= ${LOCALBASE}/bootstrap-openjdk/bin/jar
+JAVAC= ${LOCALBASE}/bootstrap-openjdk/bin/javac
.else
.if defined(WITH_GCC)
GCC_SUFX= ${WITH_GCC:S/.//}
diff --git a/java/cacao/distinfo b/java/cacao/distinfo
index c3430b1c32d1..50906d499ea1 100644
--- a/java/cacao/distinfo
+++ b/java/cacao/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cacao-1.6.0.tar.xz) = e654e5f158b8fdc0b1282efacc370f6e65ee6c0336945506e86fd7e705d98626
-SIZE (cacao-1.6.0.tar.xz) = 2394588
+SHA256 (cacao-1.6.1.tar.xz) = eecc8bd1b528a028f43d9d1d0c06b97855bbf1d40e03826d911ebbc0b6971e12
+SIZE (cacao-1.6.1.tar.xz) = 2329964
diff --git a/java/cacao/files/patch-boehm-gc__pthread_support.c b/java/cacao/files/patch-boehm-gc__pthread_support.c
deleted file mode 100644
index 3e4cf7adf3e9..000000000000
--- a/java/cacao/files/patch-boehm-gc__pthread_support.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/mm/boehm-gc/pthread_support.c.orig 2012-09-03 12:10:00.000000000 -0400
-+++ src/mm/boehm-gc/pthread_support.c 2012-10-04 19:46:21.000000000 -0400
-@@ -1080,17 +1080,6 @@
- /* can't have been recycled by pthreads. */
- UNLOCK();
- result = REAL_FUNC(pthread_join)(thread, retval);
--# if defined (GC_FREEBSD_THREADS)
-- /* On FreeBSD, the wrapped pthread_join() sometimes returns (what
-- appears to be) a spurious EINTR which caused the test and real code
-- to gratuitously fail. Having looked at system pthread library source
-- code, I see how this return code may be generated. In one path of
-- code, pthread_join() just returns the errno setting of the thread
-- being joined. This does not match the POSIX specification or the
-- local man pages thus I have taken the liberty to catch this one
-- spurious return value properly conditionalized on GC_FREEBSD_THREADS. */
-- if (result == EINTR) result = 0;
--# endif
- if (result == 0) {
- LOCK();
- /* Here the pthread thread id may have been recycled. */
diff --git a/java/cacao/files/patch-src__threads__thread.cpp b/java/cacao/files/patch-src__threads__thread.cpp
index 2ab41b412ee9..8c3129188a93 100644
--- a/java/cacao/files/patch-src__threads__thread.cpp
+++ b/java/cacao/files/patch-src__threads__thread.cpp
@@ -1,11 +1,11 @@
---- src/threads/thread.cpp.orig 2012-09-03 12:10:00.000000000 -0400
-+++ src/threads/thread.cpp 2012-10-04 16:37:45.000000000 -0400
-@@ -37,6 +37,8 @@
-
- #if defined(__LINUX__)
- # define GC_LINUX_THREADS
-+#elif defined(__FREEBSD__)
-+# define GC_FREEBSD_THREADS
- #elif defined(__IRIX__)
- # define GC_IRIX_THREADS
- #elif defined(__DARWIN__)
+--- src/threads/thread.cpp.orig 2013-06-28 09:22:26.000000000 -0400
++++ src/threads/thread.cpp 2013-07-08 15:41:56.000000000 -0400
+@@ -51,6 +51,8 @@
+ #if defined(ENABLE_GC_BOEHM)
+ # if defined(__LINUX__)
+ # define GC_LINUX_THREADS
++# elif defined(__FREEBSD__)
++# define GC_FREEBSD_THREADS
+ # elif defined(__IRIX__)
+ # define GC_IRIX_THREADS
+ # elif defined(__DARWIN__)
diff --git a/java/cacao/files/patch-src__vm__jit__i386__freebsd__md-os.c b/java/cacao/files/patch-src__vm__jit__i386__freebsd__md-os.cpp
index 017e1a17b374..27513e080a7e 100644
--- a/java/cacao/files/patch-src__vm__jit__i386__freebsd__md-os.c
+++ b/java/cacao/files/patch-src__vm__jit__i386__freebsd__md-os.cpp
@@ -1,8 +1,8 @@
---- src/vm/jit/i386/freebsd/md-os.c.orig 2012-09-03 12:10:00.000000000 -0400
-+++ src/vm/jit/i386/freebsd/md-os.c 2012-10-04 17:01:47.000000000 -0400
+--- src/vm/jit/i386/freebsd/md-os.cpp.orig 2013-06-28 09:22:26.000000000 -0400
++++ src/vm/jit/i386/freebsd/md-os.cpp 2013-07-08 16:02:06.000000000 -0400
@@ -2,6 +2,7 @@
- Copyright (C) 1996-2005, 2006, 2007, 2008
+ Copyright (C) 1996-2013
CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
+ Copyright (C) 2009 Theobroma Systems Ltd.
@@ -15,8 +15,8 @@
-#include "vm/jit/builtin.hpp"
#include "vm/signallocal.hpp"
--#include "vm/jit/asmpart.h"
- #include "vm/jit/executionstate.h"
+-#include "vm/jit/asmpart.hpp"
+ #include "vm/jit/executionstate.hpp"
-#include "vm/jit/stacktrace.hpp"
#include "vm/jit/trap.hpp"
@@ -323,3 +323,12 @@
}
+@@ -341,7 +186,7 @@
+ * Emacs will automagically detect them.
+ * ---------------------------------------------------------------------
+ * Local variables:
+- * mode: c
++ * mode: c++
+ * indent-tabs-mode: t
+ * c-basic-offset: 4
+ * tab-width: 4
diff --git a/java/cacao/files/patch-src__vm__jit__x86_64__freebsd__md-os.c b/java/cacao/files/patch-src__vm__jit__x86_64__freebsd__md-os.cpp
index 621aa0073d45..0e178889bab1 100644
--- a/java/cacao/files/patch-src__vm__jit__x86_64__freebsd__md-os.c
+++ b/java/cacao/files/patch-src__vm__jit__x86_64__freebsd__md-os.cpp
@@ -1,41 +1,40 @@
---- src/vm/jit/x86_64/freebsd/md-os.c.orig 2012-09-03 12:10:00.000000000 -0400
-+++ src/vm/jit/x86_64/freebsd/md-os.c 2012-10-04 17:04:18.000000000 -0400
+--- src/vm/jit/x86_64/freebsd/md-os.cpp.orig 2013-06-28 09:22:27.000000000 -0400
++++ src/vm/jit/x86_64/freebsd/md-os.cpp 2013-07-08 16:05:56.000000000 -0400
@@ -2,7 +2,6 @@
- Copyright (C) 2007, 2008
+ Copyright (C) 1996-2013
CACAOVM - Verein zur Foerderung der freien virtuellen Maschine CACAO
- Copyright (C) 2009 Theobroma Systems Ltd.
This file is part of CACAO.
-@@ -27,80 +26,67 @@
- #include "config.h"
+@@ -28,79 +27,65 @@
- #include <assert.h>
+ #include <cassert>
+ #include <cstdlib>
+#include <stdint.h>
- #include <stdlib.h>
#include <ucontext.h>
-+#include "vm/types.h"
-+
-+#include "vm/jit/x86_64/codegen.h"
-+#include "vm/jit/x86_64/md.h"
-+
- #include "threads/thread.hpp"
-
- #include "vm/signallocal.hpp"
+-#include "threads/thread.hpp"
+-
+-#include "vm/signallocal.hpp"
++#include "vm/types.hpp"
- #include "vm/jit/asmpart.h"
+-#include "vm/jit/asmpart.hpp"
-#include "vm/jit/stacktrace.hpp"
--
--
++#include "vm/jit/x86_64/codegen.hpp"
++#include "vm/jit/x86_64/md.hpp"
+
++#include "threads/thread.hpp"
+
-/* md_signal_handler_sigsegv ***************************************************
-+#include "vm/jit/executionstate.h"
-+#include "vm/jit/trap.hpp"
++#include "vm/signallocal.hpp"
- NullPointerException signal handler for hardware null pointer
- check.
--
++#include "vm/jit/executionstate.hpp"
++#include "vm/jit/trap.hpp"
+
-*******************************************************************************/
+/**
@@ -126,7 +125,7 @@
}
-@@ -130,6 +116,88 @@
+@@ -130,6 +115,88 @@
#endif