aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2016-01-02 09:30:21 +0000
committerGreg Lewis <glewis@FreeBSD.org>2016-01-02 09:30:21 +0000
commit2813824f6f10df64382510504a911b474fd8ee82 (patch)
treee9792186d48b35fc468f5e14661b3166b62da277 /java
parenta8af8991fbde6ef089a7b7de921a34c009d00edb (diff)
downloadports-2813824f6f10df64382510504a911b474fd8ee82.tar.gz
ports-2813824f6f10df64382510504a911b474fd8ee82.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/openjdk8/Makefile2
-rw-r--r--java/openjdk8/files/patch-jdk-src-solaris-native-sun-management-BsdOperatingSystem.c45
2 files changed, 46 insertions, 1 deletions
diff --git a/java/openjdk8/Makefile b/java/openjdk8/Makefile
index 72d4b1ae95b8..7afd72ca4baf 100644
--- a/java/openjdk8/Makefile
+++ b/java/openjdk8/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openjdk
PORTVERSION= ${JDK_MAJOR_VERSION}.${JDK_UPDATE_VERSION}.${JDK_BUILD_NUMBER:S/^0//}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= java devel
MASTER_SITES= http://download.java.net/openjdk/jdk${JDK_MAJOR_VERSION}/promoted/b${DIST_BUILD_NUMBER}/:jdk \
https://adopt-openjdk.ci.cloudbees.com/job/jtreg/${JTREG_JENKINS_BUILD}/artifact/:jtreg \
diff --git a/java/openjdk8/files/patch-jdk-src-solaris-native-sun-management-BsdOperatingSystem.c b/java/openjdk8/files/patch-jdk-src-solaris-native-sun-management-BsdOperatingSystem.c
new file mode 100644
index 000000000000..ca63753113bb
--- /dev/null
+++ b/java/openjdk8/files/patch-jdk-src-solaris-native-sun-management-BsdOperatingSystem.c
@@ -0,0 +1,45 @@
+--- /dev/null 2016-01-01 15:03:12.000000000 -0800
++++ jdk/src/solaris/native/sun/management/BsdOperatingSystem.c 2016-01-01 15:01:40.593188000 -0800
+@@ -0,0 +1,42 @@
++/*
++ * Copyright (c) 2011, 2013, Oracle and/or its affiliates. All rights reserved.
++ * DO NOT ALTER OR REMOVE COPYRIGHT NOTICES OR THIS FILE HEADER.
++ *
++ * This code is free software; you can redistribute it and/or modify it
++ * under the terms of the GNU General Public License version 2 only, as
++ * published by the Free Software Foundation. Oracle designates this
++ * particular file as subject to the "Classpath" exception as provided
++ * by Oracle in the LICENSE file that accompanied this code.
++ *
++ * This code is distributed in the hope that it will be useful, but WITHOUT
++ * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
++ * FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
++ * version 2 for more details (a copy is included in the LICENSE file that
++ * accompanied this code).
++ *
++ * You should have received a copy of the GNU General Public License version
++ * 2 along with this work; if not, write to the Free Software Foundation,
++ * Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
++ *
++ * Please contact Oracle, 500 Oracle Parkway, Redwood Shores, CA 94065 USA
++ * or visit www.oracle.com if you need additional information or have any
++ * questions.
++ */
++
++#include <jni.h>
++#include "jvm.h"
++#include "sun_management_OperatingSystemImpl.h"
++
++JNIEXPORT jdouble JNICALL
++Java_sun_management_OperatingSystemImpl_getSystemCpuLoad
++(JNIEnv *env, jobject dummy)
++{
++ return (jdouble) -1;
++}
++
++JNIEXPORT jdouble JNICALL
++Java_sun_management_OperatingSystemImpl_getProcessCpuLoad
++(JNIEnv *env, jobject dummy)
++{
++ return (jdouble) -1;
++}