aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2007-12-24 23:37:47 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2007-12-24 23:37:47 +0000
commit86c83e2de46d1cb6bca643e72435a4fdbd384da4 (patch)
tree9c066056a83b14527a7eb51a9f7b8fbc3a777f02 /java
parente77df932c3b39c46053f41e20bf76c563f8b01c7 (diff)
downloadports-86c83e2de46d1cb6bca643e72435a4fdbd384da4.tar.gz
ports-86c83e2de46d1cb6bca643e72435a4fdbd384da4.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/Makefile1
-rw-r--r--java/eclipse-hibernatetools/Makefile86
-rw-r--r--java/eclipse-hibernatetools/distinfo3
-rw-r--r--java/eclipse-hibernatetools/pkg-descr20
-rw-r--r--java/eclipse-hibernatetools/pkg-plist278
5 files changed, 388 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index 85364a200b04..b5b417637329 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -33,6 +33,7 @@
SUBDIR += eclipse-findbugs
SUBDIR += eclipse-gef
SUBDIR += eclipse-gef-examples
+ SUBDIR += eclipse-hibernatetools
SUBDIR += eclipse-jad
SUBDIR += eclipse-langpack
SUBDIR += eclipse-log4e
diff --git a/java/eclipse-hibernatetools/Makefile b/java/eclipse-hibernatetools/Makefile
new file mode 100644
index 000000000000..dc6140ef8606
--- /dev/null
+++ b/java/eclipse-hibernatetools/Makefile
@@ -0,0 +1,86 @@
+# New ports collection makefile for: Eclipse Hibernate Tools
+# Date created: Mon 24 Dec 2007 11:16:09 UTC
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hibernatetools
+DISTVERSION= 3.2.0.beta9a
+CATEGORIES= java devel databases
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= jboss
+PKGNAMEPREFIX= eclipse-
+DISTNAME= HibernateTools-${DISTVERSION}
+DIST_SUBDIR= eclipse
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Hibernate3 Tools for the Eclipse IDE
+
+## XXX - Notify the maintainer if the dependencies on java/eclipse-webtools change
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
+ ${LOCALBASE}/eclipse/features/org.eclipse.wst.common_core.feature_1.5.2.v200610140800--AXrVWXbElCl05G/feature.xml:${PORTSDIR}/java/eclipse-webtools \
+ ${LOCALBASE}/eclipse/plugins/org.apache.xerces_2.8.0.v200606131651/plugin.properties:${PORTSDIR}/java/eclipse-webtools \
+ ${LOCALBASE}/eclipse/plugins/org.eclipse.wst.common.core_1.1.100.v200608220540.jar:${PORTSDIR}/java/eclipse-webtools \
+ ${LOCALBASE}/eclipse/plugins/org.eclipse.wst.common.environment_1.0.100.v200608251934.jar:${PORTSDIR}/java/eclipse-webtools \
+ ${LOCALBASE}/eclipse/plugins/org.eclipse.wst.common.project.facet.core_1.1.1.v200608112156.jar:${PORTSDIR}/java/eclipse-webtools \
+ ${LOCALBASE}/eclipse/plugins/org.eclipse.wst.common.project.facet.ui_1.1.1.v200608112156.jar:${PORTSDIR}/java/eclipse-webtools \
+ ${LOCALBASE}/eclipse/plugins/org.eclipse.wst.common.ui_1.1.100.v200608221521.jar:${PORTSDIR}/java/eclipse-webtools \
+ ${LOCALBASE}/eclipse/plugins/org.eclipse.wst.common.uriresolver_1.1.100.v200609200443.jar:${PORTSDIR}/java/eclipse-webtools \
+ ${LOCALBASE}/eclipse/plugins/org.eclipse.wst.dtd.core_1.1.1.v200609210600.jar:${PORTSDIR}/java/eclipse-webtools \
+ ${LOCALBASE}/eclipse/plugins/org.eclipse.wst.sse.core_1.1.100.v200609182120.jar:${PORTSDIR}/java/eclipse-webtools \
+ ${LOCALBASE}/eclipse/plugins/org.eclipse.wst.xml.core_1.1.1.v200609210600.jar:${PORTSDIR}/java/eclipse-webtools \
+ ${LOCALBASE}/eclipse/plugins/org.eclipse.wst.xml.ui_1.0.200.v200609221505.jar:${PORTSDIR}/java/eclipse-webtools
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_OS= native
+
+# remove plugins that are already installed
+DUPLICATE_PLUGINS= \
+ org.eclipse.wst.common.core_1.1.100.v200608220540.jar \
+ org.eclipse.wst.common.environment_1.0.100.v200608251934.jar \
+ org.eclipse.wst.common.project.facet.core_1.1.1.v200608112156.jar \
+ org.eclipse.wst.common.project.facet.ui_1.1.1.v200608112156.jar \
+ org.eclipse.wst.common.ui_1.1.100.v200608221521.jar \
+ org.eclipse.wst.common.uriresolver_1.1.100.v200609200443.jar \
+ org.eclipse.wst.dtd.core_1.1.1.v200609210600.jar \
+ org.eclipse.wst.sse.core_1.1.100.v200609182120.jar \
+ org.eclipse.wst.xml.core_1.1.1.v200609210600.jar \
+ org.eclipse.wst.xml.ui_1.0.200.v200609221505.jar
+
+post-extract:
+# avoid empty dirs since they break the automated PLIST generation
+ @${FIND} ${WRKSRC} -type d -empty \
+ -exec ${TOUCH} "{}/.keep_me" \;
+# remove plugins that are already installed
+.for plugin in ${DUPLICATE_PLUGINS}
+ @${RM} ${WRKSRC}/plugins/${plugin}
+.endfor
+ @${RM} -Rf ${WRKSRC}/plugins/org.apache.xerces_2.8.0.v200606131651/
+
+do-install:
+# create destination dir
+ @${MKDIR} ${PREFIX}/eclipse
+# install both files and directories
+ @(cd ${WRKSRC} && \
+ ${FIND} -s features plugins -type d \
+ -exec ${MKDIR} "${PREFIX}/eclipse/{}" \; && \
+ ${FIND} -s features plugins -not -type d \
+ -exec ${INSTALL_DATA} "{}" "${PREFIX}/eclipse/{}" \; \
+ )
+
+# used to manually generate the plist files
+generate-plist-locally: build
+# annotate installation files
+ @(cd ${WRKSRC} && ${FIND} -s features plugins -not -type d) \
+ | ${SED} -ne 's,^,eclipse/,p' > ${PLIST}
+# annotate installation directories
+ @(cd ${WRKSRC} && ${FIND} -s -d features plugins -type d) \
+ | ${GREP} -vE '^plugins$$|^features$$' \
+ | ${SED} -ne 's,^,@dirrm eclipse/,p' >> ${PLIST}
+
+.include <bsd.port.mk>
diff --git a/java/eclipse-hibernatetools/distinfo b/java/eclipse-hibernatetools/distinfo
new file mode 100644
index 000000000000..6a07ac934621
--- /dev/null
+++ b/java/eclipse-hibernatetools/distinfo
@@ -0,0 +1,3 @@
+MD5 (eclipse/HibernateTools-3.2.0.beta9a.zip) = 5babed40bfcc4a76e69a415824bded3f
+SHA256 (eclipse/HibernateTools-3.2.0.beta9a.zip) = f2a1ab5c06b95d808441b4950054ab8d40a34c634e548b8a5e4cdddcf32a1cbc
+SIZE (eclipse/HibernateTools-3.2.0.beta9a.zip) = 32689290
diff --git a/java/eclipse-hibernatetools/pkg-descr b/java/eclipse-hibernatetools/pkg-descr
new file mode 100644
index 000000000000..416574d985bc
--- /dev/null
+++ b/java/eclipse-hibernatetools/pkg-descr
@@ -0,0 +1,20 @@
+[ excerpt from developer's www site with modifications ]
+
+Hibernate Tools is an entirely new toolset for Hibernate3 implemented
+as an integrated suite of Eclipse plugins, together with a unified
+Ant task for integration into the build cycle. The following features
+are available:
+
++ Mapping Editor: An editor for Hibernate XML mapping files
++ Console: Allows you to configure database connections, provides
+ visualization of classes and their relationships and allows you
+ to execute HQL queries interactively against your database and
+ browse the query results.
++ Reverse Engineering: Database reverse engineering tool that can
+ generate domain model classes and Hibernate mapping files, annotated
+ EJB3 entity beans, HTML documentation or even an entire JBoss
+ Seam application in seconds!
++ Wizards
++ Ant task
+
+WWW: http://www.hibernate.org/
diff --git a/java/eclipse-hibernatetools/pkg-plist b/java/eclipse-hibernatetools/pkg-plist
new file mode 100644
index 000000000000..aa12f63ed368
--- /dev/null
+++ b/java/eclipse-hibernatetools/pkg-plist
@@ -0,0 +1,278 @@
+eclipse/features/org.hibernate.eclipse.feature_3.2.0.beta9a/feature.xml
+eclipse/plugins/org.eclipse.draw2d_3.2.1.v20060921.jar
+eclipse/plugins/org.eclipse.emf.common_2.2.1.v200609210005.jar
+eclipse/plugins/org.eclipse.emf.ecore.xmi_2.2.1.v200609210005.jar
+eclipse/plugins/org.eclipse.emf.ecore_2.2.1.v200609210005.jar
+eclipse/plugins/org.eclipse.gef_3.2.1.v20060921.jar
+eclipse/plugins/org.eclipse.jem.util_1.2.1.v20060918_M.jar
+eclipse/plugins/org.eclipse.wst.common.frameworks_1.1.1.v200609132124.jar
+eclipse/plugins/org.eclipse.wst.sse.ui_1.0.200.v200609211325.jar
+eclipse/plugins/org.eclipse.wst.validation_1.1.1.v200609132124.jar
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/META-INF/MANIFEST.MF
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/about.html
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/codegenwizard.jpg
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/consolecfgwizard.jpg
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/hbmxmlcompletion.jpg
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/hibernatecfgwizard.jpg
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/index.html
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/alwaysactiveopenquery.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/annotationsupport.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/artifactgeneration.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/cfgxml-propertycomplete.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/classvisualization.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/codegenexporters.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/codegenlauncher.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/codegenlaunchseamexporter.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/codegenlaunchtab.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/columncompletion.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/completeinsidejava.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/configurationswithnewnodes.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/consolelog.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/criteriaeditor.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/crowdedartififactgen.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/default_.css
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/dynamicquerytranslation.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/easysetup.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/embeddedruninqueryeditor.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/enableannotationvalidation.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/entitymodel.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/entitymodel_zoomin.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/entitymodel_zoomout.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/freemarkereditor.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hbm2docwithgraph.jpg
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hbmxml-namecompletion.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hbmxml-tablecompletion.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hbmxml-typecompletion.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hbmxml-usertypecompletion.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hibernate-eclipse-news-3.0.0.alpha4.html
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hibernate-eclipse-news-3.1.0.alpha5.html
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hibernate-eclipse-news-3.1.0.beta1.html
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hibernate-eclipse-news-3.1.0.beta2.html
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hibernate-eclipse-news-3.1.0.beta3.html
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hibernate-eclipse-news-3.1.0.beta4.html
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hibernate-eclipse-news-3.1.0.beta5.html
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hibernate-eclipse-news-3.2.0.beta6.html
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hibernate-eclipse-news-3.2.0.beta7.html
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hibernate-eclipse-news-3.2.0.beta8.html
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hibernate-eclipse-news-3.2.0.beta9.html
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hibernate3setting.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hql-completion.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hqlcriteriaquicknavigation.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hqleditorsetmaxresults.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/hqlpropertycodecompletion.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/inlinequeryvalidation.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/manytomanyoptlock_ui.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/newmappingfilewizard.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/newmappingfilewizard_result.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/newoutline.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/nullinparameters.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/overlaycontenttypes.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/persistencexmlcompletion.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/pluginhelp.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/prettyentitymodel.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/properties.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/queryparameters.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/revengstrategyinui.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/revengxml_overview.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/revengxml_tablefilters.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/revengxml_tablescolumn.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/revengxml_typemappings.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/wikisearch.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/wizard-artifactnewopt.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/wizard-cfgxml-newoptions.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/wizard-reveng.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy/xmlcatalog.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/queryconsole.jpg
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/hibernate_small_icon.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/1to1property.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/1tonproperty.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/anyproperty.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/catalog.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/clear.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/close.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/close_disabled.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/columns.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/componentproperty.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/criteria_editor.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/database.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/execute.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/format.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/function.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/hibernate.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/hibernate_config.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/hibernate_icon.jpg
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/hibernate_launch.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/hibernate_mapping.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/hibernate_overlay.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/hibernate_small_icon.jpg
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/hicon.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/hicon.jpg
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/hql_editor.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/idproperty.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/ignoreparameter.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/jboss.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/layout.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/layout_disabled.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/mapped_class.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/mto1property.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/mtoaproperty.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/mtonproperty.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/new_param.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/newhibernate_wiz.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/parameter.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/pindown.jpg
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/pinup.jpg
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/plus.png
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/property.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/schema.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/table.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/treeminus.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/treeplus.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/types.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/unknowntypeproperty.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/unmapped_class.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/versionproperty.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/xpl/complete_tsk.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/xpl/incomplete_tsk.gif
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/org.hibernate.eclipse.console.jar
+eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/plugin.xml
+eclipse/plugins/org.hibernate.eclipse.help_3.2.0.beta9a/META-INF/MANIFEST.MF
+eclipse/plugins/org.hibernate.eclipse.help_3.2.0.beta9a/about.html
+eclipse/plugins/org.hibernate.eclipse.help_3.2.0.beta9a/doc.zip
+eclipse/plugins/org.hibernate.eclipse.help_3.2.0.beta9a/help.jar
+eclipse/plugins/org.hibernate.eclipse.help_3.2.0.beta9a/plugin.xml
+eclipse/plugins/org.hibernate.eclipse.help_3.2.0.beta9a/toc.xml
+eclipse/plugins/org.hibernate.eclipse.help_3.2.0.beta9a/tocapireference.xml
+eclipse/plugins/org.hibernate.eclipse.help_3.2.0.beta9a/tocreferencedocumentation.xml
+eclipse/plugins/org.hibernate.eclipse.help_3.2.0.beta9a/toctoolsreference.xml
+eclipse/plugins/org.hibernate.eclipse.jdt.apt.ui_3.2.0.beta9a.jar
+eclipse/plugins/org.hibernate.eclipse.jdt.ui_3.2.0.beta9a.jar
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/META-INF/MANIFEST.MF
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/about.html
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/hibernate_small_icon.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/1to1property.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/1tonproperty.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/anyproperty.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/clear.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/close.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/close_disabled.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/componentproperty.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/execute.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/hibernate_config.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/hibernate_icon.jpg
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/hibernate_mapping.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/hibernate_overlay.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/hibernate_small_icon.jpg
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/hicon.jpg
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/idproperty.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/mapped_class.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/mto1property.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/mtoaproperty.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/mtonproperty.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/pindown.jpg
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/pinup.jpg
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/property.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/types.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/unknowntypeproperty.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/unmapped_class.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images/versionproperty.gif
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/org.hibernate.eclipse.mapper.jar
+eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/plugin.xml
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/META-INF/MANIFEST.MF
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/about.html
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/hibernate-log4j.properties
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/annotations/ejb3-persistence.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/annotations/hibernate-annotations.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/annotations/hibernate-entitymanager.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/annotations/lucene-core-2.0.0.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/bsh-core-2.0b4.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/antlr-2.7.6.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/asm-attrs.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/asm.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/c3p0-0.9.0.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/cglib-2.1.3.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/commons-collections-2.1.1.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/commons-logging-1.0.4.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/concurrent-1.3.2.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/connector.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/dom4j-1.6.1.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/ehcache-1.1.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/ehcache-1.2.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/hibernate3.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/jaas.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/javassist.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/jboss-cache.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/jboss-common.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/jboss-jmx.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/jboss-system.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/jdbc2_0-stdext.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/jgroups-2.2.8.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/jta.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/log4j-1.2.11.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/oscache-2.1.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/proxool-0.8.3.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate/swarmcache-1.0rc2.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/tools/bsh-2.0b1.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/tools/freemarker.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/tools/hibernate-tools.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/tools/jtidy-r8-20060801.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/org.hibernate.eclipse.jar
+eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/plugin.xml
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/License.txt
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/META-INF/MANIFEST.MF
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/freemarker-2.3.8.jar
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/freemarker-ide.jar
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/assign.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/break.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/case.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/collapseall.gif
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/comment.gif
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/default.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/element.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/else.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/elseif.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/expandall.gif
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/global.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/icon.gif
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/if.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/import.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/include.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/interpolation.gif
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/interpolation.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/list.gif
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/list.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/local.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/macro.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/macro_instance.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/nested.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/predefined_directive_call.gif
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/return.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/stop.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/switch.png
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/text.gif
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons/userdefined_directive_call.gif
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/plugin.properties
+eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/plugin.xml
+@dirrm eclipse/features/org.hibernate.eclipse.feature_3.2.0.beta9a
+@dirrm eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/META-INF
+@dirrm eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc/newandnoteworthy
+@dirrm eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/doc
+@dirrm eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images/xpl
+@dirrm eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons/images
+@dirrm eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a/icons
+@dirrm eclipse/plugins/org.hibernate.eclipse.console_3.2.0.beta9a
+@dirrm eclipse/plugins/org.hibernate.eclipse.help_3.2.0.beta9a/META-INF
+@dirrm eclipse/plugins/org.hibernate.eclipse.help_3.2.0.beta9a
+@dirrm eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/META-INF
+@dirrm eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons/images
+@dirrm eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a/icons
+@dirrm eclipse/plugins/org.hibernate.eclipse.mapper_3.2.0.beta9a
+@dirrm eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/META-INF
+@dirrm eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/annotations
+@dirrm eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/hibernate
+@dirrm eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib/tools
+@dirrm eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a/lib
+@dirrm eclipse/plugins/org.hibernate.eclipse_3.2.0.beta9a
+@dirrm eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/META-INF
+@dirrm eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2/icons
+@dirrm eclipse/plugins/org.jboss.ide.eclipse.freemarker_1.0.0.Beta2