aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-12-02 20:34:28 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-12-02 20:34:28 +0000
commitbb4787a32cf03eef9091b711c1572f04b064921e (patch)
tree569784d4ba78a25fa97d27179ee548d5fcf4b2b3 /java
parentb69974b3d9f5f97c95ad46afbf0cd07f0064063d (diff)
downloadports-bb4787a32cf03eef9091b711c1572f04b064921e.tar.gz
ports-bb4787a32cf03eef9091b711c1572f04b064921e.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/phpeclipse/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/java/phpeclipse/Makefile b/java/phpeclipse/Makefile
index 5c3301a1e89e..4d3f6e70913d 100644
--- a/java/phpeclipse/Makefile
+++ b/java/phpeclipse/Makefile
@@ -15,12 +15,12 @@ DISTNAME= net.sourceforge.${PORTNAME}_${PORTVERSION}.bin.dist
MAINTAINER= lon_kamikaze@gmx.de
COMMENT= PHP Eclipse adds PHP support to the Eclipse IDE Framework
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+
PLIST_SUB= VER=${PORTVERSION}
PLUGIN_PATHS= features plugins
-RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
-
NO_BUILD= yes
USE_ZIP= yes
NO_WRKSUBDIR= yes
@@ -33,12 +33,12 @@ do-install:
@${CP} -r ${WRKSRC}/${_path}/* ${ECLIPSE}/${_path}/
.endfor
-plist: patch
+plist: build
@${ECHO} "===> Rebuilding PLIST."
@${TOUCH} ${PLIST}
@${RM} ${PLIST}
.for _path in ${PLUGIN_PATHS}
- @${FIND} ${WRKSRC}/${_path}/ -type f \
+ @${FIND} ${WRKSRC}/${_path}/ -not -type d \
| ${SED} "s|${WRKSRC}|eclipse|1" \
| ${SED} "s|${PORTVERSION}|%%VER%%|g" \
>> ${PLIST}