aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2015-06-30 20:11:59 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2015-06-30 20:11:59 +0000
commit8fd3be6a57b5998074ba0fbbe677905268e67cdb (patch)
tree53eb738bbc41a1dca7e78a4686b3f4d186b10b3f /java
parentab8c1339c4c462f4f34bf6de881adc42a406bd9e (diff)
Notes
Diffstat (limited to 'java')
-rw-r--r--java/openjdk6/Makefile5
-rw-r--r--java/openjdk6/distinfo4
-rw-r--r--java/openjdk6/files/fontconfig.properties86
-rw-r--r--java/openjdk6/files/patch-set93
4 files changed, 90 insertions, 98 deletions
diff --git a/java/openjdk6/Makefile b/java/openjdk6/Makefile
index 80238281ba97..4ff108f06946 100644
--- a/java/openjdk6/Makefile
+++ b/java/openjdk6/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= openjdk6
-PORTVERSION= b34
-PORTREVISION= 2
+PORTVERSION= b35
PORTEPOCH= 1
CATEGORIES= java devel
MASTER_SITES= APACHE/ant/binaries/:ant \
@@ -29,7 +28,7 @@ LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper \
dejavu>0:${PORTSDIR}/x11-fonts/dejavu
-OPENJDK_BUILDDATE= 20_jan_2015
+OPENJDK_BUILDDATE= 14_apr_2015
OPTIONS_DEFINE= ICEDTEA IPV6 POLICY SOUND TZUPDATE
OPTIONS_DEFAULT=ICEDTEA IPV6 TZUPDATE
diff --git a/java/openjdk6/distinfo b/java/openjdk6/distinfo
index 23fb64d83869..fd8d87c0854f 100644
--- a/java/openjdk6/distinfo
+++ b/java/openjdk6/distinfo
@@ -1,6 +1,6 @@
SHA256 (apache-ant-1.9.4-bin.tar.bz2) = 20c16575684b8869dd9d19abe0fb504566adefb5d397881e70a417886e0088cf
SIZE (apache-ant-1.9.4-bin.tar.bz2) = 4351965
-SHA256 (openjdk-6-src-b34-20_jan_2015.tar.xz) = 13d1b4e1e152b6f9ad81b5558d6c7c0d3315a9e9494e49e515229722e2ee4e51
-SIZE (openjdk-6-src-b34-20_jan_2015.tar.xz) = 33601316
+SHA256 (openjdk-6-src-b35-14_apr_2015.tar.xz) = 131cde181fbca08ac4d47bd13f6c3a64806fe2ae2106c03afe7ba651c24a4f9b
+SIZE (openjdk-6-src-b35-14_apr_2015.tar.xz) = 33730692
SHA256 (jtreg-4.1-bin-b05_29_nov_2012.zip) = 9291eb4a14501232b35614e88686ff66ad8b69d0098dbd4322b28f97b672653d
SIZE (jtreg-4.1-bin-b05_29_nov_2012.zip) = 5993382
diff --git a/java/openjdk6/files/fontconfig.properties b/java/openjdk6/files/fontconfig.properties
index f73a461ab3e3..ceb46ba9ee19 100644
--- a/java/openjdk6/files/fontconfig.properties
+++ b/java/openjdk6/files/fontconfig.properties
@@ -31,126 +31,126 @@ version=1
# Component Font Mappings
dialog.plain.latin-1=DejaVu Sans
-dialog.plain.chinese-big5=AR PL UMing TW
-dialog.plain.chinese-gb18030=AR PL UMing CN
+dialog.plain.chinese-big5=AR PL UMing
+dialog.plain.chinese-gb18030=AR PL UMing
dialog.plain.japanese-x0208=Sazanami Gothic
dialog.plain.korean=NanumGothic
dialog.bold.latin-1=DejaVu Sans Bold
-dialog.bold.chinese-big5=AR PL UMing TW
-dialog.bold.chinese-gb18030=AR PL UMing CN
+dialog.bold.chinese-big5=AR PL UMing
+dialog.bold.chinese-gb18030=AR PL UMing
dialog.bold.japanese-x0208=Sazanami Gothic
dialog.bold.korean=NanumGothicExtraBold
dialog.italic.latin-1=DejaVu Sans Oblique
-dialog.italic.chinese-big5=AR PL UMing TW
-dialog.italic.chinese-gb18030=AR PL UMing CN
+dialog.italic.chinese-big5=AR PL UMing
+dialog.italic.chinese-gb18030=AR PL UMing
dialog.italic.japanese-x0208=Sazanami Gothic
dialog.italic.korean=NanumGothic
dialog.bolditalic.latin-1=DejaVu Sans Bold Oblique
-dialog.bolditalic.chinese-big5=AR PL UMing TW
-dialog.bolditalic.chinese-gb18030=AR PL UMing CN
+dialog.bolditalic.chinese-big5=AR PL UMing
+dialog.bolditalic.chinese-gb18030=AR PL UMing
dialog.bolditalic.japanese-x0208=Sazanami Gothic
dialog.bolditalic.korean=NanumGothicExtraBold
sansserif.plain.latin-1=DejaVu Sans
-sansserif.plain.chinese-big5=AR PL UMing TW
-sansserif.plain.chinese-gb18030=AR PL UMing CN
+sansserif.plain.chinese-big5=AR PL UMing
+sansserif.plain.chinese-gb18030=AR PL UMing
sansserif.plain.japanese-x0208=Sazanami Gothic
sansserif.plain.korean=NanumGothic
sansserif.bold.latin-1=DejaVu Sans Bold
-sansserif.bold.chinese-big5=AR PL UMing TW
-sansserif.bold.chinese-gb18030=AR PL UMing CN
+sansserif.bold.chinese-big5=AR PL UMing
+sansserif.bold.chinese-gb18030=AR PL UMing
sansserif.bold.japanese-x0208=Sazanami Gothic
sansserif.bold.korean=NanumGothicExtraBold
sansserif.italic.latin-1=DejaVu Sans Oblique
-sansserif.italic.chinese-big5=AR PL UMing TW
-sansserif.italic.chinese-gb18030=AR PL UMing CN
+sansserif.italic.chinese-big5=AR PL UMing
+sansserif.italic.chinese-gb18030=AR PL UMing
sansserif.italic.japanese-x0208=Sazanami Gothic
sansserif.italic.korean=NanumGothic
sansserif.bolditalic.latin-1=DejaVu Sans Bold Oblique
-sansserif.bolditalic.chinese-big5=AR PL UMing TW
-sansserif.bolditalic.chinese-gb18030=AR PL UMing CN
+sansserif.bolditalic.chinese-big5=AR PL UMing
+sansserif.bolditalic.chinese-gb18030=AR PL UMing
sansserif.bolditalic.japanese-x0208=Sazanami Gothic
sansserif.bolditalic.korean=NanumGothicExtraBold
serif.plain.latin-1=DejaVu Serif
-serif.plain.chinese-big5=AR PL UKai TW
-serif.plain.chinese-gb18030=AR PL UKai CN
+serif.plain.chinese-big5=AR PL UKai
+serif.plain.chinese-gb18030=AR PL UKai
serif.plain.japanese-x0208=Sazanami Mincho
serif.plain.korean=NanumMyeongjo
serif.bold.latin-1=DejaVu Serif Bold
-serif.bold.chinese-big5=AR PL UKai TW
-serif.bold.chinese-gb18030=AR PL UKai CN
+serif.bold.chinese-big5=AR PL UKai
+serif.bold.chinese-gb18030=AR PL UKai
serif.bold.japanese-x0208=Sazanami Mincho
serif.bold.korean=NanumMyeongjoExtraBold
serif.italic.latin-1=DejaVu Serif Italic
-serif.italic.chinese-big5=AR PL UKai TW
-serif.italic.chinese-gb18030=AR PL UKai CN
+serif.italic.chinese-big5=AR PL UKai
+serif.italic.chinese-gb18030=AR PL UKai
serif.italic.japanese-x0208=Sazanami Mincho
serif.italic.korean=NanumMyeongjo
serif.bolditalic.latin-1=DejaVu Serif Bold Italic
-serif.bolditalic.chinese-big5=AR PL UKai TW
-serif.bolditalic.chinese-gb18030=AR PL UKai CN
+serif.bolditalic.chinese-big5=AR PL UKai
+serif.bolditalic.chinese-gb18030=AR PL UKai
serif.bolditalic.japanese-x0208=Sazanami Mincho
serif.bolditalic.korean=NanumMyeongjoExtraBold
monospaced.plain.latin-1=DejaVu Sans Mono
-monospaced.plain.chinese-big5=AR PL UMing TW
-monospaced.plain.chinese-gb18030=AR PL UMing CN
+monospaced.plain.chinese-big5=AR PL UMing
+monospaced.plain.chinese-gb18030=AR PL UMing
monospaced.plain.japanese-x0208=Sazanami Gothic
monospaced.plain.korean=NanumGothic
monospaced.bold.latin-1=DejaVu Sans Mono Bold
-monospaced.bold.chinese-big5=AR PL UMing TW
-monospaced.bold.chinese-gb18030=AR PL UMing CN
+monospaced.bold.chinese-big5=AR PL UMing
+monospaced.bold.chinese-gb18030=AR PL UMing
monospaced.bold.japanese-x0208=Sazanami Gothic
monospaced.bold.korean=NanumGothicExtraBold
monospaced.italic.latin-1=DejaVu Sans Mono Oblique
-monospaced.italic.chinese-big5=AR PL UMing TW
-monospaced.italic.chinese-gb18030=AR PL UMing CN
+monospaced.italic.chinese-big5=AR PL UMing
+monospaced.italic.chinese-gb18030=AR PL UMing
monospaced.italic.japanese-x0208=Sazanami Gothic
monospaced.italic.korean=NanumGothic
monospaced.bolditalic.latin-1=DejaVu Sans Mono Bold Oblique
-monospaced.bolditalic.chinese-big5=AR PL UMing TW
-monospaced.bolditalic.chinese-gb18030=AR PL UMing CN
+monospaced.bolditalic.chinese-big5=AR PL UMing
+monospaced.bolditalic.chinese-gb18030=AR PL UMing
monospaced.bolditalic.japanese-x0208=Sazanami Gothic
monospaced.bolditalic.korean=NanumGothicExtraBold
dialoginput.plain.latin-1=DejaVu Sans Mono
-dialoginput.plain.chinese-big5=AR PL UMing TW
-dialoginput.plain.chinese-gb18030=AR PL UMing CN
+dialoginput.plain.chinese-big5=AR PL UMing
+dialoginput.plain.chinese-gb18030=AR PL UMing
dialoginput.plain.japanese-x0208=Sazanami Gothic
dialoginput.plain.korean=NanumGothic
dialoginput.bold.latin-1=DejaVu Sans Mono Bold
-dialoginput.bold.chinese-big5=AR PL UMing TW
-dialoginput.bold.chinese-gb18030=AR PL UMing CN
+dialoginput.bold.chinese-big5=AR PL UMing
+dialoginput.bold.chinese-gb18030=AR PL UMing
dialoginput.bold.japanese-x0208=Sazanami Gothic
dialoginput.bold.korean=NanumGothicExtraBold
dialoginput.italic.latin-1=DejaVu Sans Mono Oblique
-dialoginput.italic.chinese-big5=AR PL UMing TW
-dialoginput.italic.chinese-gb18030=AR PL UMing CN
+dialoginput.italic.chinese-big5=AR PL UMing
+dialoginput.italic.chinese-gb18030=AR PL UMing
dialoginput.italic.japanese-x0208=Sazanami Gothic
dialoginput.italic.korean=NanumGothic
dialoginput.bolditalic.latin-1=DejaVu Sans Mono Bold Oblique
-dialoginput.bolditalic.chinese-big5=AR PL UMing TW
-dialoginput.bolditalic.chinese-gb18030=AR PL UMing CN
+dialoginput.bolditalic.chinese-big5=AR PL UMing
+dialoginput.bolditalic.chinese-gb18030=AR PL UMing
dialoginput.bolditalic.japanese-x0208=Sazanami Gothic
dialoginput.bolditalic.korean=NanumGothicExtraBold
@@ -180,10 +180,8 @@ filename.DejaVu_Serif_Bold=/usr/local/share/fonts/dejavu/DejaVuSerif-Bold.ttf
filename.DejaVu_Serif_Italic=/usr/local/share/fonts/dejavu/DejaVuSerif-Italic.ttf
filename.DejaVu_Serif_Bold_Italic=/usr/local/share/fonts/dejavu/DejaVuSerif-BoldItalic.ttf
-filename.AR_PL_UKai_TW=/usr/local/share/fonts/TrueType/ukai.ttc
-filename.AR_PL_UMing_TW=/usr/local/share/fonts/TrueType/uming.ttc
-filename.AR_PL_UKai_CN=/usr/local/share/fonts/TrueType/ukai.ttc
-filename.AR_PL_UMing_CN=/usr/local/share/fonts/TrueType/uming.ttc
+filename.AR_PL_UMing=/usr/local/share/fonts/TrueType/uming.ttc
+filename.AR_PL_UKai=/usr/local/share/fonts/TrueType/ukai.ttc
filename.Sazanami_Gothic=/usr/local/share/font-sazanami/sazanami-gothic.ttf
filename.Sazanami_Mincho=/usr/local/share/font-sazanami/sazanami-mincho.ttf
diff --git a/java/openjdk6/files/patch-set b/java/openjdk6/files/patch-set
index 36f82d84bd80..8f257c163348 100644
--- a/java/openjdk6/files/patch-set
+++ b/java/openjdk6/files/patch-set
@@ -5509,7 +5509,7 @@
// An entryName(path)->File map generated during "expand", it helps to
// decide whether or not an existing entry in a jar file needs to be
-@@ -249,6 +250,16 @@
+@@ -250,6 +251,16 @@
}
}
} else if (xflag) {
@@ -5526,10 +5526,10 @@
replaceFSC(files);
if (fname != null && files != null) {
extract(fname, files);
-@@ -921,6 +932,10 @@
- ZipEntry rc = null;
- String name = e.getName();
- File f = new File(e.getName().replace('/', File.separatorChar));
+@@ -975,6 +986,10 @@
+ return rc; // leading '/' or 'dot-dot' only path
+ }
+ File f = new File(name.replace('/', File.separatorChar));
+ if (!f.getCanonicalPath().startsWith(cwd)) {
+ output(formatMsg("out.ignore.entry", name));
+ return null;
@@ -5537,7 +5537,7 @@
if (e.isDirectory()) {
if (f.exists()) {
if (!f.isDirectory()) {
-@@ -942,6 +957,10 @@
+@@ -996,6 +1011,10 @@
} else {
if (f.getParent() != null) {
File d = new File(f.getParent());
@@ -12620,20 +12620,24 @@
/*
* The fd table and the number of file descriptors
-@@ -281,7 +281,7 @@
+@@ -281,9 +281,7 @@
int NET_RecvFrom(int s, void *buf, int len, unsigned int flags,
struct sockaddr *from, int *fromlen) {
-- BLOCKING_IO_RETURN_INT( s, recvfrom(s, buf, len, flags, from, (socklen_t)fromlen) );
+- socklen_t socklen = *fromlen;
+- BLOCKING_IO_RETURN_INT( s, recvfrom(s, buf, len, flags, from, &socklen) );
+- *fromlen = socklen;
+ BLOCKING_IO_RETURN_INT( s, recvfrom(s, buf, len, flags, from, (socklen_t *)fromlen) );
}
int NET_Send(int s, void *msg, int len, unsigned int flags) {
-@@ -298,7 +298,7 @@
+@@ -300,9 +298,7 @@
}
int NET_Accept(int s, struct sockaddr *addr, int *addrlen) {
-- BLOCKING_IO_RETURN_INT( s, accept(s, addr, (socklen_t)addrlen) );
+- socklen_t socklen = *addrlen;
+- BLOCKING_IO_RETURN_INT( s, accept(s, addr, &socklen) );
+- *addrlen = socklen;
+ BLOCKING_IO_RETURN_INT( s, accept(s, addr, (socklen_t *)addrlen) );
}
@@ -12690,16 +12694,7 @@
/*
* On Linux if we are connecting to a link-local address
* we need to specify the interface in the scope_id (2.4 kernel only)
-@@ -1104,7 +1126,7 @@
- }
- #endif
-
-- rv = getsockopt(fd, level, opt, result, (socklen_t)len);
-+ rv = getsockopt(fd, level, opt, result, (socklen_t *)len);
- if (rv < 0) {
- return rv;
- }
-@@ -1151,6 +1173,24 @@
+@@ -1160,6 +1182,24 @@
#define IPTOS_PREC_MASK 0xe0
#endif
@@ -12724,7 +12719,7 @@
/*
* IPPROTO/IP_TOS :-
* 1. IPv6 on Solaris: no-op and will be set in flowinfo
-@@ -1183,6 +1223,10 @@
+@@ -1192,6 +1232,10 @@
*iptos &= (IPTOS_TOS_MASK | IPTOS_PREC_MASK);
}
@@ -12735,7 +12730,7 @@
/*
* SOL_SOCKET/{SO_SNDBUF,SO_RCVBUF} - On Solaris need to
* ensure that value is <= max_buf as otherwise we get
-@@ -1230,6 +1274,84 @@
+@@ -1239,6 +1283,84 @@
}
#endif
@@ -13239,7 +13234,7 @@
"X11GD_InitXrandrFuncs: Could not open libXrandr.so.2");
--- jdk/src/solaris/native/sun/awt/awt_InputMethod.c
+++ jdk/src/solaris/native/sun/awt/awt_InputMethod.c
-@@ -69,7 +69,7 @@
+@@ -67,7 +67,7 @@
XIMPreeditDrawCallbackStruct *);
static void PreeditCaretCallback(XIC, XPointer,
XIMPreeditCaretCallbackStruct *);
@@ -13248,7 +13243,7 @@
static void StatusStartCallback(XIC, XPointer, XPointer);
static void StatusDoneCallback(XIC, XPointer, XPointer);
static void StatusDrawCallback(XIC, XPointer,
-@@ -83,7 +83,7 @@
+@@ -81,7 +81,7 @@
#define PreeditDoneIndex 1
#define PreeditDrawIndex 2
#define PreeditCaretIndex 3
@@ -13257,7 +13252,7 @@
#define StatusStartIndex 4
#define StatusDoneIndex 5
#define StatusDrawIndex 6
-@@ -101,14 +101,14 @@
+@@ -99,14 +99,14 @@
(XIMProc)PreeditDoneCallback,
(XIMProc)PreeditDrawCallback,
(XIMProc)PreeditCaretCallback,
@@ -13274,7 +13269,7 @@
#define MAX_STATUS_LEN 100
typedef struct {
Window w; /*status window id */
-@@ -148,7 +148,7 @@
+@@ -146,7 +146,7 @@
#endif /* XAWT */
jobject x11inputmethod; /* global ref to X11InputMethod instance */
/* associated with the XIC */
@@ -13283,7 +13278,7 @@
StatusWindow *statusWindow; /* our own status window */
#else
#ifndef XAWT
-@@ -427,7 +427,7 @@
+@@ -425,7 +425,7 @@
static void
freeX11InputMethodData(JNIEnv *env, X11InputMethodData *pX11IMData)
{
@@ -13292,7 +13287,7 @@
if (pX11IMData->statusWindow != NULL){
StatusWindow *sw = pX11IMData->statusWindow;
XFreeGC(awt_display, sw->lightGC);
-@@ -533,7 +533,7 @@
+@@ -531,7 +531,7 @@
pX11IMData = getX11InputMethodData(env, currentX11InputMethodInstance);
if (pX11IMData == NULL) {
@@ -13301,7 +13296,7 @@
return False;
#else
return result;
-@@ -541,7 +541,7 @@
+@@ -539,7 +539,7 @@
}
if ((ic = pX11IMData->current_ic) == (XIC)0){
@@ -13310,7 +13305,7 @@
return False;
#else
return result;
-@@ -650,7 +650,7 @@
+@@ -648,7 +648,7 @@
return result;
}
@@ -13319,7 +13314,7 @@
static StatusWindow *createStatusWindow(
#ifdef XAWT
Window parent) {
-@@ -994,7 +994,7 @@
+@@ -993,7 +993,7 @@
}
}
}
@@ -13328,7 +13323,7 @@
/*
* Creates two XICs, one for active clients and the other for passive
* clients. All information on those XICs are stored in the
-@@ -1051,7 +1051,7 @@
+@@ -1050,7 +1050,7 @@
return FALSE ;
}
@@ -13337,7 +13332,7 @@
on_the_spot_styles |= XIMStatusNothing;
/*kinput does not support XIMPreeditCallbacks and XIMStatusArea
-@@ -1064,7 +1064,7 @@
+@@ -1063,7 +1063,7 @@
break;
}
}
@@ -13346,7 +13341,7 @@
#ifdef XAWT
on_the_spot_styles |= XIMStatusNothing;
#else /* !XAWT */
-@@ -1087,7 +1087,7 @@
+@@ -1086,7 +1086,7 @@
on_the_spot_styles |= XIMStatusNothing;
#endif /* XAWT */
@@ -13355,7 +13350,7 @@
for (i = 0; i < im_styles->count_styles; i++) {
active_styles |= im_styles->supported_styles[i] & on_the_spot_styles;
-@@ -1135,7 +1135,7 @@
+@@ -1134,7 +1134,7 @@
NULL);
if (preedit == (XVaNestedList)NULL)
goto err;
@@ -13364,7 +13359,7 @@
/*always try XIMStatusCallbacks for active client...*/
{
status = (XVaNestedList)XVaCreateNestedList(0,
-@@ -1157,7 +1157,7 @@
+@@ -1156,7 +1156,7 @@
XFree((void *)status);
XFree((void *)preedit);
}
@@ -13373,16 +13368,16 @@
#ifndef XAWT
if (on_the_spot_styles & XIMStatusArea) {
Widget parent;
-@@ -1185,7 +1185,7 @@
+@@ -1184,7 +1184,7 @@
}
#endif /* XAWT */
XFree((void *)preedit);
-#endif /* __linux__ */
+#endif /* __linux__ || _ALLBSD_SOURCE */
pX11IMData->ic_passive = XCreateIC(X11im,
- XNClientWindow, XtWindow(w),
- XNFocusWindow, XtWindow(w),
-@@ -1344,7 +1344,7 @@
+ XNClientWindow, w,
+ XNFocusWindow, w,
+@@ -1343,7 +1343,7 @@
}
@@ -13391,7 +13386,7 @@
static void
StatusStartCallback(XIC ic, XPointer client_data, XPointer call_data)
{
-@@ -1412,7 +1412,7 @@
+@@ -1411,7 +1411,7 @@
finally:
AWT_UNLOCK();
}
@@ -13400,14 +13395,14 @@
static void CommitStringCallback(XIC ic, XPointer client_data, XPointer call_data) {
JNIEnv *env = GetJNIEnv();
-@@ -1514,14 +1514,14 @@
+@@ -1513,14 +1513,14 @@
/* Use IMInstantiate call back only on Linux, as there is a bug in Solaris
(4768335)
*/
-#ifdef __linux__
+#if defined(__linux__) || defined(_ALLBSD_SOURCE)
registered = XRegisterIMInstantiateCallback(dpy, NULL, NULL,
- NULL, (XIMProc)OpenXIMCallback, NULL);
+ NULL, (XIDProc)OpenXIMCallback, NULL);
if (!registered) {
/* directly call openXIM callback */
#endif
@@ -13417,7 +13412,7 @@
}
#endif
-@@ -1585,13 +1585,13 @@
+@@ -1584,13 +1584,13 @@
#endif /* XAWT */
globalRef = (*env)->NewGlobalRef(env, this);
pX11IMData->x11inputmethod = globalRef;
@@ -13434,10 +13429,10 @@
pX11IMData->lookup_buf = 0;
pX11IMData->lookup_buf_len = 0;
-@@ -1738,14 +1738,14 @@
+@@ -1737,14 +1737,14 @@
setXICFocus(pX11IMData->current_ic, req);
currentX11InputMethodInstance = pX11IMData->x11inputmethod;
- currentFocusWindow = XtWindow(w);
+ currentFocusWindow = w;
-#ifdef __linux__
+#if defined(__linux__) || defined(_ALLBSD_SOURCE)
if (active && pX11IMData->statusWindow && pX11IMData->statusWindow->on)
@@ -13451,7 +13446,7 @@
onoffStatusWindow(pX11IMData, 0, False);
if (pX11IMData->current_ic != NULL)
#endif
-@@ -1762,7 +1762,7 @@
+@@ -1761,7 +1761,7 @@
Java_sun_awt_X11InputMethod_turnoffStatusWindow(JNIEnv *env,
jobject this)
{
@@ -13460,7 +13455,7 @@
X11InputMethodData *pX11IMData;
StatusWindow *statusWindow;
-@@ -1859,7 +1859,7 @@
+@@ -1858,7 +1858,7 @@
X11InputMethodData *pX11IMData;
XVaNestedList status;
@@ -13469,7 +13464,7 @@
/*do nothing for linux? */
#else
AWT_LOCK();
-@@ -1965,7 +1965,7 @@
+@@ -1964,7 +1964,7 @@
JNIEXPORT void JNICALL Java_sun_awt_X11_XInputMethod_adjustStatusWindow
(JNIEnv *env, jobject this, jlong window)
{