aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-04-21 18:51:13 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-04-21 18:51:13 +0000
commitf95f2ae918be9bd6e698efb1e4ee8536792fe31e (patch)
tree3ba2217169f017edd9e4407af4921c964c9db662 /java
parent41569c17f131684d63568535e257355b69c65100 (diff)
downloadports-f95f2ae918be9bd6e698efb1e4ee8536792fe31e.tar.gz
ports-f95f2ae918be9bd6e698efb1e4ee8536792fe31e.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/openjfx8-devel/Makefile10
-rw-r--r--java/openjfx8-devel/distinfo6
-rw-r--r--java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_PlatformJava.cmake12
-rw-r--r--java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_CMakeLists.txt10
-rw-r--r--java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_PlatformJava.cmake15
-rw-r--r--java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_cmake_OptionsJava.cmake13
6 files changed, 43 insertions, 23 deletions
diff --git a/java/openjfx8-devel/Makefile b/java/openjfx8-devel/Makefile
index da477116b61a..6ae61606c648 100644
--- a/java/openjfx8-devel/Makefile
+++ b/java/openjfx8-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= openjfx8
-DISTVERSION= 8u172-b03
-PORTREVISION= 1
+DISTVERSION= 8u172-b11
PORTEPOCH= 1
CATEGORIES= java x11-toolkits devel
MASTER_SITES= https://github.com/t6/openjfx/releases/download/release/ \
@@ -102,10 +101,9 @@ post-patch:
# Pull Java dependencies from LOCALBASE
@${REINPLACE_CMD} 's@/usr/local@${LOCALBASE}@g' \
${WRKSRC}/build.gradle ${WRKSRC}/buildSrc/build.gradle
-# Remove the bundled libicu and libsqlite3. We use the system's
-# versions instead.
- @${RM} -r ${WRKSRC}/modules/web/src/main/native/Source/ThirdParty/icu \
- ${WRKSRC}/modules/web/src/main/native/Source/ThirdParty/sqlite
+# Remove bundled libraries. We use the system's versions instead.
+ @cd ${WRKSRC}/modules/web/src/main/native/Source/ThirdParty && \
+ ${RM} -r icu libxml libxslt sqlite
post-patch-SWT-off:
@${RM} -r ${WRKSRC}/modules/graphics/src/main/java/com/sun/glass/ui/swt
diff --git a/java/openjfx8-devel/distinfo b/java/openjfx8-devel/distinfo
index 4f7d7126ee8f..8e5744eec780 100644
--- a/java/openjfx8-devel/distinfo
+++ b/java/openjfx8-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1517218697
-SHA256 (openjfx8-8u172-b03.tar.gz) = 1648bcce3a9f3ee9ac4353f0b3fb896818a3a89440497d0bb8853d22dddf132d
-SIZE (openjfx8-8u172-b03.tar.gz) = 107849167
+TIMESTAMP = 1524062144
+SHA256 (openjfx8-8u172-b11.tar.gz) = 2e88966dadaa93d172a67b6bd6e9f32002ac41e5c4eabf625c143c53f4ed6391
+SIZE (openjfx8-8u172-b11.tar.gz) = 107629343
diff --git a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_PlatformJava.cmake b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_PlatformJava.cmake
index a2c47e55df65..56662a20f53d 100644
--- a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_PlatformJava.cmake
+++ b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_PlatformJava.cmake
@@ -1,10 +1,8 @@
---- modules/web/src/main/native/Source/PlatformJava.cmake.orig 2017-09-08 16:56:55 UTC
+--- modules/web/src/main/native/Source/PlatformJava.cmake.orig 2018-03-23 23:53:57 UTC
+++ modules/web/src/main/native/Source/PlatformJava.cmake
-@@ -1,5 +1,5 @@
+@@ -1,4 +1 @@
-add_subdirectory(ThirdParty/sqlite)
-add_subdirectory(ThirdParty/icu)
-+# add_subdirectory(ThirdParty/sqlite)
-+# add_subdirectory(ThirdParty/icu)
-
- # libxml2 should be compiled only on windows
- if (WIN32)
+-add_subdirectory(ThirdParty/libxml)
+-add_subdirectory(ThirdParty/libxslt)
++
diff --git a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_CMakeLists.txt b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_CMakeLists.txt
new file mode 100644
index 000000000000..7ac24870f680
--- /dev/null
+++ b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- modules/web/src/main/native/Source/WebCore/CMakeLists.txt.orig 2018-03-23 23:53:57 UTC
++++ modules/web/src/main/native/Source/WebCore/CMakeLists.txt
+@@ -131,6 +131,7 @@ set(WebCore_INCLUDE_DIRECTORIES
+
+ set(WebCore_SYSTEM_INCLUDE_DIRECTORIES
+ ${ICU_INCLUDE_DIRS}
++ ${CMAKE_INSTALL_PREFIX}/include/libxml2
+ )
+
+ set(WebCore_IDL_INCLUDES
diff --git a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_PlatformJava.cmake b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_PlatformJava.cmake
index e6b2aedca78e..d90aedd16d90 100644
--- a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_PlatformJava.cmake
+++ b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_PlatformJava.cmake
@@ -1,6 +1,17 @@
---- modules/web/src/main/native/Source/WebCore/PlatformJava.cmake.orig 2018-01-16 01:40:56 UTC
+--- modules/web/src/main/native/Source/WebCore/PlatformJava.cmake.orig 2018-03-23 23:53:57 UTC
+++ modules/web/src/main/native/Source/WebCore/PlatformJava.cmake
-@@ -242,7 +242,7 @@ set(WebCore_FORWARDING_HEADERS_FILES
+@@ -188,8 +188,8 @@ elseif (APPLE)
+ endif ()
+
+ list(APPEND WebCore_LIBRARIES
+- XMLJava
+- XSLTJava
++ ${CMAKE_INSTALL_PREFIX}/lib/libxml2.so
++ ${CMAKE_INSTALL_PREFIX}/lib/libxslt.so
+ )
+
+ list(APPEND WebCore_USER_AGENT_STYLE_SHEETS
+@@ -225,7 +225,7 @@ set(WebCore_FORWARDING_HEADERS_FILES
set(WebCore_USER_AGENT_SCRIPTS_DEPENDENCIES ${WEBCORE_DIR}/platform/java/RenderThemeJava.cpp)
list(APPEND WebCore_LIBRARIES
diff --git a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_cmake_OptionsJava.cmake b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_cmake_OptionsJava.cmake
index a538629311f2..76727ffc1778 100644
--- a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_cmake_OptionsJava.cmake
+++ b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_cmake_OptionsJava.cmake
@@ -1,6 +1,6 @@
---- modules/web/src/main/native/Source/cmake/OptionsJava.cmake.orig 2018-01-16 01:40:56 UTC
+--- modules/web/src/main/native/Source/cmake/OptionsJava.cmake.orig 2018-03-23 23:53:57 UTC
+++ modules/web/src/main/native/Source/cmake/OptionsJava.cmake
-@@ -52,9 +52,9 @@ elseif (APPLE)
+@@ -49,9 +49,9 @@ elseif (APPLE)
set(CMAKE_BUILD_WITH_INSTALL_RPATH TRUE)
elseif (UNIX)
#### ICU ####
@@ -12,8 +12,8 @@
+ set(ICU_JAVA_DATA_LIB ${CMAKE_INSTALL_PREFIX}/lib/libicudata.so)
#### ICU-END ####
- find_package(LibXml2 2.7.0 REQUIRED)
-@@ -191,8 +191,9 @@ if (CMAKE_MAJOR_VERSION LESS 3)
+ set(CMAKE_SKIP_RPATH TRUE)
+@@ -60,11 +60,12 @@ else ()
endif ()
set(ICU_INCLUDE_DIRS
@@ -21,6 +21,9 @@
"${THIRDPARTY_DIR}/icu/source/common"
"${THIRDPARTY_DIR}/icu/source/i18n"
)
-
+ set(ICU_LIBRARIES ${ICU_JAVA_COMMON_LIB} ${ICU_JAVA_DATA_LIB})
-
+set(ICU_LIBRARIES ${ICU_JAVA_COMMON_LIB} ${ICU_JAVA_DATA_LIB})
+ find_package(JNI REQUIRED)
+ find_package(Threads REQUIRED)
+