aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2010-07-14 03:33:40 +0000
committerGreg Lewis <glewis@FreeBSD.org>2010-07-14 03:33:40 +0000
commit4a7d9e063e6c4ed09f222a02c87266adad7e95b4 (patch)
tree5b9b8f8289475e44440ff5c1705ab2b2bbfee99d /java
parent34f4eb4eeb2fdffb5b9c99d23da938de91ac0d6c (diff)
downloadports-4a7d9e063e6c4ed09f222a02c87266adad7e95b4.tar.gz
ports-4a7d9e063e6c4ed09f222a02c87266adad7e95b4.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-gef/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/java/eclipse-gef/Makefile b/java/eclipse-gef/Makefile
index 385f50dffed1..010d564b2175 100644
--- a/java/eclipse-gef/Makefile
+++ b/java/eclipse-gef/Makefile
@@ -31,12 +31,12 @@ JAVA_VERSION= 1.5+
JAVA_OS= native
do-install:
- @${MKDIR} ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) >> ${TMPPLIST}
+ @${MKDIR} ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
@(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
| ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
+ | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
.include <bsd.port.mk>