aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
committerAde Lovett <ade@FreeBSD.org>2005-11-15 06:52:12 +0000
commit54a0b86543e9ffa811825f0afecea56e89aac2a5 (patch)
treef56fb969c6a70f5e63287a4f791d035ab1ef0ddc /java
parent1fccb46f1497a538f24ec00f14b7826570bc0a3a (diff)
downloadports-54a0b86543e9ffa811825f0afecea56e89aac2a5.tar.gz
ports-54a0b86543e9ffa811825f0afecea56e89aac2a5.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/classpath/Makefile2
-rw-r--r--java/jc/Makefile2
-rw-r--r--java/jmp/Makefile2
-rw-r--r--java/kaffe/Makefile2
-rw-r--r--java/sablevm/Makefile4
5 files changed, 5 insertions, 7 deletions
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
index 4398f6e7a694..c86eb663df46 100644
--- a/java/classpath/Makefile
+++ b/java/classpath/Makefile
@@ -18,7 +18,7 @@ COMMENT= A GNU project to create a free Java class library
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GNOME= gtk20 libartlgpl2 pkgconfig
USE_JAVA= yes
USE_JIKES= yes
diff --git a/java/jc/Makefile b/java/jc/Makefile
index 0925d503ef9b..9c882205c888 100644
--- a/java/jc/Makefile
+++ b/java/jc/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
MAN1= jc.1
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_JAVA= yes
USE_GMAKE= yes
JAVA_BUILD= jre
diff --git a/java/jmp/Makefile b/java/jmp/Makefile
index 6024d390d59e..1633299b0976 100644
--- a/java/jmp/Makefile
+++ b/java/jmp/Makefile
@@ -37,7 +37,7 @@ CFLAGS+= -DJMPDEBUG -g
CFLAGS+= -O3
.endif
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
USE_JAVA= yes
JAVA_VERSION= 1.2+
diff --git a/java/kaffe/Makefile b/java/kaffe/Makefile
index a4bfa542c348..064e59f0c657 100644
--- a/java/kaffe/Makefile
+++ b/java/kaffe/Makefile
@@ -27,7 +27,7 @@ WRKSRC= ${WRKDIR}/kaffe-${PORTVERSION}
ONLY_FOR_ARCHS= i386 amd64
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
USE_ICONV= yes
LIBTOOLFLAGS=
diff --git a/java/sablevm/Makefile b/java/sablevm/Makefile
index aa0c76311a51..236e4ebcd18e 100644
--- a/java/sablevm/Makefile
+++ b/java/sablevm/Makefile
@@ -23,11 +23,9 @@ LIB_DEPENDS= popt:${PORTSDIR}/devel/popt \
gtk-x11-2.0:${PORTSDIR}/x11-toolkits/gtk20 \
art_lgpl_2:${PORTSDIR}/graphics/libart_lgpl2
-USE_AUTOCONF_VER=259
+USE_AUTOTOOLS= autoconf:259 libltdl:15 libtool:15
#GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
-USE_LIBLTDL= yes
INSTALLS_SHLIB= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
CONFIGURE_ENV= CFLAGS="-I${PREFIX}/include -L${PREFIX}/lib"