aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2005-02-15 14:50:09 +0000
committerAnders Nordby <anders@FreeBSD.org>2005-02-15 14:50:09 +0000
commit61734a78a87881acee6396f43a021efa73668ce5 (patch)
tree08b7f14668c555d5d6a2f37bd58cc2dc8eeeb9d1 /java
parentede33c131c0e799c576d76cbbdf7934426cbe472 (diff)
downloadports-61734a78a87881acee6396f43a021efa73668ce5.tar.gz
ports-61734a78a87881acee6396f43a021efa73668ce5.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/Makefile1
-rw-r--r--java/drexelsnmp/Makefile31
-rw-r--r--java/drexelsnmp/distinfo2
-rw-r--r--java/drexelsnmp/pkg-descr13
-rw-r--r--java/drexelsnmp/pkg-plist2
5 files changed, 49 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index 00ec8f7c6eda..d451e569e86e 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -16,6 +16,7 @@
SUBDIR += cryptix-jce
SUBDIR += diablo-jdk13
SUBDIR += diablo-jre13
+ SUBDIR += drexelsnmp
SUBDIR += eclipse
SUBDIR += eclipse-EPIC
SUBDIR += eclipse-cdt
diff --git a/java/drexelsnmp/Makefile b/java/drexelsnmp/Makefile
new file mode 100644
index 000000000000..8ad8662c9e8d
--- /dev/null
+++ b/java/drexelsnmp/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: drexelsnmp
+# Date created: 2005-02-15
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= drexelsnmp
+PORTVERSION= 1.4
+CATEGORIES= java devel net-mgmt
+MASTER_SITES= http://edge.mcs.drexel.edu/GICL/people/sevy/snmp/
+DISTNAME= source_${PORTVERSION}
+
+MAINTAINER= anders@FreeBSD.org
+COMMENT= Java SNMP protocol implementation
+
+USE_JAVA= yes
+USE_ZIP= yes
+
+CLASSDIR= ${PREFIX}/share/java/classes
+NO_WRKSUBDIR= yes
+
+do-build:
+ ${MKDIR} ${WRKSRC}/build_library
+ (cd ${WRKSRC} && ${JAVAC} -sourcepath source -d build_library source/snmp/*.java && ${JAR} cvf snmp.jar -C build_library/ .)
+
+do-install:
+ ${INSTALL} -d -o root -g wheel -m 0755 ${CLASSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/snmp.jar ${CLASSDIR}/
+
+.include <bsd.port.mk>
diff --git a/java/drexelsnmp/distinfo b/java/drexelsnmp/distinfo
new file mode 100644
index 000000000000..3e03bf9df2fc
--- /dev/null
+++ b/java/drexelsnmp/distinfo
@@ -0,0 +1,2 @@
+MD5 (source_1.4.zip) = 0d856201c817b534ae31094c1794151d
+SIZE (source_1.4.zip) = 112800
diff --git a/java/drexelsnmp/pkg-descr b/java/drexelsnmp/pkg-descr
new file mode 100644
index 000000000000..e6d289243bd5
--- /dev/null
+++ b/java/drexelsnmp/pkg-descr
@@ -0,0 +1,13 @@
+This provides an introduction to the Java SNMP package , an open-source
+implementation of the SNMP protocol in a Java package. It provides support for
+basic SNMP client operations as defined in SNMP versions 1 and 2 (excluding the
+security model proposed as part of SNMP version 2, which was never widely
+accept or deployed). The package provides a mechanism for "getting and setting"
+SNMP object identifier (OID) values through a simple communication interface,
+and represents SNMP structures and datatypes as corresponding Java objects.
+The package assumes familiarity with the SNMP protocol as detailed in RFC's
+1157, 1155, 1212, etc.; however, some simple examples are provided which
+illustrate its use for simple get/set operations (though a knowledge of the
+concepts of OIDs and SNMP datatypes is still required).
+
+WWW: http://edge.mcs.drexel.edu/GICL/people/sevy/snmp/
diff --git a/java/drexelsnmp/pkg-plist b/java/drexelsnmp/pkg-plist
new file mode 100644
index 000000000000..be12766db9cf
--- /dev/null
+++ b/java/drexelsnmp/pkg-plist
@@ -0,0 +1,2 @@
+share/java/classes/snmp.jar
+@unexec rmdir %D/share/java/classes 2>/dev/null || true