aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorPedro F. Giffuni <pfg@FreeBSD.org>2019-10-06 19:08:14 +0000
committerPedro F. Giffuni <pfg@FreeBSD.org>2019-10-06 19:08:14 +0000
commitc937a4ccc9f8c084344ae2b95fda9e50dfe7ab03 (patch)
treed1f15965fd21b7db5e3b21c1d8dc8442e6e2f50e /java
parentbbc7901e66f498ae60a9b87b783813dc5fb0edf2 (diff)
Notes
Diffstat (limited to 'java')
-rw-r--r--java/Makefile10
-rw-r--r--java/apache-commons-cli/Makefile (renamed from java/jakarta-commons-cli/Makefile)3
-rw-r--r--java/apache-commons-cli/distinfo (renamed from java/jakarta-commons-cli/distinfo)0
-rw-r--r--java/apache-commons-cli/pkg-descr4
-rw-r--r--java/apache-commons-collections/Makefile (renamed from java/jakarta-commons-collections/Makefile)9
-rw-r--r--java/apache-commons-collections/distinfo (renamed from java/jakarta-commons-collections/distinfo)1
-rw-r--r--java/apache-commons-collections/files/patch-jdk8 (renamed from java/jakarta-commons-collections/files/patch-jdk8)28
-rw-r--r--java/apache-commons-collections/pkg-descr (renamed from java/jakarta-commons-collections/pkg-descr)7
-rw-r--r--java/apache-commons-lang/Makefile (renamed from java/jakarta-commons-lang/Makefile)4
-rw-r--r--java/apache-commons-lang/distinfo (renamed from java/jakarta-commons-lang/distinfo)0
-rw-r--r--java/apache-commons-lang/pkg-descr (renamed from java/jakarta-commons-lang/pkg-descr)2
-rw-r--r--java/apache-commons-logging/Makefile (renamed from java/jakarta-commons-logging/Makefile)2
-rw-r--r--java/apache-commons-logging/distinfo (renamed from java/jakarta-commons-logging/distinfo)1
-rw-r--r--java/apache-commons-logging/pkg-descr (renamed from java/jakarta-commons-logging/pkg-descr)4
-rw-r--r--java/apache-commons-primitives/Makefile (renamed from java/jakarta-commons-primitives/Makefile)5
-rw-r--r--java/apache-commons-primitives/distinfo (renamed from java/jakarta-commons-primitives/distinfo)0
-rw-r--r--java/apache-commons-primitives/pkg-descr (renamed from java/jakarta-commons-primitives/pkg-descr)4
-rw-r--r--java/jakarta-commons-beanutils/Makefile9
-rw-r--r--java/jakarta-commons-cli/pkg-descr4
-rw-r--r--java/jakarta-commons-httpclient/Makefile6
-rw-r--r--java/jakarta-oro/pkg-descr2
-rw-r--r--java/jakarta-regexp/pkg-descr2
22 files changed, 54 insertions, 53 deletions
diff --git a/java/Makefile b/java/Makefile
index 7245c690c1a8..f06431ded1a9 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -3,6 +3,11 @@
COMMENT = Java language support
+ SUBDIR += apache-commons-cli
+ SUBDIR += apache-commons-collections
+ SUBDIR += apache-commons-lang
+ SUBDIR += apache-commons-logging
+ SUBDIR += apache-commons-primitives
SUBDIR += aparapi
SUBDIR += avis
SUBDIR += berkeley-db
@@ -39,17 +44,12 @@
SUBDIR += jai
SUBDIR += jakarta-bcel
SUBDIR += jakarta-commons-beanutils
- SUBDIR += jakarta-commons-cli
SUBDIR += jakarta-commons-codec
- SUBDIR += jakarta-commons-collections
SUBDIR += jakarta-commons-dbcp
SUBDIR += jakarta-commons-discovery
SUBDIR += jakarta-commons-httpclient
- SUBDIR += jakarta-commons-lang
SUBDIR += jakarta-commons-lang3
- SUBDIR += jakarta-commons-logging
SUBDIR += jakarta-commons-pool
- SUBDIR += jakarta-commons-primitives
SUBDIR += jakarta-oro
SUBDIR += jakarta-regexp
SUBDIR += jasmin
diff --git a/java/jakarta-commons-cli/Makefile b/java/apache-commons-cli/Makefile
index ae8a03806f32..3c8f8fef617b 100644
--- a/java/jakarta-commons-cli/Makefile
+++ b/java/apache-commons-cli/Makefile
@@ -3,10 +3,9 @@
PORTNAME= commons-cli
PORTVERSION= 1.4
-PORTEPOCH= 1
CATEGORIES= java devel
MASTER_SITES= APACHE_COMMONS_BINARIES
-PKGNAMEPREFIX= jakarta-
+PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
MAINTAINER= ports@FreeBSD.org
diff --git a/java/jakarta-commons-cli/distinfo b/java/apache-commons-cli/distinfo
index d17791bd43f0..d17791bd43f0 100644
--- a/java/jakarta-commons-cli/distinfo
+++ b/java/apache-commons-cli/distinfo
diff --git a/java/apache-commons-cli/pkg-descr b/java/apache-commons-cli/pkg-descr
new file mode 100644
index 000000000000..f4bf86fafc24
--- /dev/null
+++ b/java/apache-commons-cli/pkg-descr
@@ -0,0 +1,4 @@
+The Apache Commons CLI library provides a simple and easy to use
+API for working with the command line arguments and options.
+
+WWW: http://commons.apache.org/proper/commons-cli/
diff --git a/java/jakarta-commons-collections/Makefile b/java/apache-commons-collections/Makefile
index 8d18f1a2c234..16ab1601e58f 100644
--- a/java/jakarta-commons-collections/Makefile
+++ b/java/apache-commons-collections/Makefile
@@ -5,16 +5,19 @@ PORTNAME= commons-collections
PORTVERSION= 3.2.1
CATEGORIES= java devel
MASTER_SITES= APACHE_COMMONS_SOURCE
-PKGNAMEPREFIX= jakarta-
+PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= makc@FreeBSD.org
COMMENT= Classes that extend/augment the Java Collections Framework
+LICENSE= APACHE20
+
+USES= dos2unix
+
USE_JAVA= yes
-JAVA_VERSION= 1.6+
+JAVA_VERSION= 8+
USE_ANT= yes
-USES= dos2unix
DOS2UNIX_GLOB= Multi*.java Test*.java
ALL_TARGET= jar
diff --git a/java/jakarta-commons-collections/distinfo b/java/apache-commons-collections/distinfo
index 66bcef28aaaa..ef7c4127095b 100644
--- a/java/jakarta-commons-collections/distinfo
+++ b/java/apache-commons-collections/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1570206793
SHA256 (commons-collections-3.2.1-src.tar.gz) = 9a4a800cb7ecdaf3b6f608cd608682b88b506f1b1c4b727d15471ae3329fc63d
SIZE (commons-collections-3.2.1-src.tar.gz) = 609930
diff --git a/java/jakarta-commons-collections/files/patch-jdk8 b/java/apache-commons-collections/files/patch-jdk8
index 3c4cd156b6b3..b59963086a39 100644
--- a/java/jakarta-commons-collections/files/patch-jdk8
+++ b/java/apache-commons-collections/files/patch-jdk8
@@ -1,6 +1,6 @@
---- src/java/org/apache/commons/collections/MultiHashMap.java
+--- src/java/org/apache/commons/collections/MultiHashMap.java.orig 2019-10-04 16:36:43 UTC
+++ src/java/org/apache/commons/collections/MultiHashMap.java
-@@ -331,21 +331,21 @@ public class MultiHashMap extends HashMap implements MultiMap {
+@@ -331,21 +331,21 @@ public class MultiHashMap extends HashMap implements M
* @param item the value to remove
* @return the value removed (which was passed in), null if nothing removed
*/
@@ -26,8 +26,7 @@
}
/**
-
---- src/java/org/apache/commons/collections/MultiMap.java
+--- src/java/org/apache/commons/collections/MultiMap.java.orig 2019-10-04 16:36:43 UTC
+++ src/java/org/apache/commons/collections/MultiMap.java
@@ -66,7 +66,7 @@ public interface MultiMap extends Map {
* @throws ClassCastException if the key or value is of an invalid type
@@ -47,8 +46,7 @@
/**
* Gets a collection containing all the values in the map.
-
---- src/java/org/apache/commons/collections/map/MultiKeyMap.java
+--- src/java/org/apache/commons/collections/map/MultiKeyMap.java.orig 2019-10-04 16:36:43 UTC
+++ src/java/org/apache/commons/collections/map/MultiKeyMap.java
@@ -197,7 +197,7 @@ public class MultiKeyMap
* @param key2 the second key
@@ -76,10 +74,9 @@
}
/**
-
---- src/java/org/apache/commons/collections/map/MultiValueMap.java
+--- src/java/org/apache/commons/collections/map/MultiValueMap.java.orig 2019-10-04 16:36:43 UTC
+++ src/java/org/apache/commons/collections/map/MultiValueMap.java
-@@ -153,19 +153,19 @@ public class MultiValueMap extends AbstractMapDecorator implements MultiMap {
+@@ -153,19 +153,19 @@ public class MultiValueMap extends AbstractMapDecorato
* @param value the value to remove
* @return the value removed (which was passed in), null if nothing removed
*/
@@ -103,10 +100,9 @@
}
/**
-
---- src/test/org/apache/commons/collections/TestMultiHashMap.java
+--- src/test/org/apache/commons/collections/TestMultiHashMap.java.orig 2019-10-04 16:36:43 UTC
+++ src/test/org/apache/commons/collections/TestMultiHashMap.java
-@@ -464,11 +464,11 @@ public class TestMultiHashMap extends AbstractTestMap {
+@@ -464,11 +464,11 @@ public class TestMultiHashMap extends AbstractTestMap
map.put("A", "AA");
map.put("A", "AB");
map.put("A", "AC");
@@ -123,10 +119,9 @@
assertEquals(new MultiHashMap(), map);
}
-
---- src/test/org/apache/commons/collections/map/TestMultiKeyMap.java
+--- src/test/org/apache/commons/collections/map/TestMultiKeyMap.java.orig 2019-10-04 16:36:43 UTC
+++ src/test/org/apache/commons/collections/map/TestMultiKeyMap.java
-@@ -315,10 +315,10 @@ public class TestMultiKeyMap extends AbstractTestIterableMap {
+@@ -315,10 +315,10 @@ public class TestMultiKeyMap extends AbstractTestItera
switch (key.size()) {
case 2:
assertEquals(true, multimap.containsKey(key.getKey(0), key.getKey(1)));
@@ -139,6 +134,3 @@
assertEquals(false, multimap.containsKey(key.getKey(0), key.getKey(1)));
break;
case 3:
---
-2.5.0
-
diff --git a/java/jakarta-commons-collections/pkg-descr b/java/apache-commons-collections/pkg-descr
index 30ff4cf8b74a..82612041d587 100644
--- a/java/jakarta-commons-collections/pkg-descr
+++ b/java/apache-commons-collections/pkg-descr
@@ -1,12 +1,11 @@
A suite of classes that extend or augment the Java Collections Framework.
-There are certain holes left unfilled by Sun's implementations, and the
-Jakarta-Commons Collections Component strives to fulfill them. Among the
-features of this package are:
+Commons-Collections seek to build upon the JDK classes by providing new interfaces, implementations and utilities. There are many features,
+including:
Special-purpose implementations of Lists and Maps for fast access Adapter
classes from Java1-style containers (arrays, enumerations) to Java 2-style
collections. Methods to test or create typical set-theory properties of
collections such as union, intersection, and closure.
-WWW: http://jakarta.apache.org/commons/collections/
+WWW: http://commons.apache.org/proper/commons-collections/
diff --git a/java/jakarta-commons-lang/Makefile b/java/apache-commons-lang/Makefile
index c9099b278dde..1dc30a7a3b81 100644
--- a/java/jakarta-commons-lang/Makefile
+++ b/java/apache-commons-lang/Makefile
@@ -5,11 +5,11 @@ PORTNAME= commons-lang
PORTVERSION= 2.6
CATEGORIES= java devel
MASTER_SITES= APACHE_COMMONS_SOURCE
-PKGNAMEPREFIX= jakarta-
+PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
-COMMENT= Jakarta library with helper utilities for the java.lang API
+COMMENT= Apache library with helper utilities for the java.lang API
LICENSE= APACHE20
diff --git a/java/jakarta-commons-lang/distinfo b/java/apache-commons-lang/distinfo
index 7e9fabf47253..7e9fabf47253 100644
--- a/java/jakarta-commons-lang/distinfo
+++ b/java/apache-commons-lang/distinfo
diff --git a/java/jakarta-commons-lang/pkg-descr b/java/apache-commons-lang/pkg-descr
index f3201fc3f34a..a9e5b50b78ec 100644
--- a/java/jakarta-commons-lang/pkg-descr
+++ b/java/apache-commons-lang/pkg-descr
@@ -10,4 +10,4 @@ enum type, an exception structure that supports multiple types of
nested-Exceptions and a series of utlities dedicated to help with
building methods, such as hashCode, toString and equals.
-WWW: http://jakarta.apache.org/commons/lang/
+WWW: http://commons.apache.org/proper/commons-lang/
diff --git a/java/jakarta-commons-logging/Makefile b/java/apache-commons-logging/Makefile
index 7271807ca0a5..d11312f4134b 100644
--- a/java/jakarta-commons-logging/Makefile
+++ b/java/apache-commons-logging/Makefile
@@ -5,7 +5,7 @@ PORTNAME= commons-logging
PORTVERSION= 1.2
CATEGORIES= java devel
MASTER_SITES= APACHE_COMMONS_BINARIES
-PKGNAMEPREFIX= jakarta-
+PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}-${PORTVERSION}-bin
MAINTAINER= makc@FreeBSD.org
diff --git a/java/jakarta-commons-logging/distinfo b/java/apache-commons-logging/distinfo
index a8e6b728f678..dbbab162e5d4 100644
--- a/java/jakarta-commons-logging/distinfo
+++ b/java/apache-commons-logging/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1570207571
SHA256 (commons-logging-1.2-bin.tar.gz) = 3f758805c7290d9c6d22d1451587c9f7232744aef4c984e88aa683cdea0587bd
SIZE (commons-logging-1.2-bin.tar.gz) = 315429
diff --git a/java/jakarta-commons-logging/pkg-descr b/java/apache-commons-logging/pkg-descr
index cca5492a557b..02a93bf2c47d 100644
--- a/java/jakarta-commons-logging/pkg-descr
+++ b/java/apache-commons-logging/pkg-descr
@@ -1,4 +1,4 @@
-Jakarta Commons Logging library.
+Apache Commons Logging library.
There is a great need for debugging and logging information inside of Commons
components such as HTTPClient and DBCP. However, there are many logging APIs
@@ -9,4 +9,4 @@ libraries. Commons components may use the Logging API to remove compile-time
and run-time dependencies on any particular logging package, and contributors
may write Log implementations for the library of their choice.
-WWW: http://jakarta.apache.org/commons/logging/
+WWW: http://commons.apache.org/proper/commons-logging/
diff --git a/java/jakarta-commons-primitives/Makefile b/java/apache-commons-primitives/Makefile
index d2b42ac33f1a..d0f90bd72722 100644
--- a/java/jakarta-commons-primitives/Makefile
+++ b/java/apache-commons-primitives/Makefile
@@ -3,15 +3,16 @@
PORTNAME= commons-primitives
PORTVERSION= 1.0
-PORTREVISION= 3
CATEGORIES= java
MASTER_SITES= APACHE_COMMONS_SOURCE
-PKGNAMEPREFIX= jakarta-
+PKGNAMEPREFIX= apache-
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Library supporting Java primitive types
+LICENSE= APACHE20
+
USE_JAVA= yes
JAVA_VERSION= 1.6+
USE_ANT= yes
diff --git a/java/jakarta-commons-primitives/distinfo b/java/apache-commons-primitives/distinfo
index a67b7cbf3782..a67b7cbf3782 100644
--- a/java/jakarta-commons-primitives/distinfo
+++ b/java/apache-commons-primitives/distinfo
diff --git a/java/jakarta-commons-primitives/pkg-descr b/java/apache-commons-primitives/pkg-descr
index 8b027b0211ab..3c8644d749fd 100644
--- a/java/jakarta-commons-primitives/pkg-descr
+++ b/java/apache-commons-primitives/pkg-descr
@@ -1,4 +1,4 @@
-Apache Jakarta Commons Primitives provides a collection of types and utilities
+Apache Commons Primitives provides a collection of types and utilities
optimized for working with Java primitives (boolean, byte, char, double, float,
int, long, short). Generally, the Commons-Primitives classes are faster,
smaller and easier to work with than their purely Object based alternatives.
@@ -6,4 +6,4 @@ smaller and easier to work with than their purely Object based alternatives.
Currently Commons Primitives is primarily composed of implementations of the
java.util collections adapted for the primitive types.
-WWW: http://jakarta.apache.org/commons/primitives
+WWW: http://commons.apache.org/dormant/commons-primitives/
diff --git a/java/jakarta-commons-beanutils/Makefile b/java/jakarta-commons-beanutils/Makefile
index 4f71830f072c..c099069efeb3 100644
--- a/java/jakarta-commons-beanutils/Makefile
+++ b/java/jakarta-commons-beanutils/Makefile
@@ -3,6 +3,7 @@
PORTNAME= commons-beanutils
PORTVERSION= 1.9.2
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= APACHE_COMMONS_SOURCE
PKGNAMEPREFIX= jakarta-
@@ -13,10 +14,10 @@ COMMENT= JavaBeans utility library
LICENSE= APACHE20
-BUILD_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging \
- ${JAVALIBDIR}/commons-collections.jar:java/jakarta-commons-collections
-RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging \
- ${JAVALIBDIR}/commons-collections.jar:java/jakarta-commons-collections
+BUILD_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging \
+ ${JAVALIBDIR}/commons-collections.jar:java/apache-commons-collections
+RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging \
+ ${JAVALIBDIR}/commons-collections.jar:java/apache-commons-collections
USES= dos2unix
USE_JAVA= yes
diff --git a/java/jakarta-commons-cli/pkg-descr b/java/jakarta-commons-cli/pkg-descr
deleted file mode 100644
index 92c720c4d4f3..000000000000
--- a/java/jakarta-commons-cli/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-The Jakarta Commons CLI library provides a simple and easy to use
-API for working with the command line arguments and options.
-
-WWW: http://jakarta.apache.org/commons/cli/
diff --git a/java/jakarta-commons-httpclient/Makefile b/java/jakarta-commons-httpclient/Makefile
index 9d0a38b74fa2..1b682d7f3837 100644
--- a/java/jakarta-commons-httpclient/Makefile
+++ b/java/jakarta-commons-httpclient/Makefile
@@ -3,7 +3,7 @@
PORTNAME= commons-httpclient
DISTVERSION= 3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= java www
MASTER_SITES= APACHE/httpcomponents/${PORTNAME}/source
PKGNAMEPREFIX= jakarta-
@@ -14,9 +14,9 @@ COMMENT= Package implementing the client side of the HTTP standard
LICENSE= APACHE20
-BUILD_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging
+BUILD_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging
BUILD_DEPENDS+= ${JAVALIBDIR}/commons-codec.jar:java/jakarta-commons-codec
-RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging
+RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/apache-commons-logging
RUN_DEPENDS+= ${JAVALIBDIR}/commons-codec.jar:java/jakarta-commons-codec
OPTIONS_DEFINE= DOCS
diff --git a/java/jakarta-oro/pkg-descr b/java/jakarta-oro/pkg-descr
index fc15f6512b0d..21a52b2b5616 100644
--- a/java/jakarta-oro/pkg-descr
+++ b/java/jakarta-oro/pkg-descr
@@ -7,4 +7,6 @@ libraries from ORO, Inc. (www.oroinc.com). They have been donated to
the Jakarta Project by Daniel Savarese (www.savarese.org), the
copyright holder of the ORO libraries.
+As of 2010-09-01, the ORO project is retired.
+
WWW: http://jakarta.apache.org/oro/
diff --git a/java/jakarta-regexp/pkg-descr b/java/jakarta-regexp/pkg-descr
index 00b0866dc117..d91bade637c4 100644
--- a/java/jakarta-regexp/pkg-descr
+++ b/java/jakarta-regexp/pkg-descr
@@ -1,3 +1,5 @@
A 100% Pure Java Regular Expression package by Jonathan Locke.
+As of 2011-04-17, the Regexp project is retired.
+
WWW: http://jakarta.apache.org/regexp/