aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-02-01 15:17:06 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-02-01 15:17:06 +0000
commitf09c06cf38813e4202e38c8c4885541da1894aa8 (patch)
treec9a3d1e420cf8a011649e95bc253e2f9bec470ba /java
parentf2d6bcfffc9efd477db4179f61fc5676e88a7f90 (diff)
downloadports-f09c06cf38813e4202e38c8c4885541da1894aa8.tar.gz
ports-f09c06cf38813e4202e38c8c4885541da1894aa8.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/openjfx8-devel/Makefile25
-rw-r--r--java/openjfx8-devel/distinfo6
-rw-r--r--java/openjfx8-devel/files/bsd.gradle1
-rw-r--r--java/openjfx8-devel/files/patch-build.gradle72
-rw-r--r--java/openjfx8-devel/files/patch-build.properties17
-rw-r--r--java/openjfx8-devel/files/patch-modules_media_src_main_native_gstreamer_gstreamer-lite_gstreamer_gst_gstregistry.c11
-rw-r--r--java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WTF_wtf_CMakeLists.txt4
-rw-r--r--java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WTF_wtf_unicode_java_UnicodeJava.h4
-rw-r--r--java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_PlatformJava.cmake4
-rw-r--r--java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_cmake_OptionsJava.cmake4
-rw-r--r--java/openjfx8-devel/files/patch-modules_web_src_main_native_Tools_DumpRenderTree_TestRunner.cpp4
-rw-r--r--java/openjfx8-devel/files/patch-modules_web_src_main_native_Tools_DumpRenderTree_java_CMakeLists.txt4
-rw-r--r--java/openjfx8-devel/files/patch-modules_web_src_main_native_Tools_Scripts_webkitdirs.pm4
-rw-r--r--java/openjfx8-devel/pkg-plist2
14 files changed, 69 insertions, 93 deletions
diff --git a/java/openjfx8-devel/Makefile b/java/openjfx8-devel/Makefile
index 1ab83d1fe9c0..c99297f0a873 100644
--- a/java/openjfx8-devel/Makefile
+++ b/java/openjfx8-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= openjfx8
-DISTVERSION= 8u172-b00
-PORTREVISION= 3
+DISTVERSION= 8u172-b03
PORTEPOCH= 1
CATEGORIES= java x11-toolkits devel
MASTER_SITES= https://github.com/t6/openjfx/releases/download/release/ \
@@ -21,13 +20,11 @@ ONLY_FOR_ARCHS= amd64 i386
BUILD_DEPENDS= apache-ant>0:devel/apache-ant \
antlr3>0:devel/antlr3 \
gradle>=4.0:devel/gradle \
- ${JAVALIBDIR}/junit.jar:java/junit \
- swt-devel>0:x11-toolkits/swt-devel
+ ${JAVALIBDIR}/junit.jar:java/junit
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-RUN_DEPENDS= swt-devel>0:x11-toolkits/swt-devel
-USES= gettext-runtime jpeg sqlite
+USES= gettext-runtime jpeg pkgconfig sqlite
USE_GL= gl
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk20 pango
USE_JAVA= yes
@@ -35,17 +32,22 @@ JAVA_VERSION= 1.8
USE_LDCONFIG= yes
USE_XORG= x11 xtst xxf86vm
-OPTIONS_DEFINE= MEDIA TEST WEBKIT
+OPTIONS_DEFINE= MEDIA SWT TEST WEBKIT
OPTIONS_DEFAULT= MEDIA WEBKIT
OPTIONS_SUB= yes
-MEDIA_DESC= Build media module
+MEDIA_DESC= Media module
+SWT_DESC= SWT support
MEDIA_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
libsndio.so:audio/sndio
MEDIA_USES= gmake
MEDIA_VARS= COMPILE_MEDIA=true
+SWT_BUILD_DEPENDS= swt-devel>0:x11-toolkits/swt-devel
+SWT_RUN_DEPENDS= swt-devel>0:x11-toolkits/swt-devel
+SWT_VARS= COMPILE_SWT=true
+
TEST_USES= display:test
TEST_VARS= AWT_TEST=true FULL_TEST=true
@@ -53,8 +55,7 @@ TEST_VARS= AWT_TEST=true FULL_TEST=true
WEBKIT_BUILD_DEPENDS= cmake:devel/cmake
WEBKIT_IMPLIES= MEDIA
WEBKIT_LIB_DEPENDS= libicui18n.so:devel/icu
-WEBKIT_USES= bison compiler:c++14-lang gmake gperf perl5 pkgconfig \
- python:2.7,build
+WEBKIT_USES= bison compiler:c++14-lang gmake gperf perl5 python:2.7,build
WEBKIT_USE= GNOME=libxslt,libxml2 \
PERL5=build \
RUBY=yes \
@@ -105,12 +106,16 @@ post-patch:
@${RM} -r ${WRKSRC}/modules/web/src/main/native/Source/ThirdParty/icu \
${WRKSRC}/modules/web/src/main/native/Source/ThirdParty/sqlite
+post-patch-SWT-off:
+ @${RM} -r ${WRKSRC}/modules/graphics/src/main/java/com/sun/glass/ui/swt
+
do-configure:
@${MKDIR} ${WRKDIR}/gradle-home
@${ECHO_CMD} "NUM_COMPILE_THREADS = ${MAKE_JOBS_NUMBER}" > ${WRKSRC}/gradle.properties
.for prop in COMPILE_MEDIA COMPILE_WEBKIT AWT_TEST FULL_TEST
@${ECHO_CMD} "${prop} = ${${prop}:Ufalse}" >> ${WRKSRC}/gradle.properties
.endfor
+ @${ECHO_CMD} "BSD.compileSWT = ${COMPILE_SWT:Ufalse};" >> ${WRKSRC}/buildSrc/bsd.gradle
do-build:
@cd ${WRKSRC} && ${GRADLE_RUN} zips
diff --git a/java/openjfx8-devel/distinfo b/java/openjfx8-devel/distinfo
index 408d6025dde3..4f7d7126ee8f 100644
--- a/java/openjfx8-devel/distinfo
+++ b/java/openjfx8-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1506878786
-SHA256 (openjfx8-8u172-b00.tar.gz) = b6689302cb215b22b0b673d47b3738ac48a423149f2e047dbdebbc87fbefc8ac
-SIZE (openjfx8-8u172-b00.tar.gz) = 109884684
+TIMESTAMP = 1517218697
+SHA256 (openjfx8-8u172-b03.tar.gz) = 1648bcce3a9f3ee9ac4353f0b3fb896818a3a89440497d0bb8853d22dddf132d
+SIZE (openjfx8-8u172-b03.tar.gz) = 107849167
diff --git a/java/openjfx8-devel/files/bsd.gradle b/java/openjfx8-devel/files/bsd.gradle
index 2e1e63566336..4a77f9800493 100644
--- a/java/openjfx8-devel/files/bsd.gradle
+++ b/java/openjfx8-devel/files/bsd.gradle
@@ -31,7 +31,6 @@ if (!BSD.canBuild) return;
// All desktop related packages should be built
BSD.compileSwing = true;
-BSD.compileSWT = true;
BSD.compileFXPackager = true;
// Libraries end up in the sdk/rt/lib/$OS_ARCH directory for freebsd
diff --git a/java/openjfx8-devel/files/patch-build.gradle b/java/openjfx8-devel/files/patch-build.gradle
index 3a37d8389c78..cf1fd4e50a79 100644
--- a/java/openjfx8-devel/files/patch-build.gradle
+++ b/java/openjfx8-devel/files/patch-build.gradle
@@ -1,4 +1,4 @@
---- build.gradle.orig 2017-09-08 16:56:55 UTC
+--- build.gradle.orig 2018-01-16 01:40:56 UTC
+++ build.gradle
@@ -251,6 +251,7 @@ ext.IS_64 = OS_ARCH.toLowerCase().contains("64")
ext.IS_MAC = OS_NAME.contains("mac") || OS_NAME.contains("darwin")
@@ -76,7 +76,7 @@
if (IS_WINDOWS && OS_ARCH != "x86" && OS_ARCH != "amd64") {
throw new Exception("Unknown and unsupported build architecture: $OS_ARCH")
} else if (IS_MAC && OS_ARCH != "x86_64") {
-@@ -1168,7 +1176,8 @@ allprojects {
+@@ -1169,7 +1177,8 @@ allprojects {
// By default all of our projects require junit for testing so we can just
// setup this dependency here.
dependencies {
@@ -86,7 +86,7 @@
if (BUILD_CLOSED && DO_JCOV) {
testCompile name: "jcov"
}
-@@ -1306,12 +1315,15 @@ project(":graphics") {
+@@ -1307,12 +1316,15 @@ project(":graphics") {
dependencies {
compile project(":base"), BUILD_SRC
@@ -107,7 +107,7 @@
}
// Create a single "native" task which will depend on all the individual native tasks for graphics
-@@ -1460,7 +1472,7 @@ project(":graphics") {
+@@ -1461,7 +1473,7 @@ project(":graphics") {
workingDir = "modules/graphics"
main = settings.generator
classpath = configurations.compile + configurations.antlr3
@@ -116,7 +116,7 @@
classpath += files("$buildDir/classes/jsl-compilers/decora")
args = ["-i", sourceDir, "-o", destinationDir, "-t", "-pkg", "com/sun/scenario/effect", "$settings.outputs", "$settings.fileName"]
jvmArgs "-Djava.ext.dirs="
-@@ -1471,9 +1483,9 @@ project(":graphics") {
+@@ -1472,9 +1484,9 @@ project(":graphics") {
task generateDecoraNativeHeaders(type: JavaHeaderTask, dependsOn: compileDecoraJavaShaders) {
description = "Generates JNI Headers for Decora SSE Natives"
source file("$buildDir/classes/jsl-decora")
@@ -128,7 +128,7 @@
output = file("$buildDir/generated-src/headers/jsl-decora")
}
-@@ -1601,9 +1613,7 @@ project(":graphics") {
+@@ -1602,9 +1614,7 @@ project(":graphics") {
copy {
into libsDir
from f.getParentFile()
@@ -139,7 +139,7 @@
includeEmptyDirs = false
}
// Have to rename the swt jar because it is some platform specific name but
-@@ -1650,7 +1660,7 @@ project(":controls") {
+@@ -1651,7 +1661,7 @@ project(":controls") {
javaexec {
executable = JAVA
workingDir = "modules/controls"
@@ -148,7 +148,7 @@
project(":graphics").sourceSets.main.output,
project(":base").sourceSets.main.output)
main = "com.sun.javafx.css.parser.Css2Bin"
-@@ -1687,7 +1697,11 @@ project(":swt") {
+@@ -1688,7 +1698,11 @@ project(":swt") {
}
dependencies {
compile BUILD_SRC, project(":base"), project(":graphics")
@@ -161,7 +161,7 @@
}
}
-@@ -1786,7 +1800,7 @@ project(":fxpackager") {
+@@ -1787,7 +1801,7 @@ project(":fxpackager") {
}
dependencies {
@@ -170,7 +170,7 @@
}
// When producing the jar, we need to relocate a few class files
-@@ -2037,7 +2051,7 @@ project(":fxpackager") {
+@@ -2038,7 +2052,7 @@ project(":fxpackager") {
description = "Creates the packager.jar"
archiveName = "packager.jar";
includeEmptyDirs = false
@@ -179,7 +179,7 @@
from("$buildDir/resources/main");
include('jdk/packager/**')
-@@ -2047,21 +2061,6 @@ project(":fxpackager") {
+@@ -2048,21 +2062,6 @@ project(":fxpackager") {
jar.dependsOn buildJavaPackager
jar.dependsOn packagerJar
@@ -201,7 +201,7 @@
task packagerFakeJar(type: Jar) {
dependsOn compileTestJava
from compileTestJava.destinationDir
-@@ -2240,7 +2239,7 @@ project(":media") {
+@@ -2241,7 +2240,7 @@ project(":media") {
doLast {
exec {
@@ -210,7 +210,7 @@
args("JAVA_HOME=${JDK_HOME}", "GENERATED_HEADERS_DIR=${generatedHeadersDir}",
"OUTPUT_DIR=${nativeOutputDir}", "BUILD_TYPE=${buildType}", "BASE_NAME=jfxmedia",
"COMPILE_PARFAIT=${compileParfait}")
-@@ -2250,7 +2249,7 @@ project(":media") {
+@@ -2251,7 +2250,7 @@ project(":media") {
args(IS_64 ? "ARCH=x64" : "ARCH=x32", "RESOURCE=${nativeOutputDir}/${buildType}/${WIN.media.jfxmediaRcFile}")
} else {
args ("CC=${mediaProperties.compiler}", "LINK=${mediaProperties.linker}", "LIB=${mediaProperties.lib}")
@@ -219,7 +219,7 @@
args(IS_64 ? "ARCH=x64" : "ARCH=x32")
}
-@@ -2272,7 +2271,7 @@ project(":media") {
+@@ -2273,7 +2272,7 @@ project(":media") {
enabled = IS_COMPILE_MEDIA
doLast {
exec {
@@ -228,7 +228,7 @@
args("OUTPUT_DIR=${nativeOutputDir}", "BUILD_TYPE=${buildType}", "BASE_NAME=gstreamer-lite")
if (t.name == "win") {
-@@ -2280,7 +2279,7 @@ project(":media") {
+@@ -2281,7 +2280,7 @@ project(":media") {
args(IS_64 ? "ARCH=x64" : "ARCH=x32", "RESOURCE=${nativeOutputDir}/${buildType}/${WIN.media.gstreamerRcFile}")
} else {
args ("CC=${mediaProperties.compiler}", "LINK=${mediaProperties.linker}", "LIB=${mediaProperties.lib}")
@@ -237,7 +237,7 @@
args(IS_64 ? "ARCH=x64" : "ARCH=x32")
}
}
-@@ -2301,7 +2300,7 @@ project(":media") {
+@@ -2302,7 +2301,7 @@ project(":media") {
doLast {
exec {
@@ -246,7 +246,7 @@
args("OUTPUT_DIR=${nativeOutputDir}", "BUILD_TYPE=${buildType}", "BASE_NAME=fxplugins",
"ON2_SRCDIR=${project.ext.ON2_SRCDIR}", "ON2_LIB=${project.ext.ON2_LIB}")
-@@ -2318,7 +2317,7 @@ project(":media") {
+@@ -2319,7 +2318,7 @@ project(":media") {
args(IS_64 ? "ARCH=x64" : "ARCH=x32", "RESOURCE=${nativeOutputDir}/${buildType}/${WIN.media.fxpluginsRcFile}")
} else {
args ("CC=${mediaProperties.compiler}", "LINK=${mediaProperties.linker}", "LIB=${mediaProperties.lib}")
@@ -255,7 +255,7 @@
args(IS_64 ? "ARCH=x64" : "ARCH=x32")
}
}
-@@ -2328,7 +2327,7 @@ project(":media") {
+@@ -2329,7 +2328,7 @@ project(":media") {
buildNative.dependsOn buildPlugins
@@ -264,7 +264,7 @@
def buildAVPlugin = task( "buildAVPlugin", dependsOn: [buildPlugins]) {
enabled = IS_COMPILE_MEDIA
-@@ -2339,7 +2338,7 @@ project(":media") {
+@@ -2340,7 +2339,7 @@ project(":media") {
File dir = file(libavDir)
if (dir.exists()) {
exec {
@@ -273,7 +273,7 @@
args("CC=${mediaProperties.compiler}", "OUTPUT_DIR=${nativeOutputDir}", "BUILD_TYPE=${buildType}",
"BASE_NAME=avplugin", "VERSION=${version}", "LIBAV_DIR=${libavDir}",
"SUFFIX=", IS_64 ? "ARCH=x64" : "ARCH=x32")
-@@ -2352,7 +2351,7 @@ project(":media") {
+@@ -2353,7 +2352,7 @@ project(":media") {
File dir = file(libavDir)
if (dir.exists()) {
exec {
@@ -282,7 +282,7 @@
args("CC=${mediaProperties.compiler}", "LINKER=${mediaProperties.linker}",
"OUTPUT_DIR=${nativeOutputDir}", "BUILD_TYPE=${buildType}",
"BASE_NAME=avplugin", "VERSION=${version}", "LIBAV_DIR=${libavDir}",
-@@ -2363,7 +2362,7 @@ project(":media") {
+@@ -2364,7 +2363,7 @@ project(":media") {
} else {
// Building fxavcodec plugin (libav plugin)
exec {
@@ -291,7 +291,7 @@
args("CC=${mediaProperties.compiler}", "OUTPUT_DIR=${nativeOutputDir}", "BUILD_TYPE=${buildType}",
"BASE_NAME=avplugin", IS_64 ? "ARCH=x64" : "ARCH=x32")
}
-@@ -2411,7 +2410,7 @@ project(":media") {
+@@ -2412,7 +2411,7 @@ project(":media") {
doLast {
exec {
environment(WINDOWS_NATIVE_COMPILE_ENVIRONMENT)
@@ -300,7 +300,7 @@
args("OUTPUT_DIR=${nativeOutputDir}", "BUILD_TYPE=${buildType}", "BASE_NAME=glib-lite",
IS_64 ? "ARCH=x64" : "ARCH=x32", "RESOURCE=${nativeOutputDir}/${buildType}/${WIN.media.glibRcFile}")
}
-@@ -2424,7 +2423,7 @@ project(":media") {
+@@ -2425,7 +2424,7 @@ project(":media") {
enabled = IS_COMPILE_MEDIA
doLast {
exec {
@@ -309,7 +309,7 @@
args("OUTPUT_DIR=${nativeOutputDir}", "BUILD_TYPE=${buildType}", "BASE_NAME=glib-lite")
args ("CC=${mediaProperties.compiler}", "LINK=${mediaProperties.linker}", "LIB=${mediaProperties.lib}")
}
-@@ -2477,7 +2476,7 @@ project(":web") {
+@@ -2478,7 +2477,7 @@ project(":web") {
task generateHeaders(dependsOn: compileJava) {
doLast {
@@ -327,17 +327,17 @@
IS_64 ? "${t.name}-amd64" : "${t.name}-i586"
def webkitOutputDir = cygpath("$buildDir/${t.name}")
-@@ -2586,6 +2585,9 @@ project(":web") {
+@@ -2592,6 +2591,9 @@ project(":web") {
targetCpuBitDepthSwitch = "--32-bit"
}
+ cmakeArgs += " -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON"
+ cmakeArgs += " -DCMAKE_C_COMPILER:STRING=${System.getenv("CC")}"
+ cmakeArgs += " -DCMAKE_CXX_COMPILER:STRING=${System.getenv("CXX")}"
- commandLine("perl", "Tools/Scripts/build-webkit",
+ commandLine("perl", "$projectDir/src/main/native/Tools/Scripts/build-webkit",
"--java", "--icu-unicode", targetCpuBitDepthSwitch,
"--cmakeargs=${cmakeArgs}")
-@@ -2628,7 +2630,7 @@ project(":web") {
+@@ -2634,7 +2636,7 @@ project(":web") {
task drtJar(type: Jar, dependsOn: compileJava) {
archiveName = "drt.jar"
destinationDir = file("$buildDir/test")
@@ -346,7 +346,7 @@
include drtClasses
}
if (IS_COMPILE_WEBKIT) {
-@@ -2880,22 +2882,22 @@ compileTargets { t ->
+@@ -2886,22 +2888,22 @@ compileTargets { t ->
description = "Creates the jfxrt.jar for the $t.name target"
archiveName = "build/${sdkDirName}/rt/lib/ext/jfxrt.jar";
includeEmptyDirs = false
@@ -376,7 +376,7 @@
if (!IS_MAC) {
exclude ("modules/media/build/classes/main/com/sun/media/jfxmediaimpl/platform/osx/**",
-@@ -2960,7 +2962,7 @@ compileTargets { t ->
+@@ -2966,7 +2968,7 @@ compileTargets { t ->
"modules/web/build/resources/ios",
"modules/extensions/build/classes/ios")
} else {
@@ -385,7 +385,7 @@
}
exclude("**/javafx/embed/swt/**")
-@@ -3000,8 +3002,8 @@ compileTargets { t ->
+@@ -3007,8 +3009,8 @@ compileTargets { t ->
description = "Creates the jfxswt.jar for the $t.name target"
archiveName = "build/${sdkDirName}/rt/lib/jfxswt.jar";
includeEmptyDirs = false
@@ -396,7 +396,7 @@
include("**/javafx/embed/swt/**")
exclude("**/*.java"); // Builder java files are in build/classes and should be excluded
-@@ -3022,7 +3024,7 @@ compileTargets { t ->
+@@ -3029,7 +3031,7 @@ compileTargets { t ->
description = "Creates the javafx-mx.jar"
archiveName = "build/${sdkDirName}/lib/javafx-mx.jar";
includeEmptyDirs = false
@@ -405,7 +405,7 @@
from "modules/jmx/build/resources/main"
dependsOn project(":jmx").assemble
}
-@@ -3077,7 +3079,7 @@ compileTargets { t ->
+@@ -3084,7 +3086,7 @@ compileTargets { t ->
// OSX media natives
[ "jfxmedia_qtkit", "jfxmedia_avf", "glib-lite" ].each { name ->
from ("modules/media/build/native/${t.name}/${mediaBuildType}/${library(name)}") }
@@ -414,7 +414,7 @@
from("modules/media/build/native/${t.name}/${mediaBuildType}") { include "libavplugin*.so" }
} else from ("modules/media/build/native/${t.name}/${mediaBuildType}/${library("glib-lite")}")
} else {
-@@ -3090,7 +3092,7 @@ compileTargets { t ->
+@@ -3097,7 +3099,7 @@ compileTargets { t ->
// copy libjfxmedia_{avf,qtkit}.dylib if they exist
[ "jfxmedia_qtkit", "jfxmedia_avf", "glib-lite" ].each { name ->
from ("$LIBRARY_STUB/${library(name)}") }
@@ -423,7 +423,7 @@
from(LIBRARY_STUB) { include "libavplugin*.so" }
}
else if (t.name != "android" && t.name != "dalvik" ) {
-@@ -3155,7 +3157,7 @@ compileTargets { t ->
+@@ -3162,7 +3164,7 @@ compileTargets { t ->
}
// Copy over the javapackager executable
@@ -432,7 +432,7 @@
copy {
from "modules/fxpackager/build/javapackager"
into "build/${sdkDirName}/bin"
-@@ -3208,10 +3210,11 @@ ext.JFXRT_CP =
+@@ -3215,10 +3217,11 @@ ext.JFXRT_CP =
project(":fxml").sourceSets.main.output.classesDir,
project(":swing").sourceSets.main.output.classesDir, //NOTE - used by 3Dviewer
project(":builders").sourceSets.main.output.classesDir,
@@ -446,7 +446,7 @@
project(":apps") {
// The apps build is Ant based, and gradle lets us "import" ant build.xml
// into our configuration.
-@@ -3256,7 +3259,7 @@ project(":apps") {
+@@ -3295,7 +3298,7 @@ project(":apps") {
}
rootProject.clean.dependsOn(appsClean)
}
diff --git a/java/openjfx8-devel/files/patch-build.properties b/java/openjfx8-devel/files/patch-build.properties
deleted file mode 100644
index abf994ce7854..000000000000
--- a/java/openjfx8-devel/files/patch-build.properties
+++ /dev/null
@@ -1,17 +0,0 @@
-http://hg.openjdk.java.net/openjfx/8u/rt/rev/aefb29b5a599
-
---- build.properties.orig 2017-09-08 16:56:55 UTC
-+++ build.properties
-@@ -40,10 +40,10 @@ jfx.release.milestone=ea
- jfx.release.suffix=-ea
-
- # UPDATE THE FOLLOWING VALUES FOR A NEW RELEASE
--jfx.release.name=8u162
-+jfx.release.name=8u172
- jfx.release.major.version=8
- jfx.release.minor.version=0
--jfx.release.micro.version=162
-+jfx.release.micro.version=172
-
- ##############################################################################
- #
diff --git a/java/openjfx8-devel/files/patch-modules_media_src_main_native_gstreamer_gstreamer-lite_gstreamer_gst_gstregistry.c b/java/openjfx8-devel/files/patch-modules_media_src_main_native_gstreamer_gstreamer-lite_gstreamer_gst_gstregistry.c
deleted file mode 100644
index 9a8963d04223..000000000000
--- a/java/openjfx8-devel/files/patch-modules_media_src_main_native_gstreamer_gstreamer-lite_gstreamer_gst_gstregistry.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- modules/media/src/main/native/gstreamer/gstreamer-lite/gstreamer/gst/gstregistry.c.orig 2017-10-04 12:06:08 UTC
-+++ modules/media/src/main/native/gstreamer/gstreamer-lite/gstreamer/gst/gstregistry.c
-@@ -162,7 +162,7 @@ extern HMODULE _priv_gst_dll_handle;
- #include <link.h>
- #include <dlfcn.h>
-
--static const int AVCODEC_EXPLICIT_VERSIONS[] = { 53, 54, 55, 56 };
-+static const int AVCODEC_EXPLICIT_VERSIONS[] = { 53, 54, 55, 56, 57 };
- static const int AVCODEC_FFMPEG_EXPLICIT_VERSIONS[] = { 56 };
-
- typedef unsigned (*avcodec_version_proto)();
diff --git a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WTF_wtf_CMakeLists.txt b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WTF_wtf_CMakeLists.txt
index e32a465f6b56..6c7aa8dc0086 100644
--- a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WTF_wtf_CMakeLists.txt
+++ b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WTF_wtf_CMakeLists.txt
@@ -1,6 +1,6 @@
---- modules/web/src/main/native/Source/WTF/wtf/CMakeLists.txt.orig 2017-09-08 16:56:55 UTC
+--- modules/web/src/main/native/Source/WTF/wtf/CMakeLists.txt.orig 2018-01-16 01:40:56 UTC
+++ modules/web/src/main/native/Source/WTF/wtf/CMakeLists.txt
-@@ -309,6 +309,7 @@ list(APPEND WTF_SOURCES
+@@ -343,6 +343,7 @@ list(APPEND WTF_SOURCES
)
set(WTF_SYSTEM_INCLUDE_DIRECTORIES
${ICU_INCLUDE_DIRS}
diff --git a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WTF_wtf_unicode_java_UnicodeJava.h b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WTF_wtf_unicode_java_UnicodeJava.h
index e516309fd44b..01f03348c8a8 100644
--- a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WTF_wtf_unicode_java_UnicodeJava.h
+++ b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WTF_wtf_unicode_java_UnicodeJava.h
@@ -1,8 +1,8 @@
---- modules/web/src/main/native/Source/WTF/wtf/unicode/java/UnicodeJava.h.orig 2017-09-08 16:56:55 UTC
+--- modules/web/src/main/native/Source/WTF/wtf/unicode/java/UnicodeJava.h.orig 2018-01-16 01:40:56 UTC
+++ modules/web/src/main/native/Source/WTF/wtf/unicode/java/UnicodeJava.h
@@ -15,21 +15,6 @@
- #define CharProp(p) java_lang_Character_##p
+ #define CharProp(p) com_sun_webkit_dom_CharacterDataImpl_##p
-#if PLATFORM(JAVA) && OS(WINDOWS)
-typedef wchar_t UChar;
diff --git a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_PlatformJava.cmake b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_PlatformJava.cmake
index f2b197047ee2..e6b2aedca78e 100644
--- a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_PlatformJava.cmake
+++ b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_WebCore_PlatformJava.cmake
@@ -1,6 +1,6 @@
---- modules/web/src/main/native/Source/WebCore/PlatformJava.cmake.orig 2017-09-08 16:56:55 UTC
+--- modules/web/src/main/native/Source/WebCore/PlatformJava.cmake.orig 2018-01-16 01:40:56 UTC
+++ modules/web/src/main/native/Source/WebCore/PlatformJava.cmake
-@@ -239,7 +239,7 @@ set(WebCore_FORWARDING_HEADERS_FILES
+@@ -242,7 +242,7 @@ set(WebCore_FORWARDING_HEADERS_FILES
set(WebCore_USER_AGENT_SCRIPTS_DEPENDENCIES ${WEBCORE_DIR}/platform/java/RenderThemeJava.cpp)
list(APPEND WebCore_LIBRARIES
diff --git a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_cmake_OptionsJava.cmake b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_cmake_OptionsJava.cmake
index 256db5291c76..a538629311f2 100644
--- a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_cmake_OptionsJava.cmake
+++ b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Source_cmake_OptionsJava.cmake
@@ -1,4 +1,4 @@
---- modules/web/src/main/native/Source/cmake/OptionsJava.cmake.orig 2017-09-08 16:56:55 UTC
+--- modules/web/src/main/native/Source/cmake/OptionsJava.cmake.orig 2018-01-16 01:40:56 UTC
+++ modules/web/src/main/native/Source/cmake/OptionsJava.cmake
@@ -52,9 +52,9 @@ elseif (APPLE)
set(CMAKE_BUILD_WITH_INSTALL_RPATH TRUE)
@@ -13,7 +13,7 @@
#### ICU-END ####
find_package(LibXml2 2.7.0 REQUIRED)
-@@ -233,8 +233,9 @@ if (CMAKE_MAJOR_VERSION LESS 3)
+@@ -191,8 +191,9 @@ if (CMAKE_MAJOR_VERSION LESS 3)
endif ()
set(ICU_INCLUDE_DIRS
diff --git a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Tools_DumpRenderTree_TestRunner.cpp b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Tools_DumpRenderTree_TestRunner.cpp
index 98c975585586..5bdfca88819f 100644
--- a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Tools_DumpRenderTree_TestRunner.cpp
+++ b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Tools_DumpRenderTree_TestRunner.cpp
@@ -1,6 +1,6 @@
---- modules/web/src/main/native/Tools/DumpRenderTree/TestRunner.cpp.orig 2017-09-08 16:56:55 UTC
+--- modules/web/src/main/native/Tools/DumpRenderTree/TestRunner.cpp.orig 2018-01-16 01:40:56 UTC
+++ modules/web/src/main/native/Tools/DumpRenderTree/TestRunner.cpp
-@@ -2410,7 +2410,7 @@ void TestRunner::runUIScript(JSContextRef context, JSS
+@@ -2400,7 +2400,7 @@ void TestRunner::runUIScript(JSContextRef context, JSS
if (!m_UIScriptContext)
m_UIScriptContext = std::make_unique<WTR::UIScriptContext>(*this);
diff --git a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Tools_DumpRenderTree_java_CMakeLists.txt b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Tools_DumpRenderTree_java_CMakeLists.txt
index c220daf08117..9c522dbe29d2 100644
--- a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Tools_DumpRenderTree_java_CMakeLists.txt
+++ b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Tools_DumpRenderTree_java_CMakeLists.txt
@@ -1,6 +1,6 @@
---- modules/web/src/main/native/Tools/DumpRenderTree/java/CMakeLists.txt.orig 2017-09-08 16:56:55 UTC
+--- modules/web/src/main/native/Tools/DumpRenderTree/java/CMakeLists.txt.orig 2018-01-16 01:40:56 UTC
+++ modules/web/src/main/native/Tools/DumpRenderTree/java/CMakeLists.txt
-@@ -89,9 +89,7 @@ add_library(DumpRenderTreeJava SHARED ${DumpRenderTree
+@@ -90,9 +90,7 @@ add_library(DumpRenderTreeJava SHARED ${DumpRenderTree
add_definitions(-DWEBCORE_EXPORT=WTF_IMPORT -DWEBCORE_TESTSUPPORT_EXPORT=WTF_IMPORT)
add_dependencies(DumpRenderTreeJava DumpRenderTreeBindings)
diff --git a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Tools_Scripts_webkitdirs.pm b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Tools_Scripts_webkitdirs.pm
index b816724242db..aefc2e8f1871 100644
--- a/java/openjfx8-devel/files/patch-modules_web_src_main_native_Tools_Scripts_webkitdirs.pm
+++ b/java/openjfx8-devel/files/patch-modules_web_src_main_native_Tools_Scripts_webkitdirs.pm
@@ -1,6 +1,6 @@
---- modules/web/src/main/native/Tools/Scripts/webkitdirs.pm.orig 2017-09-08 16:56:55 UTC
+--- modules/web/src/main/native/Tools/Scripts/webkitdirs.pm.orig 2018-01-16 01:40:56 UTC
+++ modules/web/src/main/native/Tools/Scripts/webkitdirs.pm
-@@ -1957,7 +1957,7 @@ sub generateBuildSystemFromCMakeProject
+@@ -2061,7 +2061,7 @@ sub generateBuildSystemFromCMakeProject
chdir($buildPath) or die;
# We try to be smart about when to rerun cmake, so that we can have faster incremental builds.
diff --git a/java/openjfx8-devel/pkg-plist b/java/openjfx8-devel/pkg-plist
index 9ee8b6e64bf1..4365ce044bd9 100644
--- a/java/openjfx8-devel/pkg-plist
+++ b/java/openjfx8-devel/pkg-plist
@@ -16,7 +16,7 @@
%%JAVA_HOME%%/jre/lib/%%ARCH%%/libprism_sw.so
%%JAVA_HOME%%/jre/lib/ext/jfxrt.jar
%%JAVA_HOME%%/jre/lib/javafx.properties
-%%JAVA_HOME%%/jre/lib/jfxswt.jar
+%%SWT%%%%JAVA_HOME%%/jre/lib/jfxswt.jar
%%JAVA_HOME%%/lib/ant-javafx.jar
%%JAVA_HOME%%/lib/javafx-mx.jar
%%JAVA_HOME%%/lib/packager.jar