aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2013-10-29 08:57:50 +0000
committerAlex Dupre <ale@FreeBSD.org>2013-10-29 08:57:50 +0000
commit0e86d9880f8e9fd5fa7337443445cde4d65299bc (patch)
tree2c9a104db5dd51b561d11723e7842e627d3e5f21 /java
parentfdf4386d0f4450e1188f158968a0e7eacd7f01dc (diff)
downloadports-0e86d9880f8e9fd5fa7337443445cde4d65299bc.tar.gz
ports-0e86d9880f8e9fd5fa7337443445cde4d65299bc.zip
Notes
Diffstat (limited to 'java')
-rw-r--r--java/java-getopt/Makefile35
-rw-r--r--java/java-getopt/distinfo4
-rw-r--r--java/java-getopt/pkg-descr2
3 files changed, 25 insertions, 16 deletions
diff --git a/java/java-getopt/Makefile b/java/java-getopt/Makefile
index ac4e6c1cc771..dc6f3e8dc47c 100644
--- a/java/java-getopt/Makefile
+++ b/java/java-getopt/Makefile
@@ -1,17 +1,18 @@
# Created by: ijliao
# $FreeBSD$
-PORTNAME= getopt
-PORTVERSION= 1.0.13
-PORTREVISION= 4
+PORTNAME= java-getopt
+PORTVERSION= 1.0.14
CATEGORIES= java devel
-MASTER_SITES= http://www.urbanophile.com/~arenn/hacking/getopt/
-PKGNAMEPREFIX= java-
-DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
+MASTER_SITES= http://www.urbanophile.com/arenn/hacking/getopt/
MAINTAINER= ports@FreeBSD.org
COMMENT= Java version of GNU getopt family functions
+LICENSE= GPLv2
+
+OPTIONS_DEFINE= DOCS
+
USE_JAVA= yes
USE_ANT= yes
ALL_TARGET= jar
@@ -19,26 +20,34 @@ ALL_TARGET= jar
NO_WRKSUBDIR= yes
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
-.if !defined(NOPORTDOCS)
+
+# hack to be removed when included in bsd.java.mk
+DESTDIRNAME= -Ddestdir
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
OTHERDOCS= COPYING.LIB ChangeLog README
PORTDOCS= api ${OTHERDOCS}
ALL_TARGET+= javadoc
.endif
-NO_STAGE= yes
post-extract:
@${CP} ${WRKSRC}/gnu/getopt/buildx.xml ${WRKSRC}/build.xml
do-install:
@${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
- @${INSTALL_DATA} ${WRKSRC}/build/lib/gnu.getopt.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${INSTALL_DATA} ${WRKSRC}/build/lib/gnu.getopt.jar \
+ ${STAGEDIR}/${JAVAJARDIR}/${PORTNAME}.jar
@${ECHO_MSG} " [ DONE ]"
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
- @${MKDIR} ${DOCSDIR}/api
+ @${MKDIR} ${STAGEDIR}/${DOCSDIR}/api
@cd ${WRKSRC}/build/ && ${FIND} api \
- | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
- @${INSTALL_DATA} ${OTHERDOCS:S,^,${WRKSRC}/gnu/getopt/,} ${DOCSDIR}/
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} \
+ ${STAGEDIR}/${DOCSDIR} > /dev/null 2>&1
+ @${INSTALL_DATA} ${OTHERDOCS:S,^,${WRKSRC}/gnu/getopt/,} \
+ ${STAGEDIR}/${DOCSDIR}/
@${ECHO_MSG} " [ DONE ]"
.endif
diff --git a/java/java-getopt/distinfo b/java/java-getopt/distinfo
index c5f925efc8ce..074ad13592a6 100644
--- a/java/java-getopt/distinfo
+++ b/java/java-getopt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (java-getopt-1.0.13.tar.gz) = 106edfea5056112bc88bd3691b6b145d6f50aa3e8ad0bf0b4f23fffcf2c45975
-SIZE (java-getopt-1.0.13.tar.gz) = 45759
+SHA256 (java-getopt-1.0.14.tar.gz) = ad0d5cd146d676a3ac0ef4bf6a292eb7f79d32d0cb4f202fa7e3d43dcb52d98e
+SIZE (java-getopt-1.0.14.tar.gz) = 45561
diff --git a/java/java-getopt/pkg-descr b/java/java-getopt/pkg-descr
index 3b1a5c11b7ed..dcb358aae52e 100644
--- a/java/java-getopt/pkg-descr
+++ b/java/java-getopt/pkg-descr
@@ -2,4 +2,4 @@ This is a Java port of GNU getopt, a class for parsing command line arguments
passed to programs. It is based on the C getopt() functions in glibc 2.0.6 and
should parse options in a 100% compatible manner.
-WWW: http://www.urbanophile.com/~arenn/hacking/download.html#getopt
+WWW: http://www.urbanophile.com/arenn/hacking/download.html#getopt